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Dear Mailer:

I would like to take this opportunity to introduce you to Melissa Data Corporation. We 
specialize in direct marketing software, list enhancement services, and mailing lists. Since 
1985 we have been helping mail order companies, direct marketers, mailing list brokers, 
and other businesses and professionals cut the high costs associated with mailings, 
improve their customer service, and streamline their database management.

Melissa Data Corporation began by marketing demographic, nutrition, financial, and ZIP 
Code databases for the PC environment. Responding to customer demand, our company 
has focused on direct marketing software since 1989. Since the introduction of 
MAILERS+4, we have continued to expand into an even broader market. MAILERS+4 
allows businesses of all sizes to access and use information previously available only on 
mainframe computers.   

Although MAILERS+4 is a powerful and effective mail automation tool, many of you enjoy 
the convenience of processing your lists through our Data Enhancement Services. You can 
easily access these through the Services menu in MAILERS+4.

Melissa Data products are designed to reduce your postage and printing expenses by up to 
65 percent. Whether you send 500 pieces of mail or have a bustling mail room, the 
products and services of Melissa Data Corporation will save you time and money. We 
provide one-stop-shopping for all your direct marketing and bulk mailing needs.

Your feedback is always important to me. Please don’t hesitate to e-mail your comments or 
suggestions to ray@MelissaData.com. I look forward to hearing from you.

Best Wishes,

Raymond F. Melissa

President





i

Contents

Chapter 1: Introduction .............................................................1
Add-On Options .......................................................................................................... 2
List Services ................................................................................................................ 2
USPS® Compliance ................................................................................................... 2

CASS™ Certification (Form 3553) ..................................................................... 2
PAVE Certification .............................................................................................. 3
Updates ................................................................................................................ 3

Program Features ...................................................................................................... 3
Address Check .................................................................................................... 3
Duplicate Check .................................................................................................. 4
Presort .................................................................................................................. 4
Label Printing ...................................................................................................... 4
Reports ................................................................................................................. 4
Adding Data to Your List .................................................................................... 5
Tally ....................................................................................................................... 5
Database Management ...................................................................................... 5
Data Entry ............................................................................................................ 5
Mail Merge+ ........................................................................................................ 5
Services ................................................................................................................ 5

System Requirements ............................................................................................... 6
Chapter 2: Installing MAILERS+4 .............................................7

Regular Installation ............................................................................................ 7
Server Installation ............................................................................................... 8



MAILERS+4  Use r ’ s  Gu ide
Con ten t s

ii

Running MAILERS+4 ................................................................................................ 9
Uninstalling MAILERS+4 ......................................................................................... 9
Installing Canadian Addresser ................................................................................. 9

Downloading the Canadian Data Files ............................................................ 9
Chapter 3: Starting MAILERS+4 .............................................11

The MAILERS+4 Sidebar ....................................................................................... 12
Chapter 4: Opening a Mailing List ...........................................15

Opening Your Mailing List ...................................................................................... 15
Browsing Records .................................................................................................... 17

Editing Field Data .............................................................................................. 18
Cutting and Copying Field Data ..................................................................... 18
Marking and Unmarking Records for Deletion ............................................ 19

Filtering Records ...................................................................................................... 19
Filter Status ........................................................................................................ 20
Filter Operators ................................................................................................. 20
Filter Examples .................................................................................................. 21

Formatting Your List ................................................................................................ 22
Exporting Your File ................................................................................................... 22
Having Trouble? ....................................................................................................... 22

Chapter 5: Formatting Lists ....................................................23
Formatting a List ...................................................................................................... 23
Formatting dBase Lists ........................................................................................... 24

Using Auto Format ............................................................................................ 24
Identifying Field Names for Auto Format ...................................................... 25
Copying List Formats ........................................................................................ 26
Formatting Fields .............................................................................................. 27

Formatting ASCII Fixed-Length Lists .................................................................... 28
Chapter 6: Setting Options .....................................................29

List Options ............................................................................................................... 29
System Options ........................................................................................................ 30

Directories Tab .................................................................................................. 30
User Information Tab ....................................................................................... 33
Program Options Tab ....................................................................................... 33

Data Entry Options ................................................................................................... 36
Backing up System Options ................................................................................... 36

Chapter 7: Checking Addresses ..............................................37
When to Use Address Check .................................................................................. 37
CASS Certification (Form 3553) ............................................................................. 38



MAILERS+4  Use r ’ s  Gu ide
Contents

iii

Database Expiration ......................................................................................... 38
DPV — Verifying Delivery Addresses ................................................................... 38
LACSLink — 911 Address Conversion .................................................................... 39
SuiteLink — Append Secondary Addresses .......................................................... 39
AddressPlus .............................................................................................................. 39
Running Address Check ......................................................................................... 40
Formatting Fields for Address Check ................................................................... 42

Required Fields ................................................................................................. 43
Recommended Fields ....................................................................................... 43
Optional Fields .................................................................................................. 44
Optional Fields (Advanced Formatting) ........................................................ 45

Address Parsing ....................................................................................................... 47
Parsing a Delivery Address ............................................................................. 48
Combining Separate Address Fields ............................................................. 48
Parsing a City/State/ZIP Field ......................................................................... 49
Combining City, State, and ZIP Fields ........................................................... 49
Formatting Records with Two Address Lines ............................................... 49
Swapping Address Fields ................................................................................ 50

Address Check Results ........................................................................................... 50
Split List ............................................................................................................. 51

Resolving Address Errors ....................................................................................... 52
Resolving Address Errors Outside MAILERS+4 ................................................. 55

Chapter 8: Checking for Duplicates .........................................57
When to Use Duplicate Check ............................................................................... 57
Running Duplicate Check ....................................................................................... 58
Multiple Lists ............................................................................................................ 60
Formatting Fields for Duplicate Check ................................................................. 61

Required Fields ................................................................................................. 61
Recommended (Optional) Fields .................................................................... 62

Duplicate Check Results ........................................................................................ 62
Viewing Duplicate Records .................................................................................... 63

Tagging/Untagging Duplicate Records ......................................................... 63
Deleting Duplicate dBase Records ................................................................ 63

Chapter 9: Presorting a List ....................................................65
Overview of Presorting ............................................................................................ 65
When to Presort Mail ............................................................................................... 65
Which Type of Presort to Use ................................................................................. 66
Formatting Fields for Presort ................................................................................. 66



MAILERS+4  Use r ’ s  Gu ide
Con ten t s

iv

Required Basic Fields ...................................................................................... 68
Required ECR Fields (Automation and Non-automation) .......................... 68
Recommended Fields ....................................................................................... 68

Additional Presort Fields ........................................................................................ 69
Automation vs. Non-automation ............................................................................ 70

Automation ........................................................................................................ 70
Non-automation ................................................................................................ 70

Presort Mailing Wizard ............................................................................................ 71
Selecting a Template ........................................................................................ 71
Presort Settings ................................................................................................ 72
Postage Statement Information ..................................................................... 74
Periodicals ......................................................................................................... 75

Preparing a Presorted Mailing ............................................................................... 76
ACS Options ...................................................................................................... 77
Mail.dat Options ................................................................................................ 78
Destinations (SCF/NDC/DDU) ........................................................................ 79
Customized Options ......................................................................................... 81

Mailing Results ........................................................................................................ 85
Presort Reports ........................................................................................................ 85

Viewing, Printing, and Saving Reports .......................................................... 85
Exporting Lists in Presorted Order ........................................................................ 87
Backing up Presort Templates .............................................................................. 87

Chapter 10: Printing Labels ....................................................89
When to Use Print Labels ....................................................................................... 89
Printing Labels ......................................................................................................... 89

Form Tab ............................................................................................................ 90
Template Tab ..................................................................................................... 93
Sequence Tab .................................................................................................... 95
Presort Options Tab .......................................................................................... 97
Print To Tab ....................................................................................................... 99
Summary Tab .................................................................................................. 100

Backing up Label Templates ................................................................................ 102
Chapter 11: Reports .............................................................103

USPS Required Reports ....................................................................................... 103
CASS (3553) ..................................................................................................... 104
USPS Qualification Report ............................................................................ 105
Postage Statement (3602) .............................................................................. 106

Additional MAILERS+4 Reports .......................................................................... 107



MAILERS+4  Use r ’ s  Gu ide
Contents

v

Error Preview Report ...................................................................................... 107
Duplicate Check Results Report .................................................................. 108
Presort Result Reports ................................................................................... 108
Phone Check Results ..................................................................................... 111

Chapter 12: Phone Check .....................................................113
When to use Phone Check ................................................................................... 114
Running Phone Check .......................................................................................... 114
Formatting Fields for Phone Check ..................................................................... 116

Required Fields ............................................................................................... 116
Recommended Fields ..................................................................................... 116
Optional Fields ................................................................................................ 116

Phone Check Results ............................................................................................ 117
Chapter 13: Name Parse .......................................................119

When to Use Name Parse ..................................................................................... 119
Using Name Parse ................................................................................................. 120
Formatting Fields for Name Parse ...................................................................... 121

Required Fields ............................................................................................... 121
Optional Fields ................................................................................................ 122

Name Parse Results .............................................................................................. 122
Name Parsing Results ................................................................................... 122
Gender Count ................................................................................................... 122

Chapter 14: Tally ..................................................................123
When to Use Tally .................................................................................................. 123
Using Tally .............................................................................................................. 123
Tally Reports ........................................................................................................... 124

Chapter 15: ZIPs/Records in Radius ......................................127
When to Use ZIPs/Records in Radius ................................................................. 127
ZIPs in Radius ........................................................................................................ 128
Records in Radius .................................................................................................. 130

Chapter 16: Adding Data to your List .....................................133
Adding Fields to a List ........................................................................................... 134

Chapter 17: Database Management ......................................137
Creating a New List Structure .............................................................................. 137

Defining Fields in a New List ........................................................................ 138
Creating a New List with QuickList .............................................................. 139

Modifying an Existing List .................................................................................... 140
Editing Field Names, Field Types, and Field Lengths ................................ 140

Copying a List Structure ....................................................................................... 140



MAILERS+4  Use r ’ s  Gu ide
Con ten t s

vi

Importing Data to a List ........................................................................................ 141
Exporting Data from a List .................................................................................... 144
Deleting Records .................................................................................................... 145
Recalling Records .................................................................................................. 146
Packing Records .................................................................................................... 146
Append .................................................................................................................... 147

Chapter 18: Data Entry .........................................................149
Creating a New List Layout ................................................................................... 149
Designing Your Data Entry Layout ...................................................................... 149

Designing the Data Entry Screen ................................................................. 149
Backing up Data Entry Templates ....................................................................... 155

Chapter 19: Exporting Street Data ........................................157
Exporting Street Data to a File ............................................................................. 157

Viewing the File ............................................................................................... 158
Chapter 20: Mail Merge+ .....................................................161

Creating a New Document ................................................................................... 161
Using Existing Content in a New Document .............................................. 161
Creating Content for a New Document ....................................................... 162
Working with Existing Documents ............................................................... 162

Inserting Data into Documents ............................................................................ 163
Data Types and their Uses ............................................................................. 163

Formatting a Document ........................................................................................ 166
Applying Fonts ................................................................................................ 166
Adding Bullets ................................................................................................. 167
Formatting Paragraphs .................................................................................. 167
Setting Tabs ..................................................................................................... 168
Choosing a Background Screen Color ........................................................ 169

Editing a Document ............................................................................................... 170
Selecting Text and Objects ............................................................................ 170
Reversing Formatting Changes .................................................................... 171

Spell Checking a Document ................................................................................. 171
Printing Documents in Mail Merge+ .................................................................. 172

Choosing a Database ..................................................................................... 172
Setting Up a Print Job .................................................................................... 173
Setting Up Page Parameters ......................................................................... 176
Viewing and Printing Your Document ......................................................... 176

Chapter 21: Scripting ...........................................................179
Overview of Scripting ............................................................................................ 179



MAILERS+4  Use r ’ s  Gu ide
Contents

vii

Running Files in Batch Mode ............................................................................... 180
Running a Single File ..................................................................................... 180
Running Multiple Files ................................................................................... 181

Setting Batch Mode Options ................................................................................ 181
Address Check Options ................................................................................. 181
Presort Options ............................................................................................... 182

Chapter 22: GeoCoder ..........................................................183
Installing GeoCoder ............................................................................................... 184
Running GeoCoder ................................................................................................ 184
GeoCoder Options .................................................................................................. 185
Formatting GeoCoder Fields ................................................................................ 186

GeoCoder Fields .............................................................................................. 187
Chapter 23: Real Time SmartMover .......................................189

Prepaid NCOALink .............................................................................................................................189

Submitting Your Database ................................................................................... 189
Retrieving Your Processed File ............................................................................ 193

Appendix A: MAILERS+4 Fields ............................................197
Address Check ....................................................................................................... 197

Advanced Address Check .............................................................................. 198
Duplicate Check  .................................................................................................... 200
Name Parse  ........................................................................................................... 201
Phone Check  .......................................................................................................... 201
Presort  .................................................................................................................... 202

Advanced Presort ............................................................................................ 202
Other Field Types ................................................................................................... 203

Records in Radius  .......................................................................................... 203
General Fields .................................................................................................. 203
Optional Fields ................................................................................................ 204

MAILERS+4 Professional Fields ......................................................................... 204
Appendix B: Error/Information Codes .....................................207

Result Codes ........................................................................................................... 207
Address Check Result Codes ........................................................................ 207
GeoCoder Result Codes ................................................................................. 211

General Error Codes ............................................................................................... 212
Address Check ................................................................................................ 212
Duplicate Check .............................................................................................. 212
Name Parse ..................................................................................................... 212
Phone Check ................................................................................................... 213



MAILERS+4  Use r ’ s  Gu ide
Con ten t s

viii

Presort .............................................................................................................. 213
Records in Radius ........................................................................................... 213

Address Check Error Codes .................................................................................. 214
DPV Footnotes ........................................................................................................ 215
LACSLink Return Codes ......................................................................................... 215
SuiteLink Return Codes .......................................................................................... 216
Duplicate Check Error Codes ............................................................................... 216
Name Parse Error Codes ....................................................................................... 216
Phone Check Error Codes ..................................................................................... 217
Presort Error Codes ............................................................................................... 217
Records in Radius Error Codes ............................................................................ 218
Information Codes ................................................................................................. 218

Return Codes ................................................................................................... 218
Presort Mail Job Codes .................................................................................. 221
Presort Package Sortation Level .................................................................. 222
Presort Container Sortation Level ................................................................ 222
Presort Rate Code ........................................................................................... 223
Presort Destination Code .............................................................................. 223
Move Type ........................................................................................................ 224
 ........................................................................................................................... 224

Appendix C: Calculating Distances ........................................225
Distance Calculation ............................................................................................. 225

Approximate Solutions .................................................................................. 225
Exact Solution .................................................................................................. 226
Bearing Formula ............................................................................................. 227

Appendix D: Street Suffixes ..................................................229
Appendix E: Technical Support & Troubleshooting .................231

Memory and MAILERS+4 ..................................................................................... 231
Windows System Resources ......................................................................... 231
Total System Memory .................................................................................... 231

GPF Messages ........................................................................................................ 231
What to Do When You Receive a GPF Error ................................................ 232

Optimizing for Speed ............................................................................................. 232
Transferring Data to the Hard Drive ............................................................. 232
Zip Sorting ....................................................................................................... 233

Technical Support .................................................................................................. 233
Contacting Technical Support ...................................................................... 233

Troubleshooting ..................................................................................................... 234



MAILERS+4  Use r ’ s  Gu ide
Contents

ix

Common Data File Questions ....................................................................... 234
Field Formatting Questions ........................................................................... 235
Presorting Questions ..................................................................................... 236
Label Printing Questions ............................................................................... 237

Appendix F: Address Type Percentages .................................239
National Address Type Percentages ................................................................... 239
Address Type Percentages by State ................................................................... 239

Index ....................................................................................243



MAILERS+4  Use r ’ s  Gu ide
Con ten t s

x



1

Introduction
Thank you for purchasing MAILERS+4!

This easy-to-use desktop program is designed to help you 
prepare a mailing for maximum postal discounts and effi-
cient postal processing and delivery. Whether you are mail-
ing First-Class Mail®, Standard Mail™, or Periodical Mail, 
you will be able to move quickly and smoothly through the 
program using the friendly interface.

MAILERS+4 takes the guesswork out of every step 
required to prepare a discounted mailing for the U. S. 
Postal Service®, from verifying and standardizing 
addresses, eliminating duplicates, and presorting for the 
lowest postage rates, to printing out your labels, tags, and 
postal forms.

This powerful program includes all the tools you need to 
automate efficient mail operations for the greatest direct-
mail savings. It also provides unique, built-in direct market-
ing and data management tools that enable you to increase 
your response rates and maximize your return on invest-
ment.

You can also benefit from the included ListWare software 
that automatically submits your file directly to Melissa Data 
for a variety of Data Enhancement Services. You’ll find data 
enhancement processing available at your fingertips for 
NCOALink™, phone and address append, Standard Indus-
trial Classification (SIC) append, walk sequence append, 
and more.

Melissa Data Corporation has been serving direct mail pro-
fessionals since 1985. We are confident you will find MAIL-
ERS+4 an indispensable tool for achieving the highest level 
of data quality for your contact information, reducing your 
postage and production costs, and maintaining an efficient, 

In this chapter...

Add-On Options ........................................ 2

List Services .............................................. 2

USPS® Compliance................................. 2

Program Features ..................................... 3

System Requirements .............................. 6
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productive database for optimum delivery and response rates. We welcome you to the Melissa 
Data family.

ADD-ON OPTIONS
The following optional add-ons are available for use with MAILERS+4 to help you meet your 
direct mailing and data management goals:

• Canadian Addresser — Verify the Canadian addresses in your mailing lists and print out
labels standardized to Canada Post requirements.

• GeoCoder — GeoCoder enhances your marketing efforts by appending more accurate
Latitude & Longitude Coordinates, Census Tract, Block Numbers, FIPS Codes, and County
Names to the records in your mailing list.

• RBDI — RBDI is a data quality solution that helps shippers minimize parcel shipping costs
by verifying the address delivery type as either business or residential. RBDI is also valu-
able to real estate and property management agencies by identifying a property type when
only the address is available.

LIST SERVICES
Melissa Data can assist you in finding leads for direct marketing purposes, regardless of if your 
target market is business or residential. Simply specify the type of businesses and/or neighbor-
hoods you would like to saturate, and we’ll provide you with a perfect list. You can order lists 
online directly from within the MAILERS+4 software using the Internet menu or by going to 
http://www.MelissaData.com/lists.html.

USPS® COMPLIANCE

CASS™ Certification (Form 3553)
CASS (The USPS Certification Process for ZIP + 4 Matching Software) was developed by the 
USPS to ensure the accuracy of ZIP + 4®, 5-digit ZIP, and Carrier Route codes on mail pieces. 
It provides a common system for measuring the quality of address matching and code assign-
ment. In order to qualify for USPS automation discounts, your mailing lists must be processed 
with software that is CASS Certified™. In addition, the data used to process the mailing must be 
current, and the mailing must be accompanied by Form 3553 (or a USPS approved facsimile). 
MAILERS+4 provides you with all of these requirements. CASS Certification denotes the follow-
ing:

• The MAILERS+4 Address Check feature meets USPS requirements.

http://www.melissadata.com/lists.html
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• All information in the database is updated bimonthly to include the latest USPS data.

• All the information required for CASS Certification is captured during list processing. Print-
ing a legal facsimile of the form is a standard option of the program.

PAVE Certification
PAVE™ is a USPS program for measuring presort accuracy. MAILERS+4 is PAVE Gold certified 
by the USPS. The PAVE program is used by the USPS to evaluate and validate presort software 
products developed by software and hardware developers. For more information on our PAVE 
certification, go to http://www.MelissaData.com/pave.htm.

Updates
MAILERS+4 is updated six times a year with new ZIP Code™ data provided by the USPS. 
These updates are important because the USPS requires that ZIP + 4, ZIP + 4 barcodes and 
Carrier Route codes are updated on a regular basis with software that includes current USPS 
address and ZIP Code data. Check with your local Post Office or the latest DMM® for the cur-
rent USPS requirements. 

Due to USPS licensing regulations, MAILERS+4 will disable the appending of +4 data and dis-
play a warning before printing CASS Certification forms approximately 105 days after the initial 
MAILERS+4 distribution date (three months beyond this distribution date and extending to the 
end of the third month). You will not be able to add +4 codes to a mailing list after the expiration 
period is reached. However, MAILERS+4 will still allow you to check your list, correct and stan-
dardize street names, correct the 5-digit ZIP Codes, and add Carrier Routes, for another year. 
The About MAILERS+4 screen (accessible from the Help menu) displays the expiration date 
and the number of days until expiration.

MAILERS+4 also automatically checks for program updates when the programs starts. If a new 
update is detected, MAILERS+4 will display a message box giving you the option of download-
ing and applying the update before continuing. You can disable the automatic updates in the 
System Options. See Program Options Tab on page 33 for more information.

PROGRAM FEATURES
Following are just some of the features that are included in your MAILERS+4 software.

Address Check
Address Check verifies addresses using data contained in the National, Canadian (with the 
Canadian Addresser add-on), and/or Regional data files. 

• DPV — Using DPV date, MAILERS+4 will verify addresses down to the suite level.

http://www.melissadata.com/pave.htm
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• LACSLink — Addresses that have undergone Rural Route conversion will be updated to the
standard street-style addresses.

• SuiteLink — MAILERS+4 will also append suite information to business addresses when
these are found in the SuiteLink database.

• AddressPlus — With AddressPlus, MAILERS+4 goes beyond SuiteLink by appending
missing secondary address information to millions of business and residential addresses.

• eLOT — Use eLOT to prepare Enhanced Carrier Route Basic, Standard, and Periodicals
mailings. You can sort Enhanced Carrier Route mailings to closely match the actual deliv-
ery sequence and qualify for Enhanced Carrier Route Presort discounts.

Once an address is verified, Address Check can standardize it to USPS and/or Canadian 
requirements and append up-to-date information, such as ZIP + 4, Carrier Route, and Delivery 
Point codes.

Duplicate Check
MAILERS+4 can save you money on printing and postage by eliminating duplicate records in 
your list. Duplicate Check can locate records with duplicate names and addresses, determine if 
you are mailing to more than one person at the same address, and even match sound-a-likes, 
nicknames, initials and abbreviations. You can also check for duplicates by phone number, or 
name and phone number combinations.

Presort
Presorting is a procedure that allows the USPS to work faster and more efficiently. When you 
presort your mail, you are eliminating the need for the Post Office™ to do so. The savings to the 
Post Office in labor and resources are passed back to you, the mailer, in the form of lower post-
age rates for presorted mail.

Label Printing
You can print mailing labels, envelopes, and container tags directly from MAILERS+4. This fea-
ture lets you design your own label layout using fields from your mailing list. You can also add 
additional text, which will appear on all your labels (for example, an ad, reminder, and so on). 
When finished, you can save the label layout for future mailings. This feature also allows you to 
select the order in which to print the labels. You can print labels in record, presort, or ZIP Code 
order. In addition, Separator Label options are available when printing in presort order, allowing 
you to choose how MAILERS+4 will indicate a change in container numbers.

Reports
The report generator in MAILERS+4 not only helps you create documentation required by the 
USPS when you submit automated and presorted mailings, it also provides additional reports to 
help you with marketing decisions and list acquisition.
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Adding Data to Your List
MAILERS+4 can add valuable data to your list. This data can save you money on postage, 
speed mail delivery, and provide valuable demographic and marketing information. See Adding 
Fields to a List on page 134 to view the information MAILERS+4 can add to your list.

Tally
The Tally feature counts the number of records in your mailing list by ZIP Code, County, Sec-
tional Center Facility (SCF), Carrier Route (CRRT), State, and/or Network Distribution Center 
(NDC). Once a count is made, Tally calculates the percentage of each, sorts the results in 
descending order, and outputs a record count results report with a summary line at the bottom. 
This can help you decide which presort discounts you may qualify for. You can view the Tally 
report online, print it out, or save it as a text file. 

Database Management
The Database Manager lets you perform common database management tasks within MAIL-
ERS+4. It works with mailing lists in dBase format to create new mailing list structures, modify 
fields in your list, copy list structures, import/export data, delete/recall or pack out records, and 
browse and edit records in your list. The Filter option allows you to set up criteria with which to 
include or exclude records during database management tasks.

Data Entry
You can add new records to existing lists using the Data Entry feature in MAILERS+4. This fea-
ture allows you to create a list layout and design the data entry screen that will be used for input-
ting your data. The Data Entry feature can also check the accuracy of the data as it is entered.

Mail Merge+ 
With Mail Merge+, you can give your mailings that personal touch by adding mailing list field 
data, logos, date fields, and signatures to your mailing correspondence. It also enables you to 
create and insert graphics using your existing graphics applications.

Services
MAILERS+4 includes a copy of Melissa Data’s free ListWare software for sending your mailing 
lists to our Data Enhancement Services division. Simply select the service you want from the 
Services menu in MAILERS+4, and the program will close your file and load it into ListWare at 
the correct order screen.

For detailed information on using ListWare to prepare and send your lists to Melissa Data, see 
the ListWare help page at http://www.melissadata.com/lw/help/lwHelp.htm or simply press 
the F1 key after starting ListWare.
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SYSTEM REQUIREMENTS
MAILERS+4 and most of its add-ons come on a single DVD-ROM. Canadian Addresser is 
downloaded separately.

MAILERS+4 requires the following system configuration:

®• Microsoft  Windows 7® or newer

• Minimum 3.9 gigabytes of free hard disk space

• Minimum 256 megabytes of RAM

• DVD-ROM  drive

If you have purchased additional options you will need the following additional free hard disk 
space:

• Canadian Addresser: 200 megabytes.

• GeoCoder: 500 megabytes.

• RBDI: 400 megabytes.
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Installing MAILERS+4
Your MAILERS+4 package contains one DVD-ROM. 

The DVD contains the program and data files for MAIL-
ERS+4, along with an electronic User’s Guide. During the 
installation process, MAILERS+4 is copied to your hard 
drive. Before installation, check your computer and find out 
what resources you have free. 

When purchasing MAILERS+4, you have the following ver-
sions to choose from:

• Regular (Standard or Professional) — The regular
version is installed on a single workstation.

• Server (Professional) — The server version is first
installed onto a server, then onto workstations con-
nected to the server.

Regular Installation
1. Make sure all software programs are closed. This

includes disabling all anti-virus programs as they
can cause the install to fail to register critical dll's
that Mailers+4 needs to run.

2. Place the MAILERS+4 DVD in your DVD-ROM
drive.

3. Click the Start button and select Run from the
pop-up menu. The Run dialog box opens.

4. Type your DVD drive letter followed by
:\SETUP.EXE in the Command Line box. (e.g.,
D:\SETUP.EXE). After typing the path, click OK.

5. Follow the on-screen instructions to complete the
installation. The following fields must be com-
pleted:

In this chapter...

The DVD contains the program and data 
files for MAILERS+4, along with an elec-
tronic User’s Guide. During the installa-
tion process, MAILERS+4 is copied to 
your hard drive. Before installation, check 
your computer and find out what 
resources you have free. .......................... 7

Running MAILERS+4............................... 9

Uninstalling MAILERS+4 ........................ 9

Installing Canadian Addresser ................ 9
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• Welcome — Click Next to continue with the installation, or Cancel to exit.

• License Agreement — Your single-user License Agreement will display
before any part of the program is installed. Click Yes if you accept all the
terms of this agreement, or No if you do not. To proceed with the MAILERS+4
installation, you must accept this agreement.

• Licensing Information — Use this screen to enter the license code for the
RBDI add-on feature you have purchased with MAILERS+4. To add this
feature, enter the license code in the box and click Add. The RBDI will be
added to the list of features to be installed.

• Choose Destination Location — Type the drive and directory where you
wish to copy the MAILERS+4 files. For new users, the default directory is
C:\Program Files\Melissa Data\MAILERS+4. For existing users, the default
directory is the directory to which MAILERS+4 was previously installed. Click
Browse to choose a different directory or Next to accept the directory shown.

• Select Start Menu Folder — Choose the program folder to which you would
like to add MAILERS+4 program icons. To create a new folder, enter a name
for the folder in the Program Folders field.

• Select Addional Task — Choose if you would like to have a shortcut to
Mailers+4 created on your desktop.

• Ready To Install — This confirms the destination location, the start menu
folder, and if you want a desktop shortcut to Mailers+4.

6. MAILERS+4 will begin installation. After you have completed the installation process,
reboot your computer before running MAILERS+4.

Server Installation
If you purchased the server version of MAILERS+4, you have the option of installing it to a net-
work. Begin with a server installation to the network drive and finish at each work station with a 
small install off the server. This will allow MAILERS+4 to run smoothly by registering the 
required dll’s on the client computer.

If you want to keep the old Mp4auto.ini file, move it out of the Mailers folder before installing 
the new version.

When repeating an installation or updating the program, MAILERS+4 will remember the directory 
of your previous installation.
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RUNNING MAILERS+4
To run MAILERS+4, click the Start button, and then point to Programs. Point to the MAILERS 
folder, and then click MAILERS+4.

UNINSTALLING MAILERS+4
To remove MAILERS+4 from your computer, click the Start button, point to Settings, and then 
click Control Panel. When the Control Panel opens, double-click the Add/Remove Programs 
icon, and then select MAILERS+4. Click the Change or Remove icon to finish the uninstall pro-
cess.

INSTALLING CANADIAN ADDRESSER
Before you can use MAILERS+4 to verify Canadian addresses, you need to purchase a sub-
scription for the Canadian Addresser Add-on. Call 1-800-MELISSA to speak to your sales rep-
resentative.

After you have purchased the add-on subscription, you will be a issued a customer number that 
you will use to activate the Canadian Addresser and download the data files.

Downloading the Canadian Data Files
The Canadian Addresser data files are updated monthly. If you attempt to verify Canadian 
address with an expired database, MAILERS+4 will alert you to download the updated files.

1. Open your database.

2. Click the List menu and select Canadian Addresser Add-On.
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3. MAILERS+4 displays the Canadian Addresser dialog.

4. If this is the first time downloading the Canadian Addresser file, you will need to enter
your User Id. Your user id can be found on your invoice, on the sticker on you Mail-
ers+4 disk, or you can call your sales reperensantive for the number.MAILERS+4 will
remember this information for subsequent downloads.

5. Click Download.

6. MAILERS+4 will download and install the most recent Canadian data files.
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Starting MAILERS+4
To open MAILERS+4:

1. Click the Start button.

2. Click All Programs.

3. Select the MAILERS folder and click
MAILERS+4.

MAILERS+4 has a new, streamlined interface that makes it 
easier to access all of the features in the program.

Upon opening, MAILERS+4 presents with a splash screen 
showing links to helpful areas on the Melissa Data website.

MAILERS+4 Splash Screen

For more information on opening files in MAILERS+4, see 
the next chapter, starting on page 15.

In this chapter...

The MAILERS+4 Sidebar ....................... 12
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When a database file is open, MAILERS+4 enables the sidebar, a vertical row of buttons down 
the left side of the MAILERS+4 screen. Use these buttons to access the major features of the 
program.

THE MAILERS+4 SIDEBAR
Use these buttons to access the following features of MAILERS+4.

The Open File button displays a standard Windows open 
file dialog to open a new database or a previously saved 
MAILERS+4 setup. When no file is open, this is the only 
button available. See chapter 4, Opening a Mailing List, 
on page 15 for more information.

The Format button displays the format screen, which 
allows you to match field names in your mailing list to data 
types in MAILERS+4. See chapter 5, Formatting Lists, on 
page 23 for more information.

Address Check displays the options for verifying the 
addresses in your mailing list and appending ZIP + 4® 
information using MAILERS+4’s CASS CertifiedTM 
technology. See chapter 7, Checking Addresses, on 
page 37 for more information.

Duplicate Check displays the options for flagging and 
removing redundant records in your mailing list. See 
chapter 8, Checking for Duplicates, on page 57 for more 
information.

Presort displays the options for selecting the right 
sortation method for your mailing list to securing the best 
possible postage rates. See chapter 9, Presorting a List, 
on page 65 for more information.

Print Labels generates mailing labels from your verified, 
de-duped and presorted mailing list. You have the option of 
using either POSTNET barcodes or the new Intelligent 
Mail® barcodes. See chapter 10, Printing Labels, on 
page 89 for more information.

SmartMover uploads your database for real-time 
NCOALink® processing.See chapter 23, SmartMover™, 
on page 185 for more information.

Name Parse splits full names into their first, middle and 
last names, along with prefixes and suffixes. It can also 
determine gender for many first names. See chapter 13, 
Name Parse, on page 119 for more information.
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Phone Check can verify that the exchange portion of a 
phone number is a valid one for the area code and that the 
area code is actually located in the associated ZIP Code™. 
If the area code has changed due to a recent area code 
split, MAILERS+4 can provide the updated information. 
See chapter 12, Phone Check, on page 113 for more 
information.

GeoCoder provides geographic data (longitude and 
latitude) and census information based on a valid ZIP + 4. 
See chapter 22, GeoCoder, on page 183 for more 
information.

Quick Tools provides access to four of MAILERS+4 useful 
tools.

• Tally counts the number of records in your mailing
list by Carrier Route, ZIP Code, County, Sectional 
Center Facility (SCF), State, and/or Network 
Distribution Center (NDC). See chapter 14, Tally, 
on page 123 for more information.

• Records in Radius tells you how many records in
your mailing list are located within a given range
from a central ZIP Code. See chapter 15,
ZIPs/Records in Radius, on page 127 for more
information.

• Export Street Address outputs the contents of
the MAILERS+4 street data file in dBase, fixed-
length (text), or comma-delimited format.

• ZIPs in Radius will report all the ZIP Codes
located within a user-defined radius of a given ZIP
Code. See chapter 15, ZIPs/Records in Radius,
on page 127 for more information.
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Opening a Mailing List
MAILERS+4 works with the following file types: 

• dBase (.dbf)

• Fixed-length (.txt)

• Comma-delimited (.csv)

• Microsoft Access (.mdb)

• Microsoft Excel (.xls)

MAILERS+4 has the ability to open mailing lists with vari-
ous file formats. If your list is in a comma-delimited format, 
MAILERS+4 will prompt you to convert it to a dBase file. 
When you finish with MAILERS+4, your comma-delimited 
list can be restored to its original format using the Export 
feature. If your database program uses a different format 
than these file types, you will need to export your list as an 
ASCII or dBase file. Check your software package’s man-
ual for instructions.

OPENING YOUR MAILING LIST
1. Start MAILERS+4.

2. There are multiple ways to open a file in MAIL-
ERS+4.

• Click the Open File
button at the top of the
sidebar on the left side of
the MAILERS+4 screen.

In this chapter...

Opening Your Mailing List...................... 15

Browsing Records .................................. 17

Filtering Records..................................... 19

Formatting Your List................................ 22

Exporting Your File .................................. 22

Having Trouble?....................................... 22
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• If you have worked with MAILERS+4 before, a list of recently opened files is dis-
played at the bottom of the File menu. Select a file name with your mouse to open
it.

• To open a new file or one not found at the bottom of the File menu, choose Open.
The Open File dialog box opens. Locate or type the name of the file you wish to
open. For more information, consult your Microsoft Windows documentation.

• Previously opened files also have an MS4 file name which can be double-clicked
in Windows Explorer to open MAILERS+4 and load the file.

3. If your file is in comma-delimited format, the program will ask if you want to convert it to
dBase. Click Yes to perform the conversion and load your list, or No to cancel and
leave the file in its original format.

4. MAILERS+4 opens the selected file in the browse window, which displays the fields in
your records in spreadsheet format, allowing you to view a number of records at once.
The name of your list appears in a colored header at the top of the MAILERS+4
screen.

MAILERS+4 with an open database in Browse mode

5. When you finish with a list, click Close to exit the active list
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BROWSING RECORDS
When a file is open in MAILERS+4, you can view and edit records using the Browse controls. 
You can use your mouse or arrow keys to move between fields in the Browse screen. Fields in 
the browse window can be resized by moving your cursor over a field border (in the title bar) and 
dragging it to the desired size when your cursor changes to the resize symbol.

• Go To — The Go To button moves you to a chosen record, which can be useful with
long lists. Once you have clicked Go To, you will be asked to enter the row number you
want to go to. Row numbers appear to the left of records in the Browse screen. The
default Go To number will be the last record in your list.

• Find and Find Next — The Find button opens the Search Text dialog box. This dialog
box can be configured to search any field in your list for a desired text entry. Simply
type the text for your search in the Text to Find field. In the Field(s) to Search box,
select the desired search fields. Use the Start From, Search for field that, and
Options boxes to specify the remaining parameters of your search. Click Find to begin
your search or Cancel to abort and return to the Browse screen. If you click Find, the
first field containing your search text will be highlighted in the Browse screen. To con-
tinue searching, click Find Next.

Find and Find Next only work on fields that have been formatted using the Format
screen. See Formatting Lists on page 23.

The Search Text dialog box

You can configure MAILERS+4 to automatically opening Format screen upon opening 
a new data file and even automatically format common fields. See System Options on 
page 30.
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Editing Field Data
By default, the database is locked when it is opened in MAILERS+4, meaning that records can-
not be altered from the Browse screen. To modify field data, click the Unlock button.

1. In the Browse screen, move the cursor to the field you want to edit.

2. Type in the new data. The contents of the field will be cleared when you begin typing. 
Press ESC to restore the original contents if you have not moved to another field.

3. When you are finished editing, use the mouse or keyboard arrow buttons to move to 
another field. 

Cutting and Copying Field Data
You can easily cut and copy field data in MAILERS+4. Press CTRL+Z to undo a cut, copy, or 
paste. Data will be cut off if you copy it into a field that is too short.

Copying Entire Records
1. Select the row number of the record you want to copy by clicking on it with your left 

mouse button.

2. Press CTRL+C to copy.

3. Select the row number of the record you want to replace by clicking on it with your left 
mouse button.

4. Press CTRL+V to paste.

Cutting and Pasting Individual Cells
1. Select the cell you want to cut by clicking and dragging across it while holding down 

your left mouse button.

2. Press CTRL+X to cut.

3. Select the cell you want to replace by clicking and dragging across it while holding 
down your left mouse button.

4. Press CTRL+V to paste.

Copying Data between Cells
1. Select the cell you want to copy by clicking and dragging across it while holding down 

your left mouse button.

2. Press CTRL+C to copy.

3. Select the cell you want to paste to by clicking on it with your left mouse button.

4. Press CTRL+V to paste.
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Marking and Unmarking Records for Deletion
The check boxes in front of records in a dBase list are Delete (del) check boxes. They are used 
to indicate whether or not a record has been marked for deletion. If a box contains an “x,” then 
that record has been marked for deletion.

To mark or unmark a record for deletion, click the left mouse button on a record’s Delete check 
box to select the box. Press the spacebar to toggle the delete mark on and off.

FILTERING RECORDS
Use Filter to specify the range of records you wish to process. To filter your records, select 
Database > Filter. The Filter dialog box opens.

Filtering records

To specify a record or range of records for processing, click Filter On to enable filtering. In the 
Field window, you will see all the formatted fields in your list, along with a few additional ones 
(these additional fields can be filtered by formatting them using the 10 optional fields available 
on the Address Check — Format tab). Click on the field you wish to use as the basis for your 
filtering operation. It will be highlighted in the Field window. 

To choose the mathematical filtering parameters MAILERS+4 will use to filter your list, use the 
Operator window to select the “Operator” that describes the filtering process you wish to per-
form. It will be highlighted in the Operator window.



MAILERS+4 User’s Guide Opening a Mailing List

20

Filter Status 
• Filter On — Enables the filtering of records within individual program functions

• Filter Off — Disables the filtering of records without changing your current filter set-
tings

Filter Operators
• Less Than will collect all records that are alphabetically or numerically less than the 

value specified in the Value box (for example, ZIP < “20000” will include records that 
have ZIP Codes between “00000” and “19999” and Name < “Phil” will include records 
that have names beginning with “A” through “Phik”).

• Less/Equal will collect records in the same way as “Less Than,” however, it also 
includes the value specified in the Value box (for example, ZIP < “20000” will cover 
records between “00000” and “20000” and Name < “Phil will cover records from “A” 
through “Phil”).

• Not Equal will collect all records where this condition is met (for example, State <> 
“TX” will include all records except the ones located in Texas).

• Equal will collect all records where this condition is met (for example, State = “TX” will 
only include records that are located in Texas).

• Greater Than will collect all records by reversing the approach of the “Less Than” 
parameter (for example, ZIP > “20000” will include records that have ZIP Codes 
between “20001” and the number of the last record in your list and Name > “Phil” will 
include records that have names beginning with “Phim” through “Z”).

• Greater/Equal will collect all records in the same way as “Greater Than,” however, it 
also includes the value specified in the Value box (for example, ZIP > “20000” will 
cover records from “20000” to the last record in your list and Name > “Phil” will cover 
records from “Phil” through “Z”).

• Contains will collect all records containing a specified sub-string (for example, Com-
pany Contains “Accounting” will include all records with a company name field that 
contains the word “Accounting”).

• Is Blank will collect all records with a designated blank field (for example, Company Is 
Blank will include all records with an empty company name field).

After you have chosen a field to use as the filter target and an operator to perform the filtering 
operation, use the Value box to enter the value you want to compare to the target field of 
records in your list (for example, in the expression ZIP = “20000,” ZIP is the target field, = is the 
operator and “20000” is the value). If you only want records to be filtered when the target field 
has the same length as the value it is compared to, select the Match Whole Word check box 
(for example, Name = “Phillip” will only produce a match if the formatted field contains “Phillip.” A 
variation such as “Phil” will be ignored). 
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Custom filters can be created by using the And and Or radio buttons to define the relationship 
between two or more operators. 

• When And is used to combine several filter operators, every filter expression must be 
true before a record is matched and included in the filtering selection. 

• When Or is used for the same purpose, the record is matched and included in the fil-
tering selection if one or more filter expressions are found to be true.

• If both And and Or are used to create a custom filter by combining filter operators, Or 
is evaluated before And (for example, City = “Laguna” or City = “Irvine” and State = 
“CA”). 

Click Add Filter when you are ready to combine your selections in the Field and Operator 
boxes with your entry in the Value box. A new filter will be created and will appear in the Active 
Filters box (the Active Filters box displays the filtering parameters that are currently in use). If 
you choose to create a custom filter by combining several active filters, make sure that And/Or 
is set to create the desired filter expression. 

You can modify your filters using the Edit Filter button by selecting them in the Active Filters 
box and changing settings that appear in the Field, Operator, and Value boxes. Click Edit Fil-
ter to keep the new settings. To remove a selected filter from the Active Filters window and 
MAILERS+4, click Delete Filter. 

The Record Count function lets you tabulate all the records in your list and see how many match 
the filter criteria. The results of your Record Count will be displayed in the Total box. You can 
use the Record Count function by clicking on the Count button. 

To undo your active filter settings and revert to the previous active filter, click Restore Last. You 
can exit the Filter dialog box and return to the main screen without saving your settings by click-
ing Cancel. When you have finished defining your active filters, click OK to save your settings 
and return to the main screen. These filters can now be selected in MAILERS+4 features and 
used to process specific records in your list.

Filter Examples
• Deleted Record = “False” (excludes deleted records from your filtering selection)

• Record Number <= “500” (includes records 1 to 500 in your filtering selection)

• City = “Laguna” or City = “Irvine” and State = “CA” (includes all California records in 
your filtering selection that have Laguna or Irvine city locations)

• ZIP <> “926” with Match Whole Word unchecked (excludes records in an SCF from 
your filtering selection)
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FORMATTING YOUR LIST
If this is the first time you are using a particular list with MAILERS+4, you need to format the 
fields in the list so the program can read and use the data properly. The formatting process is 
discussed in Formatting Lists on page 23. If your list has already been formatted in MAIL-
ERS+4, you can skip formatting and begin using the program features immediately.

EXPORTING YOUR FILE
MAILERS+4 automatically saves all changes you make to your mailing list before closing. For 
more information on moving lists in and out of MAILERS+4, see Database Management on 
page 137.

HAVING TROUBLE?
If you experience problems opening a file in MAILERS+4, you may be using a file type that can’t 
be recognized by the program. See Common Data File Questions on page 234 for more infor-
mation.
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Formatting Lists

FORMATTING A LIST
Formatting a list is the process of matching or mapping the 
fields in your list to their corresponding MAILERS+4 field 
names. For example, if your list contains the following 
fields:

NAME

STREET

CITY

STATE

ZIP

TEL

Then during formatting you would match them to the follow-
ing MAILERS+4 fields:

Formatting a list enables MAILERS+4 to recognize the 
fields in a mailing list. Files must be formatted before MAIL-
ERS+4 can run them. If you are not sure whether a file has 
been formatted, that’s alright. MAILERS+4 won’t let you 
perform any functions on a file that it cannot read properly. 

Your List MAILERS+4 Fields

NAME FULL NAME

STREET ADDRESS

CITY CITY

STATE STATE

ZIP ZIP

TEL PHONE NUMBER 

In this chapter...

Formatting a List ..................................... 23

Formatting dBase Lists .......................... 24

Formatting ASCII Fixed-Length Lists ..... 28
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If you do experience problems running a MAILERS+4 feature on your list, check for errors in 
your formatting, and then run that feature again.

The process for formatting dBase Lists and ASCII Fixed-Length Lists differ slightly. Therefore, 
make sure you know what type of file you are working with before you begin. Once you have for-
matted your list, you can begin using the program features.

FORMATTING dBASE LISTS
The easiest and quickest way to format a dBase (*.dbf) list is to use the Auto Format function. 
Auto Format does just what the name implies: MAILERS+4 searches through your list fields and 
automatically assigns them to the corresponding MAILERS+4 fields.

Using Auto Format
1. Select File > Format Fields. The Format Fields dialog box opens.

The Master Format screen

The Format Fields dialog box initially displays the first record in your list. 

• The Format Name column shows the fields selected for formatting in the Format
Options section below

• The Length column shows their lengths

For best results, the only NUMERIC fields you should format for use with MAILERS+4 are Latitude 
and Longitude fields.
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• The Name column shows the names of each field in your list

• The Data column shows the data contained in each field of your file

2. Click the Auto Format button. MAILERS+4 automatically matches the MAILERS+4
Field Names to the fields in your list.

3. Click OK to save your formatted file and return to the MAILERS+4 main screen.

Identifying Field Names for Auto Format
Most of the field names found in your list are automatically recognized by Auto Format. If, how-
ever, your list has a nonstandard abbreviation for the name of a field, Auto Format may not be 
able to match it to a MAILERS+4 Field Name. Always check all your list fields against the MAIL-
ERS+4 fields displayed to make sure they are correct. If incorrect, you can edit the MAILERS+4 
MP4AUTO.INI file. This file is loaded with the program and comes preset with most of the com-
mon names of mailing list fields. Auto Format reads from this file, when running, and won’t iden-
tify a field name that it comes across unless that name is in the MP4AUTO.INI file. This file can 
be edited so the problem fields will then be recognized by Auto Format.

Editing MP4AUTO.INI
1. Click the Start button, and then point to Programs. Point to the Accessories folder, 

and then click Notepad.

2. When Notepad opens, open the MP4AUTO.INI file located in the C:\Program-
Data\Melissa Data\MAILERS+4 directory for Windows 7 and Vista.

3. The MP4AUTO.INI file contains two columns of information, separated by equal signs 
on the left portion of the page.

• The column to the left of the equal sign contains the MAILERS+4 field names. These
fields cannot be edited.

• The right-hand column contains the field names that Auto Format is currently set up to
recognize.

4. In the left column, find the MAILERS+4 field name you want Auto Format to recognize.
Scroll down to the bottom of the MP4AUTO.INI file. In the empty spaces after the last
entry, use your mouse to insert the cursor on the next line (following the final
MP4AUTO.INI entry).

5. Type the MAILERS+4 field name that your list entry corresponds to, followed by an
equal sign. Next, type the field name from your list that you want Auto Format to recog-
nize, and then press Enter. Make sure the field names you enter are exactly like the

Use the PAGE UP/PAGE DOWN keys to view other records in your list.
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ones from MAILERS+4 and your list. If they are not, Auto Format will be unable to 
match them.

Editing the MP4AUTO.INI file

6. When you are finished editing, select File > Exit. When prompted to Save the file, click
Yes to save your changes to the file and exit.

7. In the MAILERS+4 Master Format dialog box, click Auto Format. If you typed the
information correctly in MP4AUTO.INI, your fields will now be formatted.

You can edit the MP4AUTO.INI file anytime you want to update how Auto Format reads your 
lists. Any changes you make to the MP4AUTO.INI file will stay there until you remove them.

Copying List Formats
MAILERS+4 lets you copy the format of a previously formatted list. The copied format will then 
be applied to your currently open list. Both lists must have the same layout in order for this fea-
ture to work properly.

1. Select File > Format Fields. The Format Fields dialog box opens.

2. Click Copy. The Open File dialog box opens.

3. Locate the file you wish to copy format from.

4. In the Open File dialog box, click Open. The fields in your currently open list will be for-
matted in the same manner as the MAILERS+4 file that you are copying from.

5. In the MAILERS+4 Format Fields dialog box, click OK to keep this format, or click
Cancel to quit without saving the format changes and return to the MAILERS+4 main
screen.



Formatting dBase Lists MAILERS+4 User’s Guide

27

Formatting Fields
You can format fields for most MAILERS+4 features by clicking the desired tab in the Format 
Fields dialog box. The Others tab combines the format fields for ZIP & Error Code, Records in 
Radius and 10 optional use fields. Other MAILERS+4 features are represented by their own tab 
in the Format Fields dialog box. 

You can also access the Format Fields dialog box by clicking the Format button located in the 
Options dialog box of most MAILERS+4 functions. For example, when you begin Address 
Check, the Address Check Options tab displays. Click Format to view or change your 
Address Check formatting. The fields that can be formatted in this manner vary from feature to 
feature.

To format fields, do the following:

1. Select File > Format Fields. The Format Fields dialog box opens.

The Address tab in the Format Fields screen.

2. Click on the mailing list field you want to format (press the PAGE UP and PAGE DOWN
keys to view other records). The field should now be highlighted.

3. In the Format Options section in the lower portion of the Format Fields dialog box,
select the check boxes next to the MAILERS+4 field names that apply to the mailing
list field you are formatting.

4. The MAILERS+4 field name appears to the left of your mailing list field. To undo the
format, simply select the check box again to remove the check mark.

5. Repeat the first four steps until you are satisfied with the formatting of your list (in the
Address and Presort screens additional fields are available for formatting by clicking
the Advanced button).
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6. Click OK to save the formats, or Cancel to quit without saving any changes.

FORMATTING ASCII FIXED-LENGTH LISTS
1. Open your ASCII fixed-length file in MAILERS+4.

2. Select File > Format Fields. The Format Fields dialog box opens. This Format
Fields dialog box looks slightly different than the dBase Format Fields dialog box, but
the process of formatting is very similar. The main difference is that you need to enter
the record length if your file does not contain carriage return and line feed codes.

Notice that the first record in your list displayed in the top box of the screen. As you
format the list, the matched fields appear in the empty box in the center of the Format
Fields dialog box.

3. Select a field from your mailing list to match up with a MAILERS+4 Field Name. This
can be done two ways:

a. Hold down the left mouse button while dragging your cursor over a record’s text (to
highlight it), then use your mouse to click on the desired field.

b. Type in the field’s Start Position, Stop Position, and Length in the spaces provided.
If you choose this method, keep in mind the field length has to be correct.
Scrolling up and down to view other records using PAGE UP/PAGE DOWN is a
good way to reference other records. If the field length is too short, any
information that exceeds the field limits will be cut off by MAILERS+4.

3. Click on the box next to the MAILERS+4 field name that applies to the mailing list field
you are formatting. The MAILERS+4 Format Name, Position, Length, and Data of the
formatted field appear in the Format section in the middle of the Master Format
screen.

To undo format, simply re-click the MAILERS+4 Field Name in the Format Options
section.

4. Repeat steps 1 and 2 to format the remaining fields in your list.

5. When you are finished formatting your list, click OK to save the formats, or Cancel to
quit without saving any changes.
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Setting Options
You can set various options in MAILERS+4 by using the 
Tools menu. Some of these options relate to the currently 
open mailing list, and some relate to the MAILERS+4 pro-
gram itself. 

• List Options — Manages information regarding the 
currently open list. Use the List Owner Information 
screen to enter the name and contact information of 
the list owner. All data on the List Owner Information 
screen applies to the list that is presently in use, not to 
every mailing list.

• System Options — Manages information and options 
used internally by the MAILERS+4 program. Directo-
ries are used to set the file paths for MAILERS+4, 
User Information contains contact data about the pro-
gram owner, and Program Options allows format and 
viewing preferences to be set for opening files. User 
Information data is also printed on the Presort report. 
Information entered in Directories, User Information, 
and Program Options does not change from list to list.

• Data Entry Options — Provides data entry prefer-
ence settings that can be saved for future use. These 
settings do not change from list to list.

LIST OPTIONS
To open the List Owner Information screen:

1. Select Tools > List Options. The List Owner 
Information screen opens (options set in the List 
Owner Information screen apply to the file you 
currently have open, not to every list). 

In this chapter...

List Options ............................................. 29

System Options....................................... 30

Data Entry Options ................................. 36
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The List Owner Information Screen

2. Type the name and address of the list “owner” in the fields provided. For example, if
you are a mailing house, type your client’s name and address in these fields. If the list
owner is also the mailing permit holder, type the permit number in the corresponding
field. This information will appear as “Permit Holder’s Name and Address” on the Post-
age Statement.

SYSTEM OPTIONS
To access the system options, select Tools > System Options. There are tabs for Directories, 
User Information, and Program Options. Unlike List Options (which contains USPS data regard-
ing the currently open list), information in the System Options screens consists of data used 
internally by MAILERS+4, and this information remains unchanged from list to list.

Directories Tab
To set paths for MAILERS+4 and its data files, click on the Directories tab. You can then specify 
various system paths that will not change when new mailing lists are opened.

To specify the path to a new directory location for any of the following fields, click on the field’s 
corresponding browse button.
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The Directories tab in the System Options dialog box

• US Data — The default path for the U.S. national data file (mdAddr.nat) should share the
same path as mdAddr.dat. If you moved mdAddr.nat after installation, you need to
specify its new location here.

• RBDI Data — Specify a path to the folder or drive containing your RBDI data file.

• Canada Data — Specify a path to the folder containing your Canadian data files.

• GeoCode Data — The default path for the GeoCode data file (mdGeo.dat) should be your
CD-ROM drive (D:\), unless you opted for the Large Installation, in which case, it should
share the same path as mdAddr.dat. If you moved mdGeo.dat after installation, you
need to enter its new location here.

• Default Location — When you use this field to specify a path to the folder containing your
mailing lists, MAILERS+4 will go to this directory whenever you open a list. The default
location is the My Documents directory on your computer.

• Temporary Location — Specify a path to the folder containing your temporary files. MAIL-
ERS+4 will use this folder to store the data files it uses while processing your lists. If this
field is left blank, MAILERS+4 will store these files in the MAILERS+4 home directory. If an
error message indicates the default MP4 directory does not have enough space for your
temporary files, you should specify a new temporary location.

• Presort Data — Specify a path to the folder containing your Presort data files. This should
never be change unless instructed by Melissa Data tech support.
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New License String
The New License String box enables you to add the RBDI features to MAILERS+4 if you did 
not add them when you initially installed MAILERS+4. One option would be to run the install 
program again and add the necessary license code during install, but MAILERS+4 will recopy 
all of the program and data files again. Using the New License String box, you can copy the 
RBDI data files manually from the DVD and activate the feature without running install again.

To add a new feature:

1. Insert the MAILERS+4 DVD. If the install program starts, close it. (Note that you can 
prevent the auto-run feature in Windows by holding down the Shift key while inserting 
the DVD.)

2. Using Windows Explorer, locate the Data folder on the DVD and open it.

3. Copy the desired folder or folders (RBDI) to the Data folder in your MAILERS+4 pro-
gram directory. This is C:\ProgramData\Melissa Data\MAILERS+4 directory for Win-
dows 7 and Vista.

4. Start MAILERS+4.

5. Select Tools > System Options.

6. Select the Directories tab.

7. Enter the RBDI or eLot License Code into the New License String box.

8. Click Add.
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User Information Tab
Data entered in the User Information tab will be the default for the permit holder when setting 
up a Presort template.

• Mailing Permit — Enter the mailing permit number being used for the current mailing.

• Mailer ID — This is a six or nine-digit number that uniquely identifies the source of this 
mailing. This is required for the new Intelligent Mail barcode system.

• Customer’s Number — Use this space to enter your reference for the party for which the 
current mailing is being prepared, if any.

• User is also List Owner — Check this box if you are using MAILERS+4 to process your 
own mailing lists.

The User Information tab in the System Options dialog box

Program Options Tab
Use the Program Options tab to set preferences that apply to every database you open. 

• Run “Auto-Format” on new files — Automatically formats new files 

• Go directly to format screen on new files — The Format Fields dialog box opens each 
time a new file is opened 
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• Show last entries in recently used file list — Specify how many entries are displayed in 
the list of recently used files

• Disable address swapping — Select this check box to disable address swapping

The Program Options tab in the System Options dialog box

• Index before Address Check — This option increases the processing speed of Address 
Check by sorting records by ZIP Code. You do not need to use this option if your list is 
already ZIP sorted. This feature does not permanently store the sorted order in your list. 
Because the index is not saved, this option is only good for the current Address Check. If 
you interrupt Address Check on indexed records, you will be unable to resume checking 
from where you left off.

• Ignore Suite Errors — If this box is checked and DPV is enabled, Address Check will not 
generate an error if the primary address (street name and number) is correct but the sec-
ondary address (suite or unit) is incorrect or missing.
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• Disable SuiteLink — If this box is checked, MAILERS+4 will not append suite numbers for 
business addresses, even if the company name is found in the SuiteLink database.

• Disable AddressPlus — If this box is checked, MAILERS+4 will not append secondary 
address numbers for any residential and business addresses found in the AddressPlus 
database.

If Disable SuiteLink is checked, then AddressPlus will also be automatically disabled, 
because AddressPlus requires that SuiteLink be enabled in order to function.

• Disable vacant record errors — If this box is checked, MAILERS+4 will not flag vacant 
address records. In this case, as long as the address exists, it will be treated as a deliver-
able address.

• DeliveryPlus Records — If this box is checked, MAILERS+4 will flag records that physi-
cally exists, but will not be serviced by the U.S. Postal Service. These address may still be 
serviced by delivery services such as DHL, UPS, or FedEx. 

• Strip leading zeros from tray and package number — Stripping leading zeroes from tray 
and package numbers (to avoid truncating your label endorsement line)

• Don’t reset tray numbers between presort jobs — Tray numbers will not be reset 
between multiple presort jobs

• Suppress delivery point check digit write back — MAILERS+4 will not write back the 
Delivery Point Check Digit field when performing an address check,

• Check for Program Updates — On startup, MAILERS+4 will automatically check if new 
program updates are available for download. If an update is available, the user will be 
offered the chance to automatically download and install the program update. Uncheck this 
box to disable this automatic check when starting MAILERS+4.

• Check for EWS (Early Warning System) Updates — MAILERS+4 will automatically 
check if a new Early Warning System file is available for download. If an update is available, 
the user will be offered the chance to automatically download and install the new EWS file.
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DATA ENTRY OPTIONS
To open the Data Entry Option dialog box, select Tools > Data Entry > Options. 

The Data Entry Options dialog box

From here, you can select various check boxes that correspond to your data entry preferences. 
After selecting your preferences, click Save Setting As Default to save your choices for future 
use.

• Enter key at last tab stop saves record — A short-cut for the Save button when entering 
field data. 

• Address Verification — Insures the accuracy of your information by running Address 
Check on each record as it is entered. 

• Resolve Bad Address — The Resolve Address Errors dialog box opens whenever 
Address Check is unable to verify a record, allowing you to update address data as you go 
along. 

• City/State Look-up — MAILERS+4 will find the correct city and state for your ZIP Code 
(when several cities match the ZIP Code the USPS preferred city is provided). If your ZIP 
Code includes more than one city, the Display list of all city names check box prompts 
MAILERS+4 to open a list box containing the cities that use your ZIP Code. Select your city 
from this list.

BACKING UP SYSTEM OPTIONS
System Options settings are stored in a file called mp4w32.dat in the MAILERS directory. A 
duplicate file is automatically copied to the BAK subdirectory of your main program directory 
every time you MAILERS+4.

The backup files allow you to restore your MAILER+4 settings if the original files are overwritten 
or lost for any reason.
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Checking Addresses
Address Check verifies addresses using data contained in 
the national data files. Once an address is verified, 
Address Check can standardize it to USPS/Canadian 
postal requirements and append up-to-date information 
such as ZIP + 4, Carrier Route, and Delivery Point codes. 

If Address Check finds incorrect address information in a 
record, it will attempt to correct it. If you formatted an 
address error field in your list, Address Check will insert an 
error code in the record whenever it finds an error. This 
code can be used to determine the type of error it found.

You can also correct address errors manually by using the 
Resolve Address Errors feature. 

WHEN TO USE ADDRESS CHECK
Address verification helps ensure all of your mail pieces 
are deliverable by the Post Office. It is required for 
automation discounts on postage rates and for bar coded 
or ZIP + 4 presorts. To qualify you for these discounts, 
Address Check matches your list against the USPS 
National Database file.

Running Address Check first is highly recommended as a 
correct, standardized address yields the best results from 
all MAILERS+4 features. 

In this chapter...
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DPV — Verifying Delivery Addresses.... 38

LACSLink — 911 Address Conversion ... 39

SuiteLink — Append Secondary 
Addresses................................................ 39
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Formatting Fields for Address Check.... 42
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Resolving Address Errors....................... 52
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CASS CERTIFICATION (FORM 3553)
To qualify for bar code or ZIP + 4 presort discounts, the USPS requires that 100% of the 
addresses in your mailing list be correct (the quantity of records successfully coded must match 
the number of pieces in your mailing). You must use Form 3553 to meet the USPS requirement 
for proof of address correction. Once Address Check has verified your list, you can print the 
CASS form from MAILERS+4. It is only necessary to run Address Check once to get the CASS 
information required by the USPS.

To do this, do one of the following:

• Select List > Address Check > Results. The Address Check Results dialog box 
opens. Click CASS (Form 3553). From here, you have the option of making changes, 
previewing, or printing the CASS form.

• Select List > Address Check > CASS Form. From here, you have the option of mak-
ing changes, previewing, or printing the CASS form.

Database Expiration
Due to USPS licensing regulations, MAILERS+4 disables the appending of +4 data and 
displays a warning before printing CASS Certification forms approximately 105 days after the 
initial MAILERS+4 distribution date (three months beyond this distribution date and extending to 
the end of the third month). You will not be able to add +4 codes to a mailing list after the 
average expiration period of 105 days is reached. However, MAILERS+4 will still allow you to 
check your list, correct and standardize street names, correct the 5-digit ZIP Codes, and add 
Carrier Routes for a limited time.

DPV — VERIFYING DELIVERY ADDRESSES
DPV increases the accuracy of your address checking by matching the address to a confirmed 
delivery point. It is now required in order to generate a CASS Form 3553. If DPV is enabled, the 
Address Check results will show the percentage of addresses that were verified using DPV.

DPV is required to produce a CASS Form 3553.

This percentage is the number of fields that were actually matched to deliverable addresses. 
The DPV status of a specific record can be checked using the CMRA and DPV Footnotes fields, 
if these fields have been formatted.
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LACSLINK — 911 ADDRESS CONVERSION
LACSLink is now required for to produce a CASS form 3553. 

Rural Route and Highway addresses are being converted to standard street addresses to make 
them easier for the postal service to deliver mail and for emergency services to find. For 
example, “RR10 Box 12” might become “1234 Federal Street.”

Also, there are instances when a standard street address will change, such as renaming the 
street itself or changing the numbering along that street. 

MAILERS+4 will detect addresses that have changed under one of the above circumstances 
and automatically replace the obsolete address with the current one. 

The service returns two codes that indicate the degree of matching and conversion. The 
LACSLink Indicator is returned to the LACS field and the LACSLink Return Code is returned by 
the LACSLINKReturnCode field.

See LACSLink Return Codes on page 215 for information on what values are returned and 
what they mean.

SUITELINK — APPEND SECONDARY ADDRESSES
SuiteLink is a service of the USPS that appends or updates suite information to business 
addresses when these addresses are found in the SuiteLink database of commercial secondary 
addresses.

This feature can be disabled in the System Options, on the Program Options tab. In the future, 
enabling SuiteLink will be required for CASS certification.

ADDRESSPLUS
AddressPlus is an MAILERS+4-exclusive enhancement to SuiteLink, adding millions of business 
residential addresses to which MAILERS+4 can append a secondary address, if one is missing.

This feature can be disabled in the System Options, on the Program Options tab. 
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RUNNING ADDRESS CHECK
To run Address Check, make sure the List Information screen for the desired mailing list is open. 
Select List > Address Check > Options. The Address Check Options dialog box opens.

The Address Check Options dialog box contains options for standardizing the data in your 
mailing list and/or speeding up the address checking process by indexing your list and skipping 
records with certain criteria.

• Skip previously coded records — Skips records that already contain both Carrier 
Route and ZIP + 4 codes. This can significantly decrease the amount of time needed 
to check new records. However, because MAILERS+4 cannot include skipped records 
in CASS certification (Form 3353), do not use this option when preparing a mailing.

• Use USPS Preferred City Names — Replaces any acceptable alternative city name 
with the preferred USPS city name for that ZIP Code. If this option is not selected, 
MAILERS+4 still corrects spelling errors for alternative city names it can identify, and 
provides the official city name for alternative city names it cannot identify. If this option 
is selected, MAILERS+4 changes all alternative city names to the official city name for 
that ZIP Code.

The Address Check Options

For example, MAILERS+4 will do the following for the entry of Holywood (a misspelled 
alternative city name):

• If this option is not selected, the entry is changed to Hollywood.

• If this option is selected, the entry is changed to Los Angeles, the official city 
name for that ZIP Code.
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• Combine Range and Address field — If you have separate Range and Address 
fields and wish to add the Range to the Address, select this check box. The Range is 
the street number, and the Address is the street name, direction and/or suffix. For 
example, in a record of 100 N. Main St., ‘100’ is the Range and ‘N. Main St.’ is the 
Address. Note that if you combine the Range and Address fields for records where 
they are already combined, the Range will be duplicated and Address Check will return 
an error when it codes the record.

• Address Standardization — This option changes data in the Address field to meet 
abbreviation standards set by the USPS (for example, ST for Street, N for North, and 
so on) and corrects minor spelling errors. It can be set to Never, Only On Coded 
Records, and Always. These settings tell Address Check when to apply Address Stan-
dardization to your mailing list. For example, if you select Always in the Address Stan-
dardization section, MAILERS+4 will only change data that is clearly not standard (for 
example, P.O. Box to PO Box).

• Form 3553 — Use the settings in this area to automatically print a CASS Certification 
form after address checking your list.

• Save Settings as Default — Saves the current option settings as the default for future 
address checking in the current list.

• Download latest EWS file — EWS (Early Warning System) data is composed of new 
addresses (for example, new housing developments) that are scheduled for inclusion 
in the USPS national database. The USPS updates this data every week to reflect new 
construction and home ownership. When performing an address check, MAILERS+4 
consults the EWS file as well. Having an updated EWS file prevents MAILERS+4 from 
miscoding new address information with data in the older USPS national database file. 
For example, an input of 44 Legacy Drive would be changed to 44 Legacy Street if 
Legacy Drive does not yet exist in the USPS national database. If Legacy Drive is in 
the EWS file, however, MAILERS+4 would recognize it as a new street and not code 
the record. The next database update should contain the new information and enable 
MAILERS+4 to properly code the record.

Be sure to frequently download the latest EWS file in order to have the most current 
address records. Current EWS files are available every Thursday.

• Casing — Fields which Casing affects are:

• Convert Company Field To All Caps — Converts text in the company field to all 
upper case letters. 

Delivery Address Suffix First Name

Suite Name County Name Last Name

City City/St/ZIP Full Name

Suite Urbanization
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• Do not case the name field — Select this check box to keep the current casing 
for the names in your database. Casing changes will not be applied to text in 
name fields.

• On Address Errors — Clear Existing +4’s and Clear Existing CRRT’S removes +4 
and Carrier Route codes from invalid addresses, allowing Presort to skip them when it 
processes your list. 

• Delete Unresolved dBase Records — If MAILERS+4 cannot automatically verify an 
address, it will mark the record for deletion. This option is only available for dBase lists. 
Address Check will not remove records from a dBase list. Use the Database Manager 
to pack out records marked for deletion.

• Days Until Database Expiration — Shows how many days are remaining before the 
current U.S. and Canadian databases expire.

Click Format to format fields for Address Check.

Click Filter to specify the range of records to process.

Click Cancel if you wish to quit and return to the List Information screen. 

Click Go when you are ready to begin processing your mailing list. 

FORMATTING FIELDS FOR ADDRESS CHECK
MAILERS+4 will only append this data to records that have valid addresses (records that have 
been successfully coded by Address Check).

The Format Fields tab for Address Check
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To format fields in Address Check, click Format in the Address Check Options dialog box. (For 
more information on the Address Check Options dialog box, see Running Address Check on 
page 40.) The Format Fields dialog box opens. 

Advanced Format options are available by clicking the Advanced button in this dialog box. To 
return to the main Address tab, click on the Normal button. 

Required Fields
The following fields must be formatted in order to run Address Check:

• Delivery Address — The field that contains the address you want the Post Office to 
deliver to.

• City — The field in your list that contains the city name. 

• State — The field in your list that contains the state name or abbreviation.

• ZIP — The field in your list that contains the 5-digit ZIP Code. If your ZIP Code field is 
nine or more characters in length, you do not need to define a separate Plus4 field. 
Address Check inserts a hyphen (if there are 10 characters) and a +4 Code in the ZIP 
field.

If you are using the Canadian Addresser add-on, Canadian Postal Codes must contain six 
characters.

Recommended Fields
It is recommended that the following fields be formatted prior to running Address Check:

• Address Error — This field will contain the error code (one character in length) that 
describes the type of error in your address. See Address Check Error Codes on 
page 214 for more information.

• Company — If two ZIP + 4s have been assigned to the same address, Address Check 
uses the Company field to assign the correct ZIP + 4. The program will not change or 
insert a company name in this field.

A company name is required in order for SuiteLink to append a secondary address to a 
business address, so the Company field should be formatted if SuiteLink is enabled.

• Delivery Point — This field contains a 3-digit number composed of a “check digit” 
(which is the last digit of this 3-digit number), plus two additional numbers (usually the 

The “ZIP” field should be a character field (not a numeric field) when using dBase or ODBC file 
formats. You can view the field type by selecting Database > Modify, and selecting the “Type” check 
box after clicking on the ZIP field in the “Fields” box. 

The disadvantage of a numeric format is that it strips leading zeros from the ZIP Code, doesn’t 
allow a dash between the ZIP™ and +4 Code, and adds an unwanted decimal point. This results in 
bar code failures and rejected mailings.
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first 2 digits of the address number). These three numbers, added to the 9-digit ZIP + 4 
Code, make up the Delivery Point Barcode (DPB). 

• DPB Check Digit — This field contains the last digit in the Delivery Point Barcode. The 
DPB Check Digit enables bar code scanners to verify that they have scanned the first 
11 digits of the Delivery Point Barcode correctly. If the Delivery Point field and the DPB 
Check Digit field are both formatted, Address Check will return a 2-digit number for the 
Delivery Point and a 1-digit number for the DPB Check Digit.

• Last Name — Last name of individual in address. The last name is required in order 
for AddressPlus to function, so this fields should be formatted if AddressPlus is 
enabled. Also, format this field to match its casing to the addresses in your list before 
printing labels.

Optional Fields
The following fields are optional for running Address Check:

• Address 2 — If your records have a two-line address, this field will contain the second-
ary address. See Formatting Records with Two Address Lines on page 49 for more 
information.

• Suite — A field containing the name and number of a suite, apartment, and so on.

• Private Mailbox — A field containing a private mailbox number.

• CMRA — This field is only returned if the DPV add-on was installed with MAILERS+4. 
It indicates whether or not an address belongs to a Commercial Mail Receiving Author-
ity (CMRA). The USPS will not deliver mail to addresses belonging to CMRAs unless a 
“PMB” or “#” indicator is displayed after the address and before the suite number. 

• CRRT — The Carrier Route (CRRT) code applies to pieces grouped by individual mail 
carrier routes. CRRT-coded mail can receive presort discounts if enough pieces qualify 
per Carrier Route.

• LACS — This field will return one of two codes if a rural address conversion is 
detected.

• Y — Address was converted to a new address.

• N — Address conversion attempted but not made.

• LACSLinkReturnCode — This fields indicates the degree of matching and conversion 
with the LACSLinkTM master file. For more information, see LACSLink — 911 Address 
Conversion on page 39.

• Urbanization (Puerto Rico Only) — Divides Puerto Rico’s cities into urban areas for 
delivery purposes.

• First Name — First name of individual in address (format this field to match its casing 
to the addresses in your list before printing labels).
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• Full Name — Full name of individual in address (format this field to match its casing to 
the addresses in your list before printing labels).

• ZIP + 4/DPB — This field contains the Plus4 field and the Delivery Point Barcode.

Optional Fields (Advanced Formatting) 
The following fields are optional for running Address Check. To access these fields, click the 
Advanced button in the Format Fields dialog box.

• County FIPS — The Federal Information Processing Standard (FIPS) is a 5-digit code 
assigned to each county in the U.S. by the Bureau of the Census. The first two digits 
are the state code and the last three digits are the county number.

• County Name — The name of the county.

The Format Fields Advanced tab for Address Check

• Time Zone — A 2-digit number representing the hours past Greenwich Mean Time. 

Code Time Zone

4 Atlantic Time

5 Eastern Time

6 Central Time

7 Mountain Time

8 Pacific Time
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• LOT (Line-of-Travel) Number — The Line-of-Travel number for the record.

• LOT (Line-of-Travel) Order — The code used to sort records in Line-of-Travel order.

• ZIP Type — A one-character code indicating the ZIP Code type. 

• Latitude — The latitude coordinate (degrees north of the equator) of the 5-digit ZIP 
Code centroid.

• Longitude — The longitude coordinate (degrees west of the Greenwich Meridian) of 
the 5-digit ZIP Code centroid. 

• CBSA Code — The CBSA Code is a five-digit code for the specific CBSA associated 
with the location described by the submitted ZIP Code.Metropolitan and micropolitan 
statistical areas (metro and micro areas) are geographic entities defined by the U.S. 
Office of Management and Budget (OMB) for use by Federal statistical agencies in col-
lecting, tabulating, and publishing Federal statistics. The term "Core Based Statistical 
Area" (CBSA) is a collective term for both metro and micro areas. A metro area con-
tains a core urban area of 50,000 or more population, and a micro area contains an 
urban core of at least 10,000 (but less than 50,000) population. Each metro or micro 
area consists of one or more counties and includes the counties containing the core 
urban area, as well as any adjacent counties that have a high degree of social and 
economic integration (as measured by commuting to work) with the urban core.

• CBSA Title — The official U.S. Census Bureau name for the Core Based Statistical 
Area(CBSA).

9 Alaska Time

10 Hawaii-Aleutian Time

11 Samoa Time

To presort for Enhanced Carrier Route Non-Automation Letters and Flats, you must have eLOT 
installed. You must format the Line-of-Travel Number, Line-of-Travel Order, and Delivery Point 
before running Address Check. When the data for these fields has been added to your records, you 
will be able to presort your list. If these fields have not been formatted, the Enhanced Carrier Route 
Non-Automation Letters and Flats in the "Suggested Mailings Box" will not be available during 
presort.

Code ZIP Type

M Military/APO

P PO Box

U Unique (assigned to specific organizations)

Blank Standard

Code Time Zone
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• CBSA Level — The level description for the Core Based Statistical Area (CBSA), met-
ropolitan or micropolitan.

• CBSA Division Code— The numeric code for the division within the Core Based Sta-
tistical Area containing the submitted ZIP Code. Some CBSA’s are broken into parts 
known as divisions. In this case, the CBSA Division functions will also be populated. If 
not, these fields will be empty. Each division also has a Code, Level and Title.

• CBSA Division Level — The level description (metropolitan or micropolitan) for the 
division within the Core Based Statistical Area containing the submitted ZIP Code.

• CBSA Division Title — The official U.S. Census Bureau’s official name for the division 
within the Core Based Statistical Area containing the submitted ZIP Code.

• Address Type — A one-letter identification code for the delivery location.

• Congress. District — The Congressional District number for the delivery address.

• # Residential Deliveries — Total number of residences in a Carrier Route.

• # Business Deliveries — Total number of businesses in a Carrier Route.

• DPV Footnotes — The USPS DPV footnote for the delivery address. See DPV Foot-
notes on page 215.

• IMB Numeric — The unconverted numeric representation of the information used to 
generate an Intelligent Mail® barcode. This value can be used with printers that are 
able to interpret barcode information

• IMB Alpha — The converted representation of the Intelligent Mail barcode. Combined 
with the right fonts, this data can used in Microsoft Word and other applications to print 
Intelligent Mail barcodes.

ADDRESS PARSING
Address Check can parse (split) delivery addresses into separate component fields (number, 
pre-direction, street name, and so on) or split a combined City/State/ZIP field into separate 

Code Address Type

F Firm (single business or organization)

G General Delivery (general mail pickup)

H High-rise (business park, plaza, and so on)

P PO Box (Post Office box)

R Rural Route/Highway

S Street/Residential Address
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fields. It can also combine separate address component fields into a single field and combine 
separate City, State, and ZIP fields into a single City/State/ZIP field.

Parsing a Delivery Address

1. Format the Address, City, State, and ZIP fields in your mailing list. See Formatting 
Fields for Address Check on page 42 for more information.

2. In the Format Fields dialog box, click Advanced. 

3. Format the component fields you want addresses to split into. A complete delivery 
address can be separated into as many as seven component fields. 

• Number — Street Address number (for example, 100 Main St).

• Pre-Direction — Direction indicator preceding the street name (for example, 100 
N Main St).

• Name — Street Name (for example, 100 Main St).

• Suffix — Street, Drive, and so on. (for example, 100 Main St).

• Post-Direction — Direction indicator following the street name (for example, 100 
Main N).

• Suite Number — Suite number (for example, Apt 15).

• Suite Name — Apartment, Suite, and so on (for example, Apt 15).

4. Click OK to return to the Address Check Options dialog box. Address Check will ver-
ify and correct, if possible, the addresses in your list. If Address Check is able to suc-
cessfully code your records, it will go on to parse them into component fields.

Combining Separate Address Fields
1. In the Format Fields dialog box, format the Delivery Address, City, State, and ZIP 

fields.

2. Click Advanced.

3. Format all of the fields in the Address Format Options section: Number, Pre-Direc-
tion, Name, Suffix, Post-Direction, Suite Name, and Suite Number.

4. Click OK. The Address Check Options dialog box displays. Click Go. Address Check 
will attempt to verify and correct the address components. If these address compo-
nents are successfully coded, it will combine them into a single Delivery Address field.

MAILERS+4 cannot manually resolve uncombined records.

For information on field length requirements, see MAILERS+4 Fields on page 197.
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Parsing a City/State/ZIP Field  
1. In the Format Fields dialog box, format the Delivery Address field and 

City/State/ZIP field in your list. 

2. Format separate City, State, and ZIP fields. If your new ZIP field is at least nine char-
acters long, the +4 Code will be added automatically (if 10 characters, a hyphen will be 
added). Otherwise, format a separate Plus4 field if you want the +4 Code appended to 
your list.

3. Avoid formatting a City/State/ZIP field if you have a long city name, as the field may 
not be long enough to accommodate an entire ZIP + 4.

4. Click OK. The Address Check Options dialog box displays. Click Go. Address Check 
will verify that the data in your City/State/ZIP field is correct, then copy it into the new 
fields.

Combining City, State, and ZIP Fields
1. In the Format Fields dialog box, format the City, State, and ZIP fields in your list.

2. To avoid running out of room and losing data from your field, format a 42-character (or 
longer) City/State/ZIP field.

3. Click OK. The Address Check Options dialog box displays. Click Go. Address Check 
will verify that the city, state, and ZIP Code data is correct before combining it into the 
City/State/ZIP field.

Formatting Records with Two Address Lines
MAILERS+4 allows you to format records with two address lines. For example: 

The Post Office delivers mail to the address line directly above the City, State, and ZIP. In this 
example, mail would be delivered to 100 Main Street. If you prefer delivery to the PO Box 1234 
address, format that field as the Delivery Address field.

MAILERS+4 Field Data 

Company ACME MAILERS

Address 2 PO Box 1234

Delivery Address 100 Main Street

City New York

State NY

ZIP 10044
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Swapping Address Fields

Address Check uses the Delivery Address field to determine correct ZIP + 4 and Carrier Route 
codes. If the data currently in the Delivery Address field is uncodable, then “and only then” will 
Address Check look for the Address 2 field. If the data in Address 2 is codable, Address Check 
will “swap” the data from the Address 2 field and move it into the Delivery Address field. The 
uncodable data originally in the Delivery Address field is moved into the Address 2 field. In 
this way, all addresses which Address Check codes end up in the Delivery Address field.

ADDRESS CHECK RESULTS
When Address Check has completed checking your list, the Address Check Results screen 
displays.

The Address Check Results screen

The Address Check Results screen displays a breakdown of the numbers of successfully coded 
records, Canadian coded records and records that generated an error.

• Coded — This number indicates how many records were successful matched to an 
actual delivery address. Records that are not DPV coded are included under Error 
Count. 

If you will not be using your list to create a mailing, you can disable the Address Check swapping 
feature.
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DPV returns two additional fields (CMRA and Invalid Suite Indicator) which must be 
formatted to receive the maximum benefit from DPV. These fields will indicate if a 
record is actually a deliverable address.

See DPV Footnotes on page 215 for information on what values are returned and 
what they mean.

• Canadian Coded — This number indicates how many records with Canadian records 
were successfully coded. Canadian addresses that not coded are also included under 
the Error Count.

• Delivery Plus Coded —This number indicates how many records were successfully 
coded with Delivery Plus

• Error Count — This number indicates how many records were not successfully 
coded.

For U.S. addresses, a pie chart shows the breakdown of Streets, High rises, Firms, P.O. Boxes, 
Rural Routes, and General Deliveries coded in your list.

From here, you can preview the records that Address Check was unable to correct or print a 
hard copy of the error report. The CASS Certification form (form 3553) is also available from this 
screen. 

• You can begin resolving address errors immediately by clicking Resolve Addresses. 
For more information on resolving addresses, see Resolving Address Errors on 
page 52.

• To export your records using DPVCoded, Canadian records, DeliveyPlus, and address 
error record categories, click on Split List.

• When you are finished with the Address Check Results screen, click Close. 

Split List
The Split List option enables you to save your DPV coded records, Canadian coded records, 
DeliveryPlus coded records, or any records that generated an address error to separate files. 
By saving your coded records to their own separate database, you can save processing time on 
large lists by excluding address errors from your future Duplicate Check and Presort operations. 
This feature is only avalible with DBF files.

You can export any combination of the fourrecord types to a single file (to save each record 
category to an individual file, you must split your list four times). 

• DPV Coded Only — Export all records in your list that were successfully coded

• Delivery Plus Only — Exports all records in your list are coded as Delivery Plus 
addresses

• Canadian Code Only — Export all records in your list that are coded as Canadian 
addresses
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• Error Records Only — Exports all records in your list that have address errors

Clicking OK will open the Save As dialog box, where you can save your Address Check results 
according to your export option choices. 

Clicking Cancel will exit Split List and return to the Address Check Results screen without 
exporting a file.

RESOLVING ADDRESS ERRORS
The Resolve Address Errors feature allows you to manually correct records in your list that 
Address Check is unable to update automatically.

To resolve address errors in MAILERS+4, click Resolve Addresses in the Address Check 
Results screen. Another Address Check Results screen displays, listing the addresses that 
were not updated.

If MAILERS+4 displays the message “addresses listed on-screen could not be verified by 
Address Check,” this is usually due to incorrect or insufficient information in the Address field. 
MAILERS+4 only resolves addresses in the Delivery Address and Address 2 fields. 

If you formatted two Address fields in your list and neither could be verified, both lines appear in 
the Address Check Results screen. The first line displays the data from the Delivery Address 
field and the second line displays the data from the Address 2 field. You may resolve either line. 
However, data resolved in the Address 2 field will be swapped with the Delivery Address field.

The lower-left portion of the screen displays an error message indicating what type of error is 
occurring with the highlighted address. This message corresponds to the error code in the Error 
column (if an address Error field was formatted). If you have not formatted an Error field, you 
will still be able to view the error type in this message area. If an error has already been 
resolved for a certain address, the message “No Error” appears when that address is 
highlighted.

• Ignore Range/Suite Errors — Check this box to remove any Range/Suite Errors from 
the list of records with errors. It is not possible to correct these errors using the 
Resolve Error screen, so this box allows you to focus on errors that can be addressed 
on this screen.



Resolving Address Errors MAILERS+4 User’s Guide

53

The Address Check Error List

To resolve address errors:

1. In the Address Check Results screen, click on the record you want to correct. 

2. Click Resolve. The Resolve Addresses screen displays. In the upper left portion of 
the screen is the original address data. In the upper right portion of the screen are the 
Edit Info fields. 
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The Resolve Records screen

3. If you want, edit the address information in the Edit Info fields. Type the first few letters 
of the correct street name to see street ranges for all street names in the city beginning 
with those letters. Substituting an asterisk “*” for a street name returns street range 
data for all streets in the city. You can use these wildcard features with or without an 
address number.

Street ranges are made up of a series of sequential address numbers (for example, 1 
to 99 Madison Avenue). 

• Click Search In Range to view records that match the street and city of your 
selected address and that also include the address number. 

• Click Search Out of Range to view all records that match the street and city of 
your selected address. A list of street ranges appears in the large record window. 
An “o” or “e” next to a street range indicates that only odd or even address num-
bers are present in this range. A “b” next to a street range indicates that both odd 
and even address numbers are present.

Resolve searches for street range data by city name. If you wish to search by ZIP Code, leave the 
“City” field blank. 

To find the streets in a city that have your address range, type the address number followed by an 
asterisk “*” (for example, 100 *), and then click Search In Range.
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4. Select the listing which matches the address in your record. Click Replace to actually 
replace the address data in your list. You must click Replace in order to resolve an 
error. This returns you to the Resolve Addresses screen. The error code will be gone, 
indicating that the address has been resolved. The message area at the bottom of the 
screen will read “No Error.” 

RESOLVING ADDRESS ERRORS OUTSIDE 
MAILERS+4

If you wish to bypass the Resolve Address Errors feature and correct errors with a separate 
database manager, we recommend that you format an Error field prior to running Address 
Check. Address Check can then enter address error codes when it processes your list. A list of 
MAILERS+4 error code definitions is located in Error/Information Codes on page 207.

To find records which contain errors, call up records containing Error fields that are not blank. If 
you are not using an Error field, print an Error Report from the Address Check Results screen. 
Use this list to search for unresolved addresses manually.

Clicking Replace while in the “Edit Info” fields replaces your data with the “Edit Info” field content.
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Checking for Duplicates
MAILERS+4 can save you money on printing and postage 
by eliminating duplicate records in your list. Duplicate 
Check can locate records with duplicate names and 
addresses or find out if you are mailing to more than one 
person at the same address. It can match sound-a-likes, 
nicknames (for example, Bill/William, Cindy/Cynthia), ini-
tials, and abbreviations. You can also check for duplicates 
by key field, phone number, or name and phone number 
combinations.

WHEN TO USE DUPLICATE 
CHECK

It’s always a good idea to run new lists through Duplicate 
Check. Up to 10 percent of the names and addresses in 
the average mailing list are probably duplicates.

It is also a good idea to run Address Check before using 
Duplicate Check. When you are ready to begin a mailing, 
make sure to run Duplicate Check before Presort and Print 
Labels. This allows you to weed out costly duplicates 
before they are counted as part of the mailing. 

Use the Multiple Lists option to find duplicates shared 
between two lists. For example, if you want to remove 
names from a rented list that are also on your house list.

Duplicate Check only scans addresses in the Address 1 
field. Running Address Check before Duplicate Check 
moves all good addresses to this field so they can be 
checked for duplicates.

In this chapter...

When to Use Duplicate Check .............. 57

Running Duplicate Check...................... 58

Multiple Lists........................................... 60

Formatting Fields for Duplicate Check . 61

Duplicate Check Results........................ 62

Viewing Duplicate Records.................... 63
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RUNNING DUPLICATE CHECK
For best results, make sure the free hard drive space on your computer is at least 2.5 to 3 times 
the size of your mailing list file.

To run Duplicate Check, select List > Duplicate Check, then Single List or Multiple Lists. The 
Duplicate Check Options dialog box opens.

The Duplicate Check Options dialog box

The following options are available:

Find Duplicate By
• Address Only — Duplicate Check will look for records with matching Delivery 

Addresses and ZIP Codes. All other fields will be ignored.

• Name & Address — Duplicate Check will look for records with matching Names, 
Delivery Addresses and ZIP Codes.

• Last Name & Address — Duplicate Check will look for records with matching Last 
Names, Delivery Addresses, and ZIP Codes.

• Key Field — Duplicate Check will look for records containing data that exactly 
matches the contents of the key field. Any field in your list can be formatted as a key 
field.

• Phone Number Only — Duplicate Check will look for records with matching phone 
numbers.

• Name & Phone — Duplicate Check will look for records with matching names and 
phone numbers.
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• Phone Field to use — Select the phone number you wish to check for duplicates from 
the pull-down menu (Phone #1 or Phone #2).

Suite Number 
• Ignore — Duplicate Check will ignore suite numbers while looking for duplicate 

records.

• Match To Blank — Duplicate Check will view records as a match if they have the 
same address but one contains a suite number and the other does not. For example, 
the following records would be considered duplicates:

Record # Address Field

49 100 MAIN ST #101

72 100 MAIN ST

• Match Exact — When Duplicate Check finds records with duplicate addresses, it will 
only tag records as duplicates if their suite numbers also match (suite numbers must 
be entered in the Delivery Address field).

Name Matching 
• Match To Blank — Duplicate Check will view records as a match if they have the 

same phone number but one contains a name and the other does not. For example, 
the following records would be considered duplicates:

Record # Name Field Phone Field

101 Francis Wang (949) 492-7000

189 (949) 492-7000

• Match Exact — When Duplicate Check finds records with duplicate addresses, it will 
only tag records as duplicates if their names also match.

Keep Record
• Lowest — For a set of duplicate records, Duplicate Check will keep the record with the 

lowest record number and tag the rest as duplicates.

• Highest — For a set of duplicate records, Duplicate Check will keep the record with 
the highest record number and tag the rest as duplicates.

• In Master List — For multiple lists, Duplicate Check will check for duplicate records 
against the secondary lists only, and not within the master list. Duplicate records will 
be tagged in the secondary lists, not in the master list. For more information on multi-
ple lists, see Multiple Lists on page 60.

• Most Complete — Among a set of duplicate records, Duplicate Check will keep the 
record with the most information in the Name and Address fields and tag the rest as 
duplicates.
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• Mark Duplicates for Deletion — Duplicate Check will automatically mark for deletion 
all but one dBase record it tags as duplicates. It will not mark records kept as originals. 
This check box must be selected for records to be marked for deletion, otherwise, 
duplicate records will only be displayed but not marked for deletion. Duplicate Check 
does not actually remove records from your list. Use the Pack feature in the Database 
Manager to remove records marked for deletion. For more information on the Pack fea-
ture, see Packing Records on page 146.

• Save Settings As Default — Duplicate Check will save the options you currently have 
selected so they can be applied to each new list.

• Click Format to format fields for Duplicate Check. For more information, see Format-
ting Fields for Duplicate Check on page 61.

• Click Filter to adjust the range of records being processed.

• Click Cancel to exit Duplicate Check and return to the main screen without saving any 
changes.

• Click Go to begin Duplicate Check.

MULTIPLE LISTS
Multiple Lists lets you find duplicates shared between two or more lists (up to 15 lists): the mas-
ter list (which is the currently selected list) and secondary lists. Multiple Lists checks for dupli-
cates in each list that is opened. 

The steps for Duplicate checking multiple lists have changed with the introduction of the new 
MAILERS+4 interface. Read the following steps carefully.

To use the multiple lists feature:

1. If you do not already have the master list open, select File > Open to open it.

2. Select List > Duplicate Check > Multiple Lists. The Duplicate Check Options dia-
log box opens. Make the appropriate selections. See Running Duplicate Check on 
page 58 for more information on the available options.

3. Click Next. The Duplicate Check Multiple List Options screen opens. 

4. Click Open. MAILERS+4 displays an open file dialog.

5. Select the next database file or MAILERS+4 file to be included and click Open.

6. Click Format to format the new database, if necessary.

7. Click Filter to limit the records included from the new file.

8. Repeat for every file to be included in this duplicate check.

Duplicate Check will arrange your secondary lists in alphabetical order when it compares them to 
your master list. Multiple Lists will not actually combine lists or change record numbers.
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9. Select a file and click Close to remove it from the duplicate check. Click Close All to 
remove all of the secondary lists.

The Multiple List selection screen.

10. Click Go to begin processing your lists. Using its internal memory, Duplicate Check will 
temporarily add the secondary lists to the end of the master list. 

FORMATTING FIELDS FOR DUPLICATE CHECK

Required Fields
The following fields must be formatted in order to run Duplicate Check. To format fields, click 
Format in the Duplicate Check Options dialog box.

• Address — The field that contains the address you want the Post Office to deliver the 
piece to.

• City — The field that contains the city name.

• State — The field that contains the state name or abbreviation.

• ZIP — The field that contains the 5-digit ZIP Code.

• City/St/ZIP — The field that combines the city, state, and ZIP Code. (This field is not 
required if the City, State, and ZIP fields are formatted.)

• Full Name or Last Name — The field in your list that contains the full name or last 
name (only required when locating duplicates by “Name & Address” or “Name & 
Phone”).
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• Phone Number — The field in your list that contains the telephone area code and 
number (required if checking for duplicates by phone numbers).

Recommended (Optional) Fields
• Dup Error — A “D” in this field indicates the record is a duplicate. Search for records 

with a “D” in the “Dup Error” field when you are in your database management program 
and want to delete duplicate records.

• Dup Group — Duplicate Check assigns a number to each “group” of original and 
duplicate records. To see an original and its duplicates, index on the Dup Group field.

• First Name — The field in your list that contains the first name. 

DUPLICATE CHECK RESULTS
When Duplicate Check has finished checking your list, a results screen will display. You can also 
view Duplicate Check results by selecting List > Duplicate Check > Results from the main 
screen.

The Duplicate Check Results screen

If you have not formatted fields for Duplicate Check, click the Format button in the Duplicate Check 
Options dialog box. See Formatting Lists on page 23 for more information.

See Duplicate Check on page 200 for information on fields available for formatting in Duplicate 
Check.
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The results screen displays Duplicate Check results for both single and multiple lists. You can 
view duplicates by clicking View, and proof them before printing a report by clicking Print Pre-
view and then Print.

VIEWING DUPLICATE RECORDS
If you click View from the Duplicate Check Results screen, a window displays showing all of 
the duplicate records that were all the duplicate records found according to the options set in the 
Duplicate Check Options dialog box. You can use your mouse to click on any record field 
before editing its contents with the insertion point. 

If you used Multiple Lists, the letter “A” next to a record means that the record is in the primary 
list; the letter “B” (“C, D, E, and so on) means the record is in a secondary list. Use the arrow 
keys to move around in the window. 

Tagging/Untagging Duplicate Records
The Duplicate Check Results screen allows you to see which records have been tagged as 
duplicates. These records have a narrow column on their far left-hand side with a black bar in it. 
This column is the Delete column. You must have formatted a Dup Error field in order to tag 
and untag records.

The DELETE and INSERT keys on your keyboard toggle the tagging and untagging of records 
as duplicates.

Pressing the DELETE key will retag this record for deletion. If you find a record that is tagged as 
a duplicate (that you want to keep), press the INSERT key to remove this mark from the Delete 
column. 

Deleting Duplicate dBase Records
When the Mark Duplicates for Deletion check box is selected (while using a dBase list), tag-
ging records as duplicates will automatically mark them for deletion. This check box is normally 
disabled and must be selected to activate this feature. The narrow column before the first field is 
the Delete column. This column is filled in when records are marked for deletion. Using the 
Delete and Insert keys to tag and untag records as duplicates will toggle the marking and 
unmarking of the delete column. Use the Pack feature to remove tagged records from your list 
(For more information on the Pack feature, see Packing Records on page 146). Click OK to 
close this window.

Pressing the spacebar can be used to toggle the tagging and untagging of a record. 
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In this example, the records with the black marks in the left column have been marked for dele-
tion
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Presorting a List

OVERVIEW OF PRESORTING
Presorting is a procedure that allows the USPS to work 
faster and more efficiently. When you presort your mail, you 
are eliminating the need for the Post Office to do so. The 
savings to the Post Office in labor and resources are 
passed on to you, the mailer, in the form of lower postage 
rates for presorted mail. 

MAILERS+4 takes care of the front end of the process of 
presorting. It will take your mailing list and sort it according 
to class, weight, size and quantity to create a presorted 
mailing for maximum savings. When the requested infor-
mation is entered in the Presort Wizard, MAILERS+4 Pre-
sort will handle the process of figuring out which pieces 
qualify for each presort type and sort the list accordingly.

WHEN TO PRESORT MAIL
There are many different factors that govern whether you 
will receive any discount for submitting a presorted mailing. 
Keep in mind there can be more than one type of presort 
for which a mailing is qualified since size, weight, and distri-
bution of the mailing are used to determine eligibility.

In general, the Post Office sets the following rules:

• Presorting is required for all Standard Mailings. 
The USPS defines Standard Mail as impersonal 
messages and marketing material. To qualify for 
Standard Mail® presort discounts, a list must have 
a minimum of 200 pieces or 50 pounds of mail.

In this chapter...

Overview of Presorting ........................... 65

When to Presort Mail.............................. 65

Which Type of Presort to Use................. 66

Formatting Fields for Presort ................. 66

Presort Mailing Wizard........................... 71

Preparing a Presorted Mailing............... 76

Mailing Results ....................................... 85

Presort Reports ....................................... 85

Exporting Lists in Presorted Order ........ 87
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• Presorting is also recommended for First-Class Mail®, and discounts are offered for 
mailings with 500 or more pieces. First-Class Mail is defined as mail that contains bills, 
personal letters, or business transactions. 

The numbers mentioned here are the minimum. A mailing that has the minimum number of 
pieces does not necessarily qualify for all presort discounts. However, you will not be able to 
presort your list unless you meet the minimum piece requirement.

WHICH TYPE OF PRESORT TO USE
The content of your mailing list dictates the postal discounts that presorting provides. In general, 
the more pieces you group together by 3 or 5-digit ZIP Code, Destination, or Carrier Route and 
ZIP Code, the better the postage discounts you receive. Distribution of the proposed mailing is 
one way to judge eligibility. Nationwide mailings are unlikely to provide enough pieces to individ-
ual 5 or 9-digit ZIP Codes to qualify for rate reduction (although you will still receive an ADC or 
MADC discount). Local or regional mailings may have enough pieces to qualify for a basic pre-
sort but lack the density (number of pieces going to a specified area defined by ZIP + 4, Carrier 
Route and so on) needed to qualify for higher discounts. 

However, there are cases within a nationwide mailing when clusters of ZIP Codes are receiving 
enough mail to qualify for presorted rates. Qualifying for these rates can also be based on 
weight ratios. Although a particular mailing may not contain the quantity needed to qualify, the 
weight of the containers might meet the minimums set by the Post Office.

Since Presort calculates whether you have enough mail pieces to qualify for 5 and 3-digit rates, 
the Presort wizards will help you find your best discounts. We also suggest using Tally to evalu-
ate your list (for more information on the Tally feature, see Tally on page 123). 

FORMATTING FIELDS FOR PRESORT
To perform correctly, the Presort feature in MAILERS+4 needs to know where the data it 
requires is located in your list. If you have not already formatted fields for Presort, you need to 
do so before you start. For more information on formatting lists, see Formatting Lists on 
page 23. 

To access the Presort formatting screen, follow these steps:

1. Select File > Format Fields, or click Format in the Presort Wizard Suggested Mail-
ings screen.

2. Click the Presort tab.

Before presorting your list, you should run it through Address Check and Duplicate Check. This will 
ensure the accuracy of address data and the removal of duplicate records.
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The Presort Format screen

3. Format the required fields for Presort. Experienced users can access additional Pre-
sort fields by clicking the Advanced button. To exit and return to the previous Presort 
format screen, click Normal.

The Presort Advanced Format screen
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Required Basic Fields
The following fields must be formatted for using Presort:

• ZIP — Necessary for all mail sorting options.

• Plus4 — Required for automation mailings if the ZIP field does not have Plus4 Codes.

• CRRT — Used for Carrier Route sorting and it contains the Carrier Route code. This 
code is needed to sort First-Class Automation letters, ECR Automation Basic, Line of 
Travel (LOT), High Density, Walk Sequence, and ECR Regular mailings by individual 
carrier routes.

Required ECR Fields (Automation and Non-automation)
The following fields are used when presorting for the Enhanced Carrier Route subclass level. 

• LOT (Line-of-Travel) Number —This field contains the Line-Of-Travel number 
required for sortation in the Standard Mail, Enhanced Carrier Route subclass of the 
LOT Basic rate. It is available on the Advanced Address Check Format screen.

• LOT (Line-of-Travel) Order — This field uses the letters “A” or “D” to indicate an 
ascending or descending Line-of-Travel order. It is available in the Advanced Address 
Check Format dialog box.

• Walk Seq — This field contains a Walk Sequence number which allows your mail to be 
presorted in Walk Sequence order. The Walk Sequence number is required for Walk 
Sequence and High Density mailings. Walk Sequence mailings must be delivered to 
the Post Office with the proper paperwork, including a Walk Sequence Production Cer-
tificate, within 90 days of the Walk Sequence certification date. You must submit your 
mailing list to a postmaster or USPS licensed service bureau in order to get a walk 
sequence number assigned to the valid records in your list. The Walk Sequence pro-
cessing of your list is called DSF.

• Delivery Point — This field contains a 3-digit number composed of two numbers and 
a “correction digit.” These numbers, added to the 9-digit ZIP + 4 code, make up the 
Delivery Point Barcode and are needed for ECR regular Line-Of-Travel mailings and 
for the printing of accurate Delivery Point Barcodes.

Recommended Fields
• Endorsement — This field contains the optional endorsement line sort type code that 

can be included on your mailing labels.

• Presort Error — Presort inserts a “P” in this field if it finds invalid information for that 
record. 

If your list is in Walk Sequence order, it does not need to be presorted. You can print labels from 
this list in record order.
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To facilitate the preparation of mail pieces in packages and containers, you can format the fol-
lowing fields:

• Pkg Number — Pieces sharing this number are to be bundled together and delivered 
in package number order to the Post Office. 

• Container Number — This number identifies the container to which a piece or pack-
age of pieces belongs.

ADDITIONAL PRESORT FIELDS
The following fields are not required or necessary for you to complete your mailing and much of 
it is summarized on the various reports and postage statement. They are included for your use if 
you wish to store the information in your database. For more information about these fields, see 
your copy of the DMM from the U.S. Postal Service®.

• Container Type — Returns a one-character designator for the type of container 
assigned to the current mail piece.

• Container Line1 — Returns the first line of the label for container assigned to the cur-
rent mail piece.

• Container Line2 — Returns the second line of the label for container assigned to the 
current mail piece.

• CIN Code — Returns the three-digit Content Identifier Number for the current mail 
piece.

• Container Proc. Code — Returns the two-digit processing code for the tray assigned 
to the current mail piece.

• Sort Level — Returns the code for the sortation level of the container assigned to the 
current mail piece. See the table on page 222 for the possible values.

• Container ZIP — Returns the ZIP Code of the destination for the container assigned 
to the current mail piece.

• Package Sort Level — Returns the code for the sortation level of the package 
assigned to the current mail piece. See the table on page 222 for the possible values.

• Package ZIP — Returns the ZIP Code of the destination for the package assigned to 
the current mail piece.

• Destination — When presorting for SCF/NDC/DDU destination discounts, this field’s 6 
or 8-digit code (for example, SCFxxx) specifies the facility for which the record quali-
fies. 

If your mailing piece dimensions are over 10” long or 4 5/8” (4.625”) high, Presort will use the EMM 
container size to determine how to place mail pieces in 2’ EMM trays (1’ trays will not be used).



MAILERS+4 User’s Guide Presorting a List

70

• Destination Code — Returns the code for the destination discount assigned to the 
current mail piece. See the table on page 223 for a list of possible values.

• Rate Code — Returns the code for the postage rate assigned to the current mail 
piece. See the table on page 223 for a list of possible values.

• Label List — Returns a reference to the table number from the DMM containing rout-
ing information to confirm the rate code of the current mail piece. To look up the value 
returned on the Internet, see http://pe.usps.gov/text/dmm300/labeling_lists.htm.

• Mail Job — Returns the mail job code assigned to the current mail piece. See the 
table on page 221 for a list of possible values.

• Zone Code — Returns the zone abbreviation for the current mail piece Applies only to 
Periodicals mailings.

• Mail Entry ZIP — Returns the ZIP Code for the entry unit of the current piece.

• Mail Piece Rate — Returns the actual postage costs of the current mail piece.

• Sequence Number — Returns a number that designates the current mail piece’s posi-
tion in the Presorted list.

AUTOMATION VS. NON-AUTOMATION
Automation mailings receive lower rates than most non-automation mailings. MAILERS+4 will 
allow you to do a Standard (A) Non-automation mailing of less than 200 pieces or 50 pounds if it 
is mailed with an Automation mailing that meets the 200 piece or 50 pound qualification require-
ment.

Automation
• 100 percent of the final mailing must be CASS Certified and contain information to 

generate Delivery Point codes (9-digit ZIP + 4 plus 2-digit Delivery Point code). ZIP + 4 
and Delivery Point codes can be appended to addresses in Address Check. You can 
print Delivery Point codes on your mailing labels using Print Labels.

• Addresses must be verified using CASS Certified software (such as Address Check) 
every six months.

• Carrier Route information must be updated using a CASS-certified process (such as 
Address Check) within 90 days before mailing.

• Barcoded container labels are required.

Non-automation
• Address-checking software must be used once a year to match addresses to correct 

5-digit ZIP codes.

http://pe.usps.gov/text/dmm300/labeling_lists.htm
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PRESORT MAILING WIZARD
MAILERS+4 contains a Presort wizard that makes it very simple to prepare your presort mail-
ing. To start the Presort wizard, select List > Presort > Options.

Selecting a Template

Selecting a presort mailing template

Begin the process of presorting your mailing by selecting an existing template (saved from a 
previous mailing) or New Mailing (to create a new template). If this is your first Presort in MAIL-
ERS+4, you will not have saved templates to choose from and New Mailing will be selected by 
default. 
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Presort Settings
After selecting a Presort template, MAILERS+4 displays the Presort Settings screen.

Presort Settings

The Presort Settings screen is where you select or set the following options:

Post Office of Mailing

The Post Office of Mailing is the Post Office where you will be depositing this mailing with the 
USPS. If this is your first Presort in MAILERS+4 or you wish to use a different Post Office for this 
mailing, type the City, State, and ZIP + 4 (the +4 field is optional) of the Post Office your current 
mailing will originate from. To use this Post Office for future mailings, select the Save as default 
check box.

Mail Class
• First-Class — First-Class mailings are defined by the USPS as bills, personal letters 

or business transactions. For CASS certification, First-Class mailings require a mini-
mum of 500 pieces. Lists for First-Class mailings are also required to have Move 
Update verification performed on them within 95 days prior to their mailing date.

• Periodical — The USPS defines periodicals as subscription publications issued at 
least 4 times a year at specified intervals.

• Standard — Standard Mail (A) is defined by the USPS as impersonal messages or 
promotional pieces. For CASS certification, Standard (A) mailings require a minimum 
of 200 pieces or 50 pounds. Lists for Standard mailings are also required to have Move 
Update verification performed on them within 95 days prior to their mailing date.
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Mail Piece Type
Select Postcard, Letter/Card, or Flat to match the piece type of your mailing. Consult the 
Domestic Mail Manual (DMM®) if you are not sure of the requirements for each piece type.

Rate Type
• Profit — Applies to regular mail outside the nonprofit category. 

• Nonprofit — The processing of Nonprofit Mail is exactly like Standard Mail (A). The 
difference is in the rates that are charged. USPS Nonprofit rate authorization is 
required prior to mailing.

• Classroom — A special Periodicals rate available to educational, scientific, or reli-
gious publications that are used for scholastic or religious instruction.

• Science of Agriculture — A special Periodicals rate for agrarian publications (70% of 
the subscribers must be rural residents).

My Post Office of Mailing
Specify if you will be taking your mailing to a SCF (Sectional Center Facility) or a NDC (Net-
work Distribution Center). Depending on your selection, the mailing will be prepared differ-
ently, which in turn will affect your rate.

Sample Size and Weight
You must take a sample of your mailing and enter its dimensions and weight in order to deter-
mine the minimum and maximum container quantities. You will need to determine the height 
and width of a single mail piece, in addition to measuring the thickness and weight of a 10-piece 
(or greater) sample, to get accurate results. Using this data, Presort will automatically divide the 
thickness and weight by the sample number to find the average for each mailing piece. 

1. In the Number of pieces in sample field, type the number of mail pieces (for example, 
10) in your sample.

2. In the Sample Thickness in inches field, type the measured thickness of your sample 
(all 10 pieces). 

3. In the Sample Weight in field, type the weight, in ounces or pounds, of your sample 
(all 10 pieces). 

4. In the Height of mail piece in inches field, type the height (in inches) of a single piece 
of your mailing.

5. In the Width of mail piece in inches field, type the width (in inches) of a single piece 
of your mailing.

6. In the Aspect Ratio field, type the Width/Height ratio. The Aspect Ratio is the dimen-
sion of a mail piece expressed as a ratio of length (the direction parallel to the address) 
divided by height. You must meet USPS range requirements (1.3 to 2.5) to qualify for 
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postal discounts. The Aspect Ratio requirement only applies to Automation Let-
ters and Cards.

7. Select the FSM 1000 check box if your Post Office of mailing has this machine. This 
will allow you to presort oversize flats as part of your mailing.

8. In the Mail Processing Type area, select the Nonmachinable check box if the mail 
pieces in your mailing must be processed manually because of their size, shape, con-
tent, or address legibility. 

Postage Statement Information
From the Presort Settings screen, click Next. The Postage Statement Information screen 
displays. 

Entering postage statement information

If a mailing will be sent using the permit of a third party (not the user or list owner), enter the 
requested “Mailing Agent” information in the fields provided. Additional information may also be 
required, such as the actual “Mail Date,” “Seq (Sequence) #,” “Receipt #,” “Customer #,” “Agency 
Code,” and “CAPS/CTAS” (Centralized Account Processing System) number. 

Select the Move Update Method that you employ from the options on the right side of this dia-
log. This information will be included on the Postage Statement.

To follow the USPS method of calculating sample thickness, place 10 to 20 mail pieces in a 
container and tilt it at 45 degrees. After the pieces have compressed naturally you can measure the 
thickness of the stack (when calculating your sample thickness, allow for rubber bands and 
adhesive labels).
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Before clicking Next to advance to the Select Mailings screen, choose a postage payment 
option and whether or not to save your entries as the default setting.

Periodicals
If you selected the Periodicals mail class as the Mailing Type, the Periodical Information 
screen displays.

Publication Information
1. In the Publication Name field, type the name of your periodical (for example, 

MAILER’S MONTHLY).

2. In the Publication # filed, type the issue number of your periodical (for example, VOL 
2, ISSUE 8).

3. In the Date of issue field, type the publication date of your periodical (for example, 
AUGUST 1999).

4. In the Frequency field, type the annual number of issues for your periodical (quarterly 
is the USPS minimum).

5. In the Edition code/key field, type an identifying code for the periodical edition (for 
example, morning, evening, and so on). 

6. In the Advertising % field, type the percentage of advertising copy in your periodical 
(for example, 34.28).

7. If Barcoded Mail is checked, MAILERS+4 will use the barcoded rate for any pieces. If 
the box is unchecked, the unbarcoded rate will be used for all pieces in the mailing.

8. Select the Use In-County check box to receive an In-County discount for mail deliv-
ered within your county of mailing (Presort provides the County Number). The FIPS 
code of qualifying records must match your Post Office FIPS code.

The County Number is a 3-digit code that is taken from the Post Office of mailing ZIP Code and it 
also appears in the FIPS code.

You must have a formatted FIPS field in your mailing list (with the correct 5-digit code information) 
to qualify for In-County rates (Address Check can provide this information).
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Specifying information for periodicals

9. In the Subscribers box, select All if all of your records are subscribers, None if all of 
your records are nonsubscribers, and Subscriber field if your list has a field to indi-
cate the records that contain a subscriber. The USPS defines a subscriber as an 
individual or organization that is paying more than a nominal rate for a specified 
period.

10. In the Additional Information box, select the News check box if your periodical is 
published once a week or more.

PREPARING A PRESORTED MAILING
As with any function within MAILERS+4, you must first have a list opened and formatted (see 
Opening a Mailing List on page 15 and Formatting Lists on page 23 for more information).

1. Open the Presort Wizard by selecting List > Presort > Options. The Presort Wizard 
screens takes you sequentially through the presort process (see Presort Mailing Wiz-
ard on page 71), prompting you at each step for the required information.

2. When you have entered all the necessary information, the Presort Wizard Suggested 
Mailings screen displays.



Preparing a Presorted Mailing MAILERS+4 User’s Guide

77

T

The Presort Wizard Suggested Mailings Screen

From here you can Format your list for Presorting, Filter your records to include a 
desired Presort range, add or remove SCF/NDC/DDU Destinations, Customize your 
list by including additional data in your mailings, or go Back to return to the previous 
screen.

3. Click Go when you are ready to begin, or Cancel to exit and return to the main screen.

ACS Options
When you chose either ASC or OneCode ACS as your Move Update method, you will need to 
choose what type of ACS to run. Your choices wil be: ASR Option 1; ASR Option 2; CSR Option 
1; and CSR Option 2.

You can deselect a mailing in the Suggested Mailings window by selecting its check box to remove 
the check mark. This mailing will not be processed when you presort your list.
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If you are not sure what type to choose, you can ask your Post Master or refer to the OneCode 
ACS Technical Guide which is avaliable on the RIBBS Web site.

Mail.dat Options
Mail.dat options are only availble if you are doing First-Class or Standard mailing. 

Mail.dat
You will need to pass the TEM test from the USPS in order to submit your mail.dat files.

• License Code - This is the code that IDEAlliance assigns you when you sign up 
to do Mail.dat. It is sometimes called “Provider Code” by IDEAlliance.

• Contact Name - The person the Post Office should contact if there is a problem 
with the mailing.

• Phone - The contact Name’s phone number.

• Verification Facility Name - The name of the post office where you drop off your 
mail.

• Verification Facility Zip+4 Code - the ZIPcode and plus 4 of your Post Office.

• Path to Mail.dat output files - The directory where you want the Mail.dat file out-
putted to.

Full Service IMb
• Auto - Mailers+4 will automically generate the IMb serial number.

https://ribbs.usps.gov/acs/documents/tech_guides/OneCodeACSTechnicalGuide.pdf#page=17
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• Manual with Starting # - this allows you to choose the starting IMb Serial num-
ber.

• User Defined Field - This is if you have formatted a field in your database as IMb 
serial number.

Destinations (SCF/NDC/DDU)
Bringing Standard Mail to a Sectional Center Facility (SCF), Network Distribution Center (NDC) 
or a Destination Delivery Unit (DDU) can reduce postage costs substantially. (DDU is only avail-
able for CRRT sort.) 

The USPS requires at least 200 pieces or 50 pounds to be mailed from a destination in order to 
qualify for a destination discount. To find out if your mailing may qualify for SCF or NDC dis-
counts, run Tally on your list (see Tally on page 123 for more information). DDU qualified pieces 
can be totaled using your database manager. If you have more than 200 records, or enough 
records to account for 50 pounds or more of mail going to a single SCF, NDC, or DDU, you may 
get a destination discount if you mail those pieces directly from that SCF/NDC/DDU.

If you have enough pieces to qualify for SCF/NDC/DDU discounts, Presort will sort each 
SCF/NDC/DDU group separately (See Mailing Results on page 85).

Selecting Destinations
Presort will highlight the SCF/NDC destination closest to the ZIP Code in the Post Office of 
mailing screen. The Destination Discounts screen lists all SCFs and NDCs loaded in the pro-
gram. However, as a result of the large number of DDUs, the DDU list has been intentionally left 
blank, so you must enter your DDU information before Presort will process data to that level.

You may wish to compare the labor costs involved in preparing and delivering Destination Discount 
mailings with the resulting savings in postage. 

If a selected DDU Destination has more than one ZIP Code, you can include all its ZIP Codes at the 
same time instead of adding the DDU with each ZIP Code (for example, 92614, 92615, 92616 for 
Irvine). The first ZIP Code you enter must be the ZIP Code for your DDU’s Post Office.
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The Destinations dialog box

To select or deselect NDC/SCF/DDU locations:

1. Click Destinations in the Presort Wizard Summary screen. The Destination Dis-
counts dialog box opens.

2. Click on a facility’s name, and then click Add SCF, Add NDC, or Add DDU, to choose 
the desired destination. Your choice appears in Selected Destinations box.

To remove NDC, SCF, or DDU destinations, highlight the facility you wish to remove in 
the Selected Destinations box, and then click Remove. That facility will be removed. 

3. To add or remove DDU facilities, click Edit DDUs. When the DDU Editor dialog box 
opens, click New or Delete to modify data in the Destination fields. Click OK or Cancel 
to accept or ignore your changes.

4. In the Sort Destinations box, click by ZIP or by Name to indicate how destinations 
will be displayed in the list boxes.

5. Click OK to save your destination data and return to the Presort Options screen.
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Customized Options
MAILERS+4 provides customized options for various types of presort mailings. Depending on 
the type of presort mailing you are doing (postcard, letter/card, or flat), the available options will 
vary slightly.

Standard Letter/Card

Tray Options screen

The Tray Options screen lets you specify the minimum and maximum number of mail pieces 
that will be contained in each tray and in each package. You can also specify if the mailing will 
be barcoded or not.
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Sort Options screen

The Sort Options screen lets you determine if a a 5-digit sort or 3-digit sort should be used. If 
the 5-digit sort options are not selected, a 3-digit sort will be used.

Sort Options screen

The options in this screen let you specify the minimum number of pieces and walk sequence 
options.
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Standard Flat/First-Class Postcard

Sack Options screen

The Sack Options screen lets you specify the weight for each mail sack, to prevent the sack 
from being too heavy to be carried. Depending on the weight of the sack, the number of mail 
pieces in the sack will differ. You can also specify the maximum size of each package, and the 
number of pieces within the package.
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Periodicals (Letters)

Tray Options screen for periodicals

This screen lets you specify the minimum and maximum number of pieces for each tray size, 
and the number of pieces in each sort level. You can also specify the number of pieces for each 
package.

Periodicals (Flats)
The customize screen for Periodicals flats contains two additional check boxes for optional tray 
preparation. According to DMM 707.25.6:

As an option, mailers may place in flats trays machinable pieces prepared that would normally 
be placed in sacks. Mailers must either bundle or group together all pieces for each 5-digit 
scheme, 5-digit, 3-digit scheme, 3-digit, SCF, and ADC destination. Bundling is not permitted 
unless it achieves a finer presort than the presort destination of the tray. The trays are subject to 
a container charge, and any bundles are subject to a bundle charge.

• Check Tray Preparation to use this option.

• Check Do Grouping to using grouping instead of bundling.
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MAILING RESULTS
The Mailing Results screen appears when presorting is finished. You can also reach this 
screen by selecting List >Presort > Results.

The Presort Results screen

A piece count is displayed for each mailing your list was sorted to, in addition to the total cost for 
sorting by that option. All pieces that do not qualify for presort discounts will be displayed as a 
Residual Mailing. There is also a summary of the total pieces to be mailed, overall postage 
costs, and savings compared to unsorted.

After presorting your list, you can view or print presort reports and print your labels using the 
Print Labels feature (see Printing Labels on page 89) or export your list in presorted order to 
print labels in another program. 

PRESORT REPORTS
Mailing reports contain tray numbers, package types, 5-digit ZIP Codes, 3-digit ZIP Codes, 3 
and 5-digit ZIP Code schemes, Carrier Routes, EMM containers (where applicable) plus totals 
for each classification.

Viewing, Printing, and Saving Reports
From the Mailing Results screen, click Next. The View Reports screen displays.

On the Reports screen, users can choose which reports to include with their mailing. Simply 
click the desired mailing in the Mailings area, and then select a desired report option.



MAILERS+4 User’s Guide Presorting a List

86

The Presort Reports Screen

• Qualification Report — (Required) This report provides a detailed summary of the 
contents of each container.

• Mailing Summary — This report provides a brief summary of the information returned 
in the qualification report.

• Presort Parameters — This report provides a summary of the sortation and options 
selected for the current mailing.

• Zone Listing — This report only applies to Periodicals mailings. It is only available 
when the Periodical mailing class is selected from the Presort Wizard.

• Bundle Report — Also used only for Periodicals.

• Postage Report — (Required) This report produces the Postage Statement for the 
current mailing.

• Tray and Sack Tags — This option prints the container tags for this mailing in the 
standard IMB format.

• Whittier Mail — This option outputs the container tags in a file formatted for use with 
Whittier Mail printers.

Once a report has been selected, click Print to create a hard copy, View to view a PDF version 
of the report, and Export to output the selected mailing (in Presort order) using the same format 
as your list. 
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EXPORTING LISTS IN PRESORTED ORDER

MAILERS+4 can export your mailing list in presorted order. This feature is particularly useful if 
you create a mailing template in another program and want to mail merge your list with it. For 
more information on the MAILERS+4 Mail Merge feature, see Mail Merge+ on page 161.

To export your list from MAILERS+4 in presort order:

1. Select List > Presort > Results.

2. Click Next until you arrive at the Presort Reports screen.

3. Click Export. The Save As dialog box opens.

4. Type a name for your presorted list and choose the directory you want to save your list 
to.

5. Click Save.

After exporting a list, you will have a file you can use for your mail merge. MAILERS+4 Presort 
will export your list in the format in which it was opened (dBase files are exported as dBase files, 
and so on). The program also saves all the fields that exist in each record, not just the informa-
tion that has been formatted in MAILERS+4.

BACKING UP PRESORT TEMPLATES
MAILERS+4 allows you to save your presort settings as a template that can be re-used every 
time you presort a list without having to select the various options again. These settings are 
stored in a file called mp4w32.dat in the MAILERS directory.

The backup files allow you to restore your MAILER+4 settings if the original files are overwritten 
or lost for any reason.

Only mailing lists with the .dbf or .txt extensions can be exported in presorted order. Mailing 
lists created in Microsoft Excel or Microsoft Access cannot be exported.
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Printing Labels
You can print mailing labels, envelopes, and container tags 
directly from MAILERS+4 using the Print Labels feature. 

This feature lets you design your own label layout using 
fields from your list. You can even add extra text to all your 
labels and save a layout for future mailings. You can also 
specify the order of your label printing by putting labels in 
record, presort, or ZIP Code order. Before you begin, how-
ever, you must have a formatted list open in MAILERS+4.

WHEN TO USE PRINT LABELS
In order to receive the best postage rates and quickest 
delivery time, we recommend running your list through 
Address Check, Duplicate Check, and Presort before print-
ing labels for a mailing. In Address Check, MAILERS+4 
can verify and standardize addresses and ZIP Codes in 
your list, as well as add +4, Carrier Route, and other postal 
codes. Presort puts records in the proper order to receive 
postage discounts. You must run a list through Presort in 
order to print labels in presort order.

PRINTING LABELS
To print labels, select List > Print Labels > Address 
Labels. The Form tab for printing labels displays.

In this chapter...

When to Use Print Labels ...................... 89

Printing Labels ........................................ 89
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Form Tab
Defining a Label Type
To define the label type, choose the desired label. The Selected Label field displays the label 
type currently selected (the type of label you will be printing on). The selected label is also high-
lighted in the Label Description column. 

• To change label types, click the desired label. If your label is not listed, you can edit 
existing label types or create new ones. For more information, see Editing a Label 
Type on page 90 or Creating a New Label Type on page 92.

• To remove a label type, highlight it and click Delete. 

• To reload default forms for all your labels and to undo the changes you made to them, 
click Restore. 

After defining your label on the Form tab, click Next. 

The Form tab

Editing a Label Type
If your label format is not listed in the Form tab, you can edit an existing label (for example, if 
your label is 3 x 15/16 1-Up, select a 4 x 15/16 label type).

1. Select a label in the Forms tab. The label appears in the Selected Label field.

2. Click Edit. 
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Editing a label

3. Fill in all the options listed in the dialog box. If an option does not apply to your situa-
tion, enter a “0” instead of leaving the field blank.

• Label Description — Currently selected label type.

• Height — Label height for labels and print area height for all others.

• Width — Label width for labels and print area width for all others.

• Labels Across — Number of labels across a page.

• Labels Per Page — Number of labels per page.

• Paper Length — Total page length (for example, 11” if the paper is 8.5” x 11”).

• Top Margin — Space from top of page to first line of print area.

• Left Margin — Space from left edge of page to first character of print area.

• Columns Between — Number of text columns between labels.

• Lines Between — Number of lines between labels. 

Most pin feed labels have a top margin of zero and a left margin of zero. Laser printers default to a 
1/2” margin at the top and bottom of a sheet of labels.

Letter and envelope height is determined by subtracting the top margin from the paper length.
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Label definitions

4. Click Save to keep your edited label description or Cancel to ignore any changes. 

Creating a New Label Type
If your label does not closely match any label type in the Form tab, you will need to create your 
own label type. This process is very similar to editing a label.

1. In the Form tab, click New. A blank Label Definition dialog box displays.

2. Type a description in the Label Description field.

3. Type in the height, width, top margin, left margin, lines between, columns between, 
number of labels across, labels per page, and paper length. Avoid leaving any selec-
tion blank on the Label Definition screen. Type “0” instead, so MAILERS+4 will let you 
add your label.

4. Click Add to save the label or Cancel to ignore any changes.
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Template Tab
After you have specified the dimensions of your label form, click the Template tab. 

The Template tab

This tab is used to enter and manipulate the actual content of your address labels. Select your 
layout choices in the Template Name area. If you are using a saved layout, its file name 
appears in the Selected Template field. You can preview the content of your current layout in 
the View of Template area.

Defining a Label Layout
Defining a label layout means telling MAILERS+4 where you want specific information to appear 
on your mailing labels. You can decide which fields you want to use for your labels, add text and 
punctuation, and change the alignments and typefaces used.

To edit a saved template file or design a new label layout, click the New or Edit buttons in the 
Template tab. A Template Layout dialog box opens.
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Defining a label layout

In the upper left corner of the screen is the Field Names area that lists all the formatted fields in 
your mailing list. The Template Layout area displays the layout as it will appear on your labels.

To define your layout:

1. In the Template Layout area, place the cursor where you want a field (or text) to 
appear.

2. In the Field Names area, double-click the desired entry, or select the desired field 
name and then press the arrow button to the right of it. If you want to include specific 
text, type it directly in the Template Layout area. Any text or punctuation you enter will 
appear on all labels but will not affect your records (The USPS recommends avoiding 
any punctuation on addresses).

3. To begin a new line on the label, click New Line or press the Enter key on your key-
board.

4. To change the typeface (bold, italics, underline) of fields or text, place the cursor at the 
beginning of the field/text you want to change. Then double-click the desired com-
mand, or select the desired command and then press the arrow button to the right of it. 
A command symbol appears in the Template Layout field. This symbol will not appear 
in your labels. Next, place the cursor where you want to end the typeface change and 
apply the corresponding “off” command (for example, Bold Off). Another command 
symbol will be inserted in the Template Layout area. You can choose more than one 
typeface option at a time. 

When you are designing a mailing label layout, remember that the USPS considers the line directly 
above the city, state, and ZIP Code to be the delivery address.
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5. If you want to center or right-justify a line in your label, place the cursor at the begin-
ning of that line and then apply the Center or Right Justify command. These com-
mands only affect the line where the command symbol was entered. If you want every
line in your label centered, you must apply the Center command on each line.

6. If you are using a Windows driver, you can change the appearance of your label’s
fields by using the Font button. You can switch fonts and change their size, style, color,
and effect.

7. When you are finished designing your label, you can keep the layout as a template for
future mailings. Saving your layout will enable you to reprint these labels without rede-
signing them. To save your layout, type a layout name in the Template Name field and
click Save.

To exit the layout screen without saving your changes, click Cancel. If you change your
mind after returning to the Template tab, click Delete to erase the entire template.

8. After designing your label, click Next to continue or Back to return to the Form tab.

Sequence Tab
Use this tab to choose the range, order, and sequence of label printing, and to restart jobs that 
have been interrupted.

Print Order
• Record —This option prints labels in record number order.

• ZIP —This option prints labels in numeric ZIP Code order.

• Presort — Use this option to print labels in presort order. You will only be able to print
labels in Presort order after presorting your mailing list.

Print Sequence
The Normal and Reverse sequence options can be applied to all three print orders: Record, ZIP, 
and Presort. 

• Normal — This option prints labels in ascending order.

• Reverse —This option prints labels in descending order.

Avoid using fonts with a size of less than 8 points. Check with the USPS for more information on 
their label requirements.



MAILERS+4 User’s Guide Printing Labels

96

The Sequence tab

Print Range 
• All Pages — Includes all your labels in the range of pages to print.

• Select — Allows you to define which pages or labels to print.

Intelligent Mail® Barcode
The Intelligent Mail® barcode is the new standard and becomes mandatory in May 2011. It com-
bines the capabilities of the POSTNET barcode and the PLANET Code® barcode into one 
unique barcode.

To use Intelligent Mail barcodes instead of POSTNET on your mailing labels, check this box.

Restart Mode
If label printing is interrupted, you can restart printing from the last label printed. To choose the 
next label to print, click Find Page in the Sequence screen. To print the entire mail job, click All 
Pages.

Some older label printers do not support Intelligent Mail barcodes. In order to print them, it may be 
necessary to upgrade your hardware. Modern inkjet and laser printers should be able to print them.

When your Sequence/Print Order is set to Presort, you can only use the Find Page function if no 
more than one job (sort) is selected in the Job List area in the Presort Options tab. Check the Job 
List area before beginning your search to make sure you have the right job selected.
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1. In the Enter Text To Search field, enter some text (name, address, and so on) from 
the last label printed. Use the Search and Printing boxes to specify a record, ZIP Code, 
or container range to search and the pages or labels to print. 

2. Click Search. MAILERS+4 will search for a record containing your text and display it in 
the Found Label box.

The Sequence tab Find Page option

3. If the label information in the Found Label box matches the label you want to start 
printing from, click Finish to return to the Sequence tab. You can click the Summary 
tab and click Print to resume printing. If the label information does not match the label 
you want to start printing from, click Search (again) to find the next record with the text 
you entered.

4. To restart your search using different text, click Reset and enter the new text before 
clicking Search again.

5. To abort a search in progress, click Stop. To quit searching without saving your loca-
tion, click Cancel.

Presort Options Tab
If you presorted lists in MAILERS+4, you can select a mailing and print its labels in presorted 
order by using the Presort Options tab. 

If you do a full name search for a specific page, the name you enter must have the same number of 
full name characters as the full name field in your label template (including the number of spaces 
between the first and last name of your full name).
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In the Separator Label area, choose one of the following options:

• None to allow the entire list to print without any pauses or breaks.

• Marker (#) to signify a change in package/container numbers (for automated label 
machines)

• Pause to momentarily stop label printing between changes.

• Blank Label to indicate any changes.

• Header Label to print a descriptive summary of the next package/container. 

The Presort Options tab

You can also print Endorsement Lines on the first, last, or every label by selecting this option 
while here.
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Print To Tab
Use this tab to choose a printer and specify lines per inch (LPI), characters per inch (CPI), and 
printer port settings.The 12 LPI option is only available for the Taneum 618+ printer. Use the 
Generic Text option (in the Printer List area) if you have a printer that generates USPS bar-
codes.

The Print To tab
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Summary Tab
After you have prepared your labels, use the Summary tab to display your results. From here, 
you can click Back to return to the previous screen, Print Sample to align the label template 
with your labels, Preview to proof your layout before printing, Print to print out your labels, and 
Cancel to exit Print Labels. Layout and print settings information also appear here. If you have a 
Windows printer driver, you can define the printer (or emulation) you will be using from the 
Printer Name drop-down box.

The Summary tab

Before clicking Print on the Summary tab, you must choose and configure your printer in the Print 
To tab.
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Selecting a Printer
If you are using a Windows driver, you can access the Print dialog box by clicking Print from the 
Summary tab. 

The Print dialog box

• Printer Name — This pull-down menu shows printers supported in MAILERS+4. To
change the printer, click on the arrow button to the right of the name field and highlight your
selection.

• Printer Type — This box shows the printer selected to print the labels.

To change the current printer:

1. Click the Printer Name drop-down arrow.

2. Click on the printer type you wish to use. The new printer appears in the Printer Type
box.

If your printer uses a non-Windows driver, click the Print To tab and highlight your printer in the 
Printer List area. Its name then appears in the Printer Name field. You can also specify the 
lines per inch, characters per inch, and printer port.
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BACKING UP LABEL TEMPLATES
MAILERS+4 allows you to save your label settings as a template that can be re-used every time 
you print labels without having to set up the format each time. These settings are stored in a file 
called mp4w32.dat in the MAILERS directory. 

The backup files allow you to restore your MAILERS+4 settings if the original files are overwrit-
ten or lost for any reason.
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Reports
The powerful report generator within MAILERS+4 will not 
only help you create the documentation required by the 
USPS when you submit automated and presorted mailings, 
it will also provide additional reports that can help you with 
marketing decisions, list acquisitions, and more.

You can access any results report that applies to your mail-
ing by selecting the Results sub-menu of its associated 
feature in the List menu. The Results sub-menu of a 
report’s associated feature will be grayed if the report has 
not been generated. For example, the Results sub-menu 
of Address Check in the List menu will not be available 
until you Address Check your list.

USPS REQUIRED REPORTS
The following reports must be submitted to the Post Office 
with your mailing:

• CASS (3553)

• USPS Qualification Report

• Postage Statement (3602)

In this chapter...

USPS Required Reports ....................... 103

Additional MAILERS+4 Reports ......... 107
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CASS (3553)
This form (or a USPS-approved facsimile) must accompany your mailing in order to qualify for 
automation discounts. Print this form by selecting List > Address Check > CASS Form. 

CASS form
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USPS Qualification Report
The USPS Qualification Report includes tray numbers, package types, 5-digit ZIP Codes, 3-digit 
codes, and totals for each classification. A separate USPS Qualification Report is required for 
each qualified mail job. Print this report by selecting List > Presort > Results, clicking Next 
twice, selecting Qualification Report, and then clicking Print.

USPS Qualification Report
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Postage Statement (3602)
This report is accessed from the Reports screen by clicking Postage Report. This will open the 
Postage Statements screen where, you can print your report.

Postage Statement (3602)

Name and Address of Individual or
Organization for Which Mailing Is Prepared

Name and Address
of Mailing Agent 

Type of 

Postage

 No. and type of Containers

U
S

P
S

 U
s
e

 O
n

ly

Postmaster:  Report Total Postage in 

(Permit Imprint Only)

For postage affixed add additional payments to net postage due;
for permit imprint  add additional payment to total postage. 

  Total Adjusted Postage Affixed

The mailer's signature certifies acceptance of liability for and agreement to pay any revenue deficiencies assessed on this mailing, subject to appeal. If an
agent signs this form, the agent certifies that he or she is authorized to sign on behalf of the mailer, and that the mailer is bound by the certification and
agrees to pay any deficiencies. In addition, agents may be liable for any deficiencies resulting from matters within their responsibility, knowledge, or control.
The mailer hereby certifies that all information furnished on this form is accurate, truthful, and complete; that the mail and the supporting documentation
comply with all postal standards and that the mailing qualifies for the rates and fees claimed; and that the mailing does not contain any matter prohibited by
law or postal regulation. I understand that anyone who furnishes false or misleading information on this form or who omits information requested on this form
may be subject to criminal and/or civil penalties, including fines and imprisonment.

Post Office: Note Mail Arrival Date & Time

If Sacked, Based on For Mail Enclosed within Another Class

For USPS Use Only:  Additional Postage Payment 

Net Postage Due 

Postage Statement — Standard Mail

Permit Holder's Name and Address and
Email Address, If Any

 Mailing Date

Customer No. 

CAPS  Cust. Ref. No.

Customer No. Customer No.

For Enhanced Carrier Route Rate Pieces, Enter Date of
Address Matching and Coding

 Signature of Mailer or Agent  Telephone

 Rate at Which Postage Affixed (Check one) 

Correct Lowest Neither

(Add parts totals)

United States Postal Service

 (Subtract postage affixed from total postage)

_________ pcs. x $ _____ . ______ =

____ . ____ ____ ____ ____ pounds

Round Stamp    (Required)

 Contact Date Mailer Notified

PS Form 3602-R1, May 2007 (Page 1 of 11)  PSN 7530-07-000-6209             This form and mailing standards available on Postal Explorer at pe.usps.com.

AM
PM

NoYes

 Telephone

 (If other than permit holder)

 Statement Seq. No.

 Weight of a Single Piece

(If other than permit holder)

        ____ . ____ ____ ____ ____  pounds

Telephone

0

Printed Name of Mailer or Agent Signing Form

 Total Pieces

 Total Weight

Permit Imprint

Metered

Precanceled Stamps

Bound Printed Matter Library Mail 125 pcs 15 lbs.

For Automation Rate Pieces, Enter Date of Address
Matching and Coding 

____ ____ / ____ ____ / ____ ____ ____ ____ ____ ____ / ____ ____ / ____ ____ ____ ____

(State reason)

 Federal Agency Cost Code

C
e

rt
if
ic

a
ti
o

n
P

o
s
ta

g
e

M
a

ili
n

g
M

a
ile

r

  Total Adjusted Postage Permit Imprint

Post Office 

of Mailing

Permit #

Parts Completed (Select all that apply)

Postage Affixed

LB C D F GEA H

Total Pieces Total Weight

Total Postage

 Verifying Employee's Signature

0

Periodicals

Parcel Post both

For Enhanced Carrier Route Rate Pieces, Enter Date of

Carrier Route Sequencing 

____ ____ / ____ ____ / ____ ____ ____ ____

I J K S

Total Postage 

AIC 130

Privacy Notice:  For information regarding our Privacy Policy visit www.usps.com.

Media Mail

 Are postage figures at left adjusted from 
 mailer's entries?  If "Yes" state reason.

 By (Initials)

Weight of a Single Piece

TimePrint Verifying Employee's Name

Yes No

 Presort Verification Performed? (Check one)

 I CERTIFY that this mailing has been inspected
concerning: (1) eligibility for postage rates claimed;
(2) proper preparation (and presort where required);
(3) proper completion of postage statement; and
(4) payment of annual fee (if required).

_____  Sacks

_____  1 ft. Letter Trays

_____  2 ft. LetterTrays

_____  EMM Letter Trays

_____  Flat Trays

Processing Category

CMM

NFMFlats

Letters

Parcels - Irregular

Letters - Paid as NFMs

ECR Letters - Paid as ECR Flats

Parcels - Machinable

_____  Pallets

_____  Other
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ADDITIONAL MAILERS+4 REPORTS
Many MAILERS+4 features will create reports detailing their results. These reports can be 
accessed from the Results screen of each feature. You can also view these screens by select-
ing the Results sub-menu of each associated feature from the List menu of MAILERS+4. 

Error Preview Report
Displays the records that Address Check was unable to code.

Address error report
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Duplicate Check Results Report
Displays the duplicate records that Duplicate Check found in your list.

Error Preview Report

Presort Result Reports
By clicking Postage Report from the Presort Results screen, you can access the Postage 
Statement for your mailing. You can also access the Qualification, Mailing Summary, Presort 
Parameters, and Zone Listing reports from the Presort Results screen. For more information 
on presorting a mailing list, see Presorting a List on page 65.
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Mailing Summary Report
This report breaks down your presorted mailing by tray, mail type/count, and destinations.

Container Report
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Presort Parameters Report
This report details your mailing list and its presort results.

Parameters Report
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Phone Check Results
Displays the number of area codes updated in your list and summarizes any distance errors 
found in the telephone numbers of your list. Print this report by selecting List > Phone Check > 
Results, and then clicking Print. 

Phone Check Results Report



MAILERS+4 User’s Guide Reports

112



113

Phone Check

MAILERS+4 Professional Only
Phone Check verifies the area code and prefix of phone 
numbers by comparing them to an up-to-date database 
included with MAILERS+4. It will also check the distance of 
a record’s telephone number to its ZIP Code. If the tele-
phone number is located too far from the ZIP Code, a “D” 
will appear in the Phone Check “Error” field.

For example, if your record has a phone number of 949-
492-7000, Phone Check will verify the following:

1. The area code 949.

2. The prefix 492 is valid with the area code 949.

3. The phone number is within a set distance from 
the center of its ZIP Code area (the default is 100 
miles).

The last 4 digits of the phone number will not be 
checked.

Phone Check includes an up-to-date list of new area 
codes. If it finds an old area code-prefix combination in 
your list, it can update it with the new area code. Phone 
Check can verify two phone numbers at the same time. You 
must format both phone numbers to take advantage of this 
new feature. Phone Check can also standardize the format 
of telephone numbers in your list.

In this chapter...

When to use Phone Check .................. 114

Running Phone Check ......................... 114

Formatting Fields for Phone Check..... 116

Phone Check Results ........................... 117
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WHEN TO USE PHONE CHECK
Phone Check updates area codes and creates uniform phone number listings. It is a good idea 
to run lists through Phone Check when they are over three months old, and before beginning 
telephone campaigns.

RUNNING PHONE CHECK
To run Phone Check, select List > Phone Check > Options. The Phone Check Options dia-
log box opens.

The Phone Check Options screen

• Phone Number Format — Lets you decide how you want telephone numbers to be 
formatted in your list. You can choose from seven preset options, create your own for-
mat, or keep the phone numbers in their original format.

• User Defined Format — Allows you to define your own telephone number format. Use 
the pound sign (“#”) to stand for telephone number digits. You can use any symbol as a 
separator mark, except for the pound sign. An example of a user defined telephone for-
mat may be “###.###.####”. Telephone number extensions are always formatted 
“x###”. 

• Local Area Code — When you are changing the format of your phone number, you 
can use this box to replace the missing area codes in valid telephone numbers. If you 
select an update or correction option in the “Correction Level” box and type an area 
code in the “Local Area Code” box, the correct area code will be added to the valid 
phone numbers in your list that have missing area codes.
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For example, since 492-7000 uses the 949 area code, it will become 
949-492-7000 while 637-8477 will become 714-637-8477, since it uses the 714 area 
code. If a telephone number already has an area code, the “Local Area Code” number 
won’t be added. If you leave the default “0” in the “Local Area Code” box, Phone Check 
will return error codes for records without area codes. 

• Skip Blank Phone Numbers — Use this option to exclude records with missing phone 
numbers from the Phone Check process. If records with missing phone numbers are 
not skipped, these records will be reported as errors.

• Correction Level options:

If the distance between the ZIP Code and area code/prefix combination exceeds 100 
miles, Phone Check will return a “D” (distance) error for the first three Correction Level 
options. If you are using Correction Level options 1 or 2, you can unformat the ZIP 
Code field to eliminate this error.

• Validate Only — Use this option to check the accuracy of your phone data without 
updating or correcting the numbers that have errors. Phone Check will return an 
error if it finds invalid phone data. 

• Update Current Splits — Use this option to update the current area code splits 
that are in their permissive period. Telephone numbers of less than 10 digits will 
not be updated.

• Update Bad Area Code/Prefix — Use this option to check for compatible area 
code/ prefix combinations, to update current area code splits, and to replace area 
codes that have missing digits with the area code that is closest to each record’s 
ZIP Code.

• Use ZIP Code To Correct All Area Codes — When you use this option, MAIL-
ERS+4 uses each record’s ZIP Code to look up its phone number prefix before 
finding the matching area code and using it to update your phone records (includ-
ing the current area code splits). Since this Correction Level option relies entirely 
on the ZIP Code and prefix, it will update the area codes in your records without 
checking to see if the old ones are accurate.

• Click Format if you have not previously formatted fields in your list for Phone Check.

• Click Filter to specify the range of records you wish to process.

• Click Go when you are ready to begin Phone Check, or Cancel to return to the MAIL-
ERS+4 main screen. 
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FORMATTING FIELDS FOR PHONE CHECK
For assistance with formatting for Phone Check, see Formatting Fields on page 27.

The Phone Check Format screen

Required Fields
• Phone #1 — This field contains a record’s telephone information (If you need to verify 

two phone numbers the Phone #2 field will also be required). 

• ZIP Code — The field in your list with a record’s 5-digit ZIP Code.

Recommended Fields
• Phone #1 Error — This field contains the error code (1-character in length) describing 

the type of error in your primary phone number.

• Phone #2 Error — This field contains the error code (1-character in length) describing 
the type of error in your secondary phone number.

Optional Fields
• City — The field in your list containing the city name.

• State — This field contains a record’s state name or abbreviation.
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PHONE CHECK RESULTS
After Phone Check has finished checking your list, the Phone Check Results screen displays. 
This screen is also available by selecting List > Phone Check > Results. From here, the Phone 
Check Report can be displayed on screen by clicking Preview, and a hard copy can be created 
by clicking Print.

The Phone Check Results screen
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Name Parse

MAILERS+4 Professional Only
Many applications require that name components be in 
separate fields. MAILERS+4 can parse (split) a full name 
into separate fields with its Name Parse feature. Name 
Parse is also helpful when conducting name searches and 
merging name fields in documents. 

Name Parse contains a built-in database of 13,000 first 
names and their genders. If you create a Gender field in 
your list, Name Parse will insert the gender. “Genderizing” 
can be an effective tool for targeted mailings and for learn-
ing the gender composition of a list.

WHEN TO USE NAME PARSE
Name Parse can be very useful for creating personalized 
direct mail. By splitting names into separate fields, you can 
use the parsed name fields as merge fields in your docu-
ments. For example, include a First Name field in your let-
ter to add a personal touch to your mailing. (Use Mail 
Merge to merge the First Name field into your document.) 

Gender coding also opens up a number of opportunities to 
target your mailings more effectively. Use the Gender field 
to determine salutations (Mr., Ms., and so on) in your let-
ters, or to divide your list between men and women, and 
create a specific mailing for each gender.

In this chapter...

When to Use Name Parse.................... 119

Using Name Parse................................ 120

Formatting Fields for Name Parse....... 121

Name Parse Results ............................. 122
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USING NAME PARSE
1. Select List > Name Parse. The Name Parse Options dialog box opens.

The Name Parse Options screen

2. Click Format. The Format Fields dialog box for Name Parse opens. Format the 
desired fields. Auto Format will quickly format your list fields and assign them to corre-
sponding MAILERS+4 fields. For more information on formatting fields, see Format-
ting Fields for Name Parse on page 121.

3. Click OK to close the Format Fields dialog box. The Name Parse Options dialog box 
displays again.

4. Select a casing option. You have the option to convert text fields to all upper case let-
ters (Upper), upper and lower case letters (Upper/Lower) where only the first letter of 
each word will be capitalized, or to keep existing upper case letters (Auto). Fields 
affected by casing are:

Full Name First Name Middle Name 

Last Name Prefix Suffix

5. Click Filter if you want to specify a Record Range. The Filter option lets you limit Name 
Parse to a selected range of records within your mailing list.

6. Select the Delete dBase records with vulgar words check box if you want to mark for 
deletion any records that have offensive names in the full or first name fields.

Casing should be used with care to avoid damage to suffixes.
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7. Click Go to begin Name Parse.

FORMATTING FIELDS FOR NAME PARSE

The Format Fields for Name Parse

Required Fields
• Full Name — The Full Name field has priority over all other fields. To Name Parse, 

you must format separate fields for each name component. Name Parse will then split 
from the combined Full Name field. 

For example, if the Full Name field in a record contains: 

“Mr. John Q. Public III”

Name Parse can split the name into five separate fields:

Prefix Mr.

First Name John

Middle Name Q.

Last Name Public

Suffix III
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• Gender (Required for Gender ID) — One of the following gender classification codes 
will be inserted into the Name Gender field:

M= Male

F= Female

N= Neutral (Pat, Chris, and so on)

U= Unknown (When a name doesn’t appear in the database, it is coded as unknown.)

V= Vulgar

Optional Fields
• Name Error — Name Parse inserts an asterisk (“*”) in this field when it can’t find 

names in a record. If the Full Name field is blank, Name Parse will report it as an error.

NAME PARSE RESULTS
The Name Parse Results screen displays the number of records processed and successfully 
coded; the number and percent of errors found; and a pie chart breakdown of the Male, Female, 
Neutral, and Unknown gender categories in your list. Click OK to exit Name Parse and return to 
the main screen.

Name Parsing Results
• Total Records — Displays the records processed by Name Parse. 

• Records Coded — Displays the records that Name Parse was able to code. 

• Records in Error — Displays the records that Name Parse was unable to code. 

• Error Percentage — Displays the percentage of total records processed that Name 
Parse was unable to code.

Gender Count
• Male — Displays the number of records that fall into the male gender category.

• Female — Displays the number of records that fall into the female gender category.

• Neutral — Displays the number of records that fall into the neutral gender category.

• Unknown — Displays the number of records that fall into the unknown gender cate-
gory.

• Vulgar — Displays the number of records that fall into the vulgar category.
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Tally
Tally counts the number of records in your mailing list by 
Carrier Route, ZIP Code, County, Sectional Center Facility 
(SCF), State, and/or Network Distribution Center (NDC). 
Once a count is made, Tally calculates the percentage of 
each and sorts the results in descending order. When fin-
ished, Tally creates a report that can be viewed on-screen, 
sent to the printer, or saved as a text file.

WHEN TO USE TALLY
The Post Office requires a minimum number of pieces in 
order to qualify for destination discounts. Using Tally will 
give you a better idea of which destination discounts you 
may be eligible for in Presort. 

Tally can also be used to find out which areas are heavily 
represented in a particular list. This data will help you tar-
get your recipients more effectively.

USING TALLY
Before using Tally, be sure to format the following desired 
fields in your list:

• Carrier Route

• ZIP Code

• County

• Sectional Center Facility (SCF)

• State

• Network Distribution Center (NDC)

In this chapter...

When to Use Tally ................................. 123

Using Tally ............................................. 123

Tally Reports .......................................... 124
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1. Select List > Tally. The Tally dialog box opens. 

The Tally dialog box

2. Click Format if your list has not been formatted. Click Filter if you wish to specify a 
range of records to process.

3. Select the desired fields to indicate the type of data you want Tally to count. Fields 
selected for Tally to count must already be formatted in your list. 

4. Type a number in the Show top field to see only the top 10 (or whichever number you 
enter) entries for a selected category in your list. Tally reports the count and percent-
age of total records for each of these entries in the selected category of your mailing 
list.

5. Click Go when you are ready to begin, or Cancel to return to the MAILERS+4 main 
screen.

TALLY REPORTS
The Tally Results screen contains options to let you preview, print, or save the Tally report to a 
text file named *.$TR.

You can only preview or print one tally option (ZIP Code, state, and so on) at a time. Select an 
option by selecting the corresponding check box. 

Tally will overwrite the report file each time a new Tally Report is created. To prevent this from 
happening, use your file manager to change the name of your existing Tally Report file.

The Auto CRRT column on Carrier Route and ZIP Code reports indicates whether a record 
qualified for carrier route sortation rates (Y = ZIP Code qualified, N = ZIP Code did not qualify).
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The Tally Results screens

Save All will save the entire Tally report.

Sample tally report



MAILERS+4 User’s Guide Tally

126



127

ZIPs/Records in Radius

MAILERS+4 Professional Only
Using a given ZIP Code as a center point, ZIPs in Radius 
will report all the ZIP Codes located within a user-defined 
radius. ZIPs in Radius accepts high and low radius limits, 
enabling you to conduct “Donut” searches. You can view 
the results of your search on-screen, print them as a 
report, or save them as a text file.

Records in Radius tells you how many records in your mail-
ing list are located within a given range from a central ZIP 
Code. You can save a list of these records to a separate 
file. Records in Radius can also append the distance from 
the central ZIP Code to each of the records in your list.

WHEN TO USE ZIPS/RECORDS IN 
RADIUS

Use ZIPs in Radius or Records in Radius to target your 
mailings by ZIP Code or the distance from a central loca-
tion. 

If, for example, you want to send a mailing to prospects liv-
ing within 25 miles of your store, enter your store’s ZIP 
Code as the center point in ZIPs in Radius. It will then gen-
erate a listing of all the ZIP Codes within that area. You can 
use this information to acquire a new mailing list which tar-
gets these ZIP Codes. 

You may also want to write a special letter targeting people 
who live within a given commute of your location, such as 
between 25-50 miles. ZIPs in Radius lets you do this by tar-
geting ZIP Codes using high and low radius ranges. 

In this chapter...

When to Use ZIPs/Records in Radius. 127

ZIPs in Radius ....................................... 128

Records in Radius................................. 130
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Records in Radius lets you target existing customers by distance. You can find your closest cus-
tomers (or how far you have to go to reach a certain number of them), and even save their 
records to a separate file.

ZIPS IN RADIUS
To use ZIPs in Radius, do the following:

1. Select Tools > ZIP’s in Radius. The ZIP’s in Radius dialog box opens.

2. Type the ZIP Code you want to use as your center point. The ZIP Code field specifies 
the ZIP that will be the center point for your radius. 

3. If you want to search the entire area between your center point and the radius limit, 
type the radius range (in miles) in either the Low Radius or High Radius field. Leave 
the field “0.” The Low Radius and High Radius fields designate the boundaries of 
your radius area (when conducting a “Donut” search).

The ZIP’s in Radius dialog box

4. If you want to conduct a “Donut” search (for example, all ZIP Codes between 25-100 
miles of your center point), type the low radius limit (25) in the Low Radius field and 
the high radius limit (100) in the High Radius field.

Since the radius is calculated from one ZIP Code centroid to another, the data it yields is not always 
useful. Conditions affecting the accuracy of ZIPs/Records in Radius results are ZIP Code centroids 
that have too close of a proximity to each other, and centroids that are not in the center of the area 
they represent.
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5. If desired, select the Include Unique ZIP Codes and/or Include PO Box ZIP Codes 
check boxes to include them in your search. Otherwise, they will not be listed in the 
results. Include PO Box ZIP Codes adds Post Office Box ZIPs to your search. 
Include Unique ZIP Codes allows processing of ZIP Codes that belong to a particular 
organization. 

6. Click Go.

The ZIPs in a Radius results screen displays when the search is completed. This screen dis-
plays the number of ZIP Codes found in the radius and gives you the option of viewing, printing, 
or saving a report as a text file. The report includes a list of each ZIP Code found, its distance 
from the center point, and the city, state, and county it represents. 

If you save your report to a file, the file will be named after the ZIP Code you used as center 
point with the extension .DAT (for example, DS92673.DAT).

ZIPs in radius results

ZIPs in a Radius “donut” results
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RECORDS IN RADIUS
To use Records in Radius, select List > Records in Radius. This opens the Records in 
Radius screen. The Records Listing area indicates the range of records that will be pro-
cessed. The Center Point — ZIP Code field specifies the starting point from which the record 
radius or distance calculations will be made. 

You can use the Format button to format the necessary fields. Use the Filter button to define 
the range of records to process by entering a mailing list’s Start and Stop points.

1. Type the ZIP Code you want to use as your center point. 

2. Click Go. When the Records in Radius results screen appears, it defaults to radius 
and displays the distance of the closest record to your target ZIP Code. You can 
choose to find the number of records in a radius, or calculate the center point distance 
required to reach a certain number of records.

The Records in Radius Options screen

• If you want to find the number of records in a radius, click Radius and specify the 
number of miles you want to search, then click Results.

• If you want to find the distance from the center point required to reach a certain 
number of records, click No. of Records and specify the number of records you 
want to look for, then click Results.

You must format your “ZIP Code” field to use ZIPs/Records in Radius features.
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3. If you want to save the records found to a separate file, click Save Results. Type a 
name for the results file and select the drive and directory that you want the file to be 
saved to.

The Records in Radius Results screen

4. Click OK. The results file is now saved to the directory of your choice.

The following fields are used by Records in Radius to process your list and append the 
data from your search results.

5. When you are finished with Records in Radius, click Close to return to the main 
screen.

FIELD NAME LENGTH TYPE

ZIP Code 10 Character

Distance 4 Character

ZIP Code Error 1 Character

Center 5 Character
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Adding Data to your List
MAILERS+4 can add valuable data to your list. This data 
can save you money on postage, speed mail delivery, and 
provide valuable demographic and marketing information. 
The types of information that MAILERS+4 can add to your 
list include:

• ZIP + 4 Code

• Carrier Route (CRRT) Code

• Delivery Point Code 

• Endorsement Line

• County Name

• County FIPS Code

• SCF/NDC/DDU Destinations 

• Congressional District

• Telephone Area Code

• Time Zone

• Latitude & Longitude

• MSA and PMSA Codes

• Tray/Package Numbers

• Address Type

• ZIP Code Type

• Duplicate Group

• Distance from a ZIP Code

• Error Fields

• LOT Order

• LOT Number

In this chapter...

Adding Fields to a List .......................... 134
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In order to add this information to your list, you must first format a field in your list to hold the 
information (See Formatting Lists on page 23 for help with formatting lists). MAILERS+4 can 
then write data to these fields when processing your list.

To append data to your list:

1. Format a field in your mailing list.

2. Run Address Check (Address Check will append the field data while it is checking your 
list). 

ADDING FIELDS TO A LIST
If your mailing list file does not have a field to hold the information you want, you can add a field 
using the MAILERS+4 Database Manager (see Database Management on page 137). 

For instance, if you want MAILERS+4 to add Carrier Route (CRRT) codes to your records but 
your mailing list file doesn’t have a CRRT field, you must add a CRRT field before MAILERS+4 
will append the CRRT data to your list. 

To add a new field to a mailing list:

1. Select Database > Modify. (If you are creating a new database, select Database > 
Create.

2. Click Insert to add a new field to the list (if you need to remove an existing field, select 
it and click on Delete). The text “NEWFLD1” will appear in the “Fields” box and in the 
“Name” box.

3. In the “Name” box, change “NEWFLD1” to the name you want the field to have (If the 
field will hold address data, name it “Address,” and so on).

4. Select a field type in the Type drop-down box. The default field type is CHARACTER, 
as all MAILERS+4 fields are CHARACTER fields (except Latitude and Longitude, 
which are NUMERIC).

5. Predefined fields are available in the Quick drop-down box. To add to your mailing list 
all the fields contained in a typical record, select COMMON FIELDS. You can also 
choose ADVANCED FIELDS and fields used by individual MAILERS+4 features.

6. Define the field length in the “Length” box. Data will be lost if the field length is too 
short. Minimum, maximum, and suggested field lengths for fields used with MAIL-
ERS+4 are listed in MAILERS+4 Fields on page 197.

7. If the field requires a decimal (used with NUMERIC field types), enter it in the Decimal 
field.

8. Click OK to save the new list structure or Cancel to exit without saving your changes.

Field descriptions and length requirements are located in MAILERS+4 Fields on page 197.
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You may want to consider adding the following fields:

• Address Type — Adding an Address Type field will allow Address Check to assign 
codes for the type of addresses (S=Street, F=Firm, and so on) that it finds.

• Carrier Route Code (CRRT) — This field will allow Address Check to add CRRT 
codes to the records in your mailing list.

• Congressional District — MAILERS+4 can add congressional district numbers to 
addresses in your mailing list. You can use this information to target particular congres-
sional districts or to refer people to their Representative in Congress. Using a relational 
database management program such as FoxPro, Alpha Four/Five, or dBase IV, you 
can link the State and Congressional District field to the 108TH.DBF file located on 
the MAILERS+4 CD-ROM. The 108TH.DBF contains contact information (name of 
Representative, mailing address, telephone number, and so on) for the 106th Con-
gress.

• County FIPS Code — Formatting this field allows Address Check to add the Federal 
Information Processing Standard codes to counties in your list.

• County Name — Allows Address Check to add the county, parish, or borough name.

• Delivery Point Code — When formatted, this field will allow Address Check to append 
the delivery point codes to records in your list. For more information on Delivery Point 
Codes see Checking Addresses on page 37.

• Endorsement Line — This field allows Presort to add the sort type code and can be 
included on the mailing label.

• Error Fields — Error fields are used by MAILERS+4 to insert error codes when it finds 
incorrect data. Error fields are extremely useful when viewing records MAILERS+4 
cannot automatically correct. For example, if Address Check is unable to correct an 
address because the street name is misspelled, it will insert the code letter “U” in the 
“add error” field, identifying the error as an “unknown street.” Error/Information Codes 
on page 207 contains a complete list of error codes.

Error fields must be formatted before MAILERS+4 can code them. You can format sep-
arate error fields for Address Check, Duplicate Check, Phone Check, Name Parse, 
Presort, and DataSelect. If you do not wish to format this many error fields in your mail-
ing list, you can choose to format a single Error Code field. However, error codes 
placed in this field can be overwritten by other MAILERS+4 operations. For example, 
Address Check will automatically clear the error field in every record it processes, 
whereas other operations will overwrite the error field only if an error is present in that 
record. 

Do not format existing fields as error fields because data currently in them may be overwritten by 
MAILERS+4. 

If you do not have any error fields in your list, you may want to create one or more character fields 
using the MAILERS+4 Database Manager (See Database Management on page 137).
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• Latitude & Longitude — Allows Address Check to append information to an address 
regarding its position on earth (Address Check uses 5-digit Latitude/Longitude num-
bers).

• LOT Number — Formatting this field will let Address Check append the Line of Travel 
Number for that address.

• LOT Order — This field will contain the “A” or “D” codes used to sort records to indi-
cate an “Ascending” or “Descending” carrier route direction.

• MSA and PMSA Codes — When formatted, this field allows Address Check to add 
codes for Metropolitan Statistical Area and Primary Metropolitan Statistical Area.

• SCF/NDC/DDU Destinations — Formatting of this field allows Presort to enter the 
code for SCF/NDC/DDU destination discounts.

• Time Zone — Allows Address Check to append information to your list regarding the 
time zone that any particular record is located in.

• Tray/Package Numbers — This field is used by Presort to identify which pieces of 
mail go where when being delivered to the Post Office.

• ZIP Code Type — Allows Address Check to add a code to identify the type of ZIP 
Code found in each record.

• ZIP + 4 Code — When formatted, this field identifies the ZIP + 4 Code for all records in 
your mailing list. ZIP + 4 information is used by almost all of MAILERS+4 features.
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Database Management
The Database Manager lets you perform common data-
base management tasks within MAILERS+4, working with 
dBase format. Note that some of the fields within the Filter 
function work with fixed length files. 

Use the Database Manager to:

• Create new mailing list structures.

• Modify your list by changing field names, field 
types, and field lengths.

• Copy list structures to a new mailing list file.

• Import data from other files to your list.

• Export data from your list to other file types (using 
Nth Record Selection).

• Delete records.

• Recall deleted records.

• Pack out deleted records.

• Append new records to an existing list.

CREATING A NEW LIST 
STRUCTURE

A database can be thought of as a computerized Rolodex. 
Just as a Rolodex is made up of a number of cards which 
hold certain types of information, a database is made up of 
a number of records, each of which hold certain types of 
data. In a database, the types of data which a record can 

In this chapter...

Creating a New List Structure ............. 137

Modifying an Existing List .................... 140

Copying a List Structure....................... 140

Importing Data to a List ....................... 141

Exporting Data from a List ................... 144

Deleting Records .................................. 145

Recalling Records................................. 146

Packing Records ................................... 146

Append .................................................. 147
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hold (name, address, telephone number, and so on) are called fields. In order to create a new 
database structure, you need to define what fields you want in its records.

Defining Fields in a New List
To define a field, you must specify its name, type, and length. You can do this by using the Cre-
ate dialog box in MAILERS+4.

1. Select Database > Create. The Create dialog box opens.

Creating a new database

2. Click Insert to add a new field to the list. The text “NEWFLD1” appears in the Fields 
box and in the Name field.

3. In the Name field, change “NEWFLD1” to the name you want the field to have (for 
example, If the field will hold address data, name it “Address”).

4. Select a field type in the Type drop-down box. The default field type is CHARACTER, 
as all MAILERS+4 fields are CHARACTER fields (except Latitude and Longitude, 
which are NUMERIC).

Lists are created in dBase format and can be used by other programs, such as Foxpro, dBase III, 
Alpha Four, and so on. 

The only NUMERIC field types you should create for MAILERS+4 are Latitude and Longitude. 
Make sure all other fields (including ZIP, phone number, and so on) are CHARACTER fields or 
MAILERS+4 will not read them correctly.
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Inserting a new field

5. Define the field length in the Length field. Data will be cut off if the field length is too 
short. Minimum, maximum, and suggested field lengths for fields used with MAIL-
ERS+4 are listed in MAILERS+4 Fields on page 197.

6. If the field requires a decimal (used with NUMERIC field types), enter it in the Decimal 
field.

7. Repeat the previous steps until you have defined all the fields you want included in 
your new list.

8. To remove a field from the list, highlight it and click Delete. Click Cancel to quit without 
saving the list structure.

9. Click OK to save your new list structure as a file.

The “Fields” and “Length” status boxes (located at the bottom of the screen) show the total num-
ber of fields and the total record length for your list. As you add or remove fields from the list, 
these numbers will increase or decrease. The maximum number of fields allowed is 255 and the 
total record length cannot exceed 4000.

Creating a New List with QuickList
At the bottom of the Create dialog box is the Quick drop-down box containing predefined list 
structures. By selecting a predefined QuickList, the fields from that list are added to the Fields 
list box. 

Several QuickLists have been included that contain fields for various MAILERS+4 features. You 
can use more than one QuickList selection in a list and add QuickList selections to fields you 
have already created. However, QuickList will only add new fields that have not already been 
defined in your list. Click on a selection in the Quick drop-down box to add the structure to your 
list. 
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MODIFYING AN EXISTING LIST
Modifying a list is similar to creating a new list structure, except that the fields from the currently 
open list are displayed in the Fields list box.

To modify an existing list:

1. Open a list in MAILERS+4.

2. Select Database > Modify. The Modify dialog box opens, with the fields from your list 
displayed in the Fields box.

3. In the Fields box, highlight the field you want to remove, and then click Delete.

4. To define a new field in the list, see Defining Fields in a New List on page 138.

5. To add a QuickList field, see Creating a New List with QuickList on page 139. To exit 
without saving changes to a list, click Cancel. 

Modifying a database list

Editing Field Names, Field Types, and Field Lengths
Changing the type or length of an existing field may alter data contained in those fields. In the 
Modify dialog box:

1. In the Fields box, highlight the field you want to edit.

2. Make your changes in the Name, Type, Length, or Decimal fields.

COPYING A LIST STRUCTURE
The Copy Structure feature copies the dBase list structure from a currently open list to a new 
file. Use Copy Structure to start a new database with the same fields as the current list. No 
record data is transferred through this process.

To copy the current list structure to a new file:
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1. Select Database > Copy Structure.

2. Type the path of the file you want to copy to (for example, C:\MP4\Mailer.dbf).

3. Click Save. 

IMPORTING DATA TO A LIST
The Import feature allows you to append data to the end of your currently open list. You can 
import from other dBase, comma-delimited, tab-delimited, and fixed-length files.

When importing data, MAILERS+4 will place data into your list file in the same order as it 
appears in the import file, up to the length of each field in the list file. MAILERS+4 will begin 
importing from the first field to the next, up to the number of fields in the currently open list file.

If the two files do not match exactly, field data may not transfer correctly. For example, if the 
import file has more fields than the list file, the extra fields from the import file won’t be trans-
ferred. If the input file has less fields than the list file, the extra fields in the list file will be left 
empty.

To import data to a list:

1. Open a list in MAILERS+4.

2. Select Database > Import. The Import Records Options dialog box opens.

Importing data

3. Click Select to locate the file you will be importing from. 

4. Select the File Type of the file you will import from.

5. Click OK to begin importing, or Cancel to quit.

Example 1: Importing to a Matching File

CUSTMR.DBF is the name of the mailing list file open in MAILERS+4. You want to append data 
to CUSTMR.DBF from the file APPNDME.DBF. MAILERS+4 will transfer the data between these 
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files by matching up field names. While data is being transferred if an APPNDME.DBF field is 
copied to a shorter CUSTMR.DBF field, it will be truncated. 

Example 2: Importing to a Non-Matching File

In this example, CUSTMR.DBF and APPNDME.DBF contain different field structures. Note how 
data is appended incorrectly to CUSTMR.DBF. In addition to data being imported to the wrong 
fields, the text in the State field of CUSTMR.DBF is cut off because the State field length is 
shorter than the City field length in APPNDME.DBF. “ZIP” field data from APPNDME.DBF does 
not copy to CUSTMR.DBF because there is no field left to accommodate it.

Example 3: Delimited Files

When appending data from a comma- or tab-delimited file, check to see if there are the same 
number of fields in the list file as there are in the delimited file. If any data in the delimited file is 
longer than the length of the field it is being appended to in the list file, the copied data will be 
cut off to fit the list field.

Comma-delimited file, first line:

APPNDME.DBF CUSTMR.DBF

Field Type Length Data Field Type Length Data

First Character 20 Bob First Character 20 Bob

Last Character 25 Smith Last Character 25 Smith

Address Character 20 100 Main St Address Character 20 100 Main St

City Character 28 Anytown City Character 28 Anytown

State Character 2 CA State Character 2 CA

ZIP Character 10 12345 ZIP Character 10 12345

APPNDME.DBF CUSTMR.DBF

Field Type Length Data Field Type Length Data

Title Character 8 Mr. First Character 20 Mr.

First Character 20 Bob Last Character 25 Bob

Last Character 25 Smith Address Character 20 Smith

Address Character 20 100 Main St City Character 20 100 Main St

City Character 28 Anytown State Character 2 An

State Character 2 CA ZIP Character 10 CA

ZIP Character 10 12345 ZIP data is omitted because all fields are in use. 
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”Bob,” “Smith,” ”100 Main St,” ”Anytown,” ”CA,” ”12345"

Example 4: Fixed Length File Appended Incorrectly

Fixed length files are appended according to the lengths of the list file. In the following example, 
the data is not appended correctly. To fix this problem, a new list file should be created in which 
the field lengths match those of the fixed-length file.

Fixed-length file, first line:

Lengths: 10 10 15 8 2 5
Bob Smith 100 Main ST Anytown CA 12345

Example 5: Fixed Length File Appended Correctly

In this example, the field lengths in the list file were defined to match the lengths of the data in 
the fixed-length file. 

Fixed-length file, first line:

CUSTMR.DBF

Field Type Length Data

First Character 20 Bob

Last Character 25 Smith

Address Character 20 100 Main St

City Character 28 Anytown

State Character  2 CA

ZIP Character 10 12345

CUSTMR.DBF

Lengths Field Type Length Data

Bob=10 First Character 20 Bob Smith

Smith=10 Last Character 25 100 Main St Anytown CA

100 Main St=15 Address Character 20 12345

Anytown=8 City Character 28

CA=2 State Character 2

12345=5 ZIP Character 10

CUSTMR.DBF

Lengths Field Type Length Data

Bob=10 First Character 10 Bob Smith
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EXPORTING DATA FROM A LIST

To export data from a list (using nth record selection):

1. In MAILERS+4, open the list you wish to export data from.

2. Select Database > Export. The Export Records Options dialog box opens.

Exporting data from a list

3. Fields in your current list appear in the left side of the Export Records Options dialog 
box. Choose which field data you want to export by highlighting a field and clicking the 
> button. If you want to export data from all the fields in your list, click the Add All but-
ton.

Smith=10 Last Character 10 100 Main St Anytown CA

100 Main St=15 Address Character 15 12345

Anytown=8 City Character 8

CA=2 State Character 2

12345=5 ZIP Character 5

The Export function only works with dBase files. You can not export a Microsoft Access file type.

CUSTMR.DBF

Lengths Field Type Length Data
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4. Fields you have selected to export appear on the right hand side of the Export 
Records Options dialog box. To remove a field from the export list, highlight it and 
click the < button. If you want to remove all the fields from the export list, click the 
Remove All button.

5. In the Records to Export area, click All Records to export the selected fields for your 
entire list, click Every to export the selected fields based on your entry of a numerical 
value, and click Randomly selected records to export the selected fields by randomly 
choosing records until the numerical value you entered is reached.

Therefore, if you click Every and enter a numerical value of 4, every fourth record will 
be exported (for example, 4, 8, 12, and so on). If you click Randomly selected 
records and enter a numerical value of 50, MAILERS+4 will randomly export 50 
records from your list. 

6. Click Filter if you wish to apply additional selection criteria to the records you have 
chosen to export. Your records should be filtered before any settings in the Records to 
Export area are applied.

7. Click Save to export your records, or Cancel to quit.

DELETING RECORDS
The Delete feature marks records in your list for deletion. You can delete a single record, a 
range of records, or all the records in the list. 

To mark a record for deletion, select Database > Delete. The Delete Records dialog box 
opens.

Marking records for deletion

• Current Record — The current record number is shown here. To change the current 
record, simply type in a new record number.

• Range — These options let you choose whether to delete a range of records, the rest 
of the records from the current record to the end of the list, or all the records in the list.
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• Next — This option allows you to delete a range of records beginning with the cur-
rent record. For example, to delete only the current record, type “1.” To delete the 
current record and the following 49 records, type “50.”

• Rest — Select this option to delete records from the current record to the end of 
the list.

• All — Select this option to delete all the records in the list.

RECALLING RECORDS
Use Recall to “unmark” records marked for deletion. Recall works exactly like Delete. To unmark 
records for deletion, select Database > Recall. The Recall Records dialog box opens.

• Current Record — The current record number is shown here. To change the current 
record, simply type in a new record number.

• Range — These options let you choose whether to recall the deleted records in a 
range, in the rest of the list, or all of the list.

• Next — This option allows you to recall deleted records from a range beginning 
with the current record. For example, to recall only the current record, type “1.” To 
recall the current record and any deleted records in the following 49 records, type 
“50.”

• Rest — Select this option to recall all deleted records from the current record to 
the end of the list.

• All — Select this option to recall all the deleted records in the list.

PACKING RECORDS
Pack permanently removes records that have been marked for deletion. You also have the 
option of packing out records which have address, duplicate, phone, or general errors (if you for-
matted the corresponding fields in your list prior to running their respective features).

To pack out deleted records in your list:

1. Select Database > Pack. The Pack dialog box opens.

2. Choose whether to pack out all the “Deleted” records in your list (that have been 
marked for deletion), or those with error codes in the Address Error, Dup Error, 
Phone Error, or Error Code fields. A check mark will appear next to the options you 
select.

3. Click Pack to begin or Cancel to quit.
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Packing out deleted records

MAILERS+4 creates a backup file of your list before it packs out your records. This backup file 
can be found in the same directory as your list. It has the same file name as your list but with the 
extension .BAK.

APPEND
This function is another of the MAILERS+4 Data Entry features (see Data Entry on page 149). 
It allows you to add new records to an existing list. Data Entry will only add records to lists that 
are in dBase format. 

To add records to your list:

1. Open the list that you want to add records to in MAILERS+4.

2. From the List Information screen, select Database > Append. The Data Entry 
screen that you formatted for the file opens. The current record number is displayed in 
the lower left-hand corner of the screen. For new lists, this number will start at 1.

3. Type the requested information in the first field. Press either TAB or ENTER to advance 
to the next field. You can also use the Append toolbar at the top of the Data Entry 
screen to navigate to a desired record layout.

4. Continue this process until all of your information has been entered into the screen.

5. Click Save to save your data that you entered. Click Cancel to clear the screen of all 
data.

6. To advance to the next screen and save your information after entering data in the last 
field of your Data Entry screen, press the TAB or ENTER key, and then click Save.

7. To view the next or previous record, click Next or Previous at the top of your Data 
Entry screen. Clicking Go To will allow you to type the number of a specific screen and 
jump to that screen.
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8. Select File > Quit to exit Append and return to the MAILERS+4 List Information 
screen.

To scroll backwards through a record, hold down the SHIFT key while pressing TAB. You can 
also return to the previous record in your list using the CTRL-HOME hotkey combination, or 
advance to the next record in your list using the CTRL-END hotkeys.
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Data Entry
You can create new lists and add records to existing lists 
with the MAILERS+4 Data Entry feature. This feature 
allows you to design the Data Entry screen that will be 
used for inputting your data. Data Entry will only add 
records to existing lists that are in dBase format.

CREATING A NEW LIST LAYOUT
Before you can begin adding records to a new list, you 
must first define the fields that will be used. To define a 
field, you must specify the field’s name, type, and length. It 
is important to remember to close any other lists that MAIL-
ERS+4 may be running before attempting to create a new 
list. See Creating a New List Structure on page 137.

DESIGNING YOUR DATA ENTRY 
LAYOUT

Now that you have told MAILERS+4 the fields that you will 
be working with, it is time to create the screen you will use 
to enter your data. A well-planned, well-laid-out Data Entry 
screen will greatly reduce the time and stress of data entry, 
especially when working with a large number of records.

Designing the Data Entry Screen
1. Open your list in MAILERS+4. Select Tools > 

Data Entry > Design View. A blank Design View 
screen displays.

In this chapter...

Creating a New List Layout .................. 149

Designing Your Data Entry Layout ...... 149
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2. Select File > AutoCreate to pull up the fields that are in your list. AutoCreate will only 
display fields that were formatted using Format Fields. If you are creating a new list 
from scratch, fields must be created one-at-a-time manually (AutoCreate cannot work 
with something that does not exist). For more information, see Adding, Deleting, and 
Moving Fields on page 152.

Designing a data entry screen

The fields for your list will appear in the Design View screen as grey rectangles with the field 
names to the left. It is important to remember that the boxes in the Design View screen repre-
sent the viewable area of the fields in your list and not the actual fields themselves.

For example, if you had a First Name field formatted in your list with a field length of 20, and for-
matted the Design View screen box for a length of 15, you would be able to enter 20 charac-
ters, but only 15 characters would appear on the Data Entry screen. The length of the boxes 
indicates the viewable area of that field on the screen.
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Editing the Name and Length of New Fields
The names and lengths of your Design View screen boxes can be edited to reflect the actual 
length of your fields. Care should be taken when modifying Design View screen boxes to keep 
lengths consistent with the fields that are in your list. If not, information may be hidden on the 
Data Entry screen.

To prevent losing entry fields off the edge of the screen, design the Data Entry screen with the 
screen resolution set to match the resolution of the screens that it will be running on. 

To edit field name and length:

1. Using the right-hand button of your mouse, click on the field that you want to modify. 
The Field’s Information dialog box opens.

Selecting a field to edit

This screen shows field names and lengths for the Design View screen boxes in your 
list. The Field’s Information area on the right portion of the screen shows the details 
of the highlighted field’s actual name and length as it exists in your list. At the bottom of 
the screen, the Label and Length fields show the name and viewable area that will 
appear on the Data Entry screen for that field.

2. Delete the current Label name and type in the new name that you wish to appear in 
the Data Entry screen.

3. Delete the number in the Length field and type in the field length displayed in the 
Field’s Information area. The viewable area on the Data Entry screen for that field 
will now have the same length as the actual field in your list.

4. Click OK to save your changes and return to the Design View screen.

5. Repeat the above steps until all your fields have the desired name and length.
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The display length of each field can also be adjusted in the Design View screen. Note that the 
boxes in the Design View screen represent the viewable area of the fields in your list and not 
the actual fields themselves. 

To change the display length of your fields:

1. Move your cursor to the left or right edge of the field that you want to resize. The 
pointer will become a cross.

2. Click and hold the left button on your mouse and the box will become an outline.

3. Move the cursor left or right to stretch the box to the desired length.

4. Release the left mouse button to set the new size of the box. After stretching a field, 
the new field length information can be viewed by double-clicking your mouse on that 
field.

Adding, Deleting, and Moving Fields
Individual fields can be added or deleted to the Data Entry screen. 

To add a field:

1. Select Database > Modify.

2. Click Insert. A new field is added.

3. Type the Name, Type, and Length of the new field.

4. Click OK.

5. Select Tools > Data Entry > Design View. 

6. Select Field > Create...Ins. A field outline will appear under your cursor.

7. Use your mouse to position the field outline in a desired location, and then double-click 
it to open the Field’s Information dialog box.

8. In the Display box, specify a Label and Length for the new field. Select the label in 
the Fields box. 

9. Click OK.

10. To save the new field, select File > Save View.

To delete a field:

1. Select Field > Delete...Del. in the Design View screen. The Select A Field dialog box 
opens.

2. Select the field you wish to delete, and then click OK.

To move a field:

1. Click and hold down the left mouse button on the Design View field you wish to move.

2. Using your mouse, drag this field to a desired location.

3. Release the left mouse button to set the new field location.
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4. Repeat these steps until all of the fields are arranged to your liking.

Aligning Fields
Fields in your Data Entry screen can be aligned using the Alignment menu.

To align data entry fields:

1. Using your mouse, click and drag to draw a square around the fields you want to align, 
then release the mouse button.

2. Using the Alignment menu, choose the alignment style you want (Left, Right, Top, or 
Bottom). The field boxes will now align themselves with the inside edge of the box that 
you indicated.

Grouping
The Grouping feature in Design View can be used to draw borders around sets of field boxes, or 
to create permanent text boxes in your Data Entry screen. 

• Grouping fields allows you to set off related fields by containing them inside a box. 

• Text boxes allow on-screen messages to be displayed in the Data Entry screen. 

Grouping and text boxes can be modified in Design View, however, they are fixed in the Data 
Entry screen.

To create a grouping box:

1. Select Group > Box. An outline of a grouping box appears under your cursor.

2. Move the grouping box outline to a desired location and left-click your mouse to set it.

3. To resize a grouping box, click and hold the left mouse button on any side of the box 
and stretch it to your desired size.

4. If you need to reposition a grouping box, move your cursor to the box, then click and 
hold the left mouse button. This will pick up the box.

5. Move the grouping box with your cursor to a desired location and release the left 
mouse button to place the box.

6. Repeat the above steps until the layout of the grouping boxes suits you.

To create a text box:

1. Select Group > Text. An outline of a text box appears under your cursor.

2. Move the text box to a desired location and left-click your mouse to set it.

3. To add text to the box, double-click the box with your mouse. The Assign Text dialog 
box opens. Type the desired text in the Text field.

4. Click OK. Your text will appear in the text box you just created. Text can be changed at 
any time by double-clicking a desired text box

5. You can resize and reposition this box in the same manner as a grouping box.
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Tab Order
The Tab Order feature in Design View allows you to select the sequence in which fields will be 
accessed when entering data. After data has been typed into a field, pressing TAB or ENTER 
will, by default, advance the cursor to the next field (as defined by Tab Order).

To modify tab order:

1. Click Tab Order in the menu bar. Numbers will appear next to each field, indicating the 
order these fields will advance during data entry. The default setting is the order these 
fields were added to the screen.

2. Click on the field you want to be first during Data Entry. The number “1” will now 
appear next to this field.

3. Click on the field you want to be second during data entry to designate that field #2.

4. Continue clicking on the rest of the fields on your screen until all of the fields have been 
assigned a new number.

5. Left-clicking your mouse button on a clear part of the screen (away from the field 
boxes) will save your Tab Order changes.

Save/Cancel Buttons
The Save and Cancel buttons in the Design View screen can be repositioned anywhere on the 
screen. During data entry, these buttons can be used to either save information that has been 
input, or cancel the entry and clear the current screen. These buttons cannot be removed from 
the Design View screen.

When you are finished with the layout of the Design View screen, select File > Save View. 
Enter the name of your mailing list file and click OK. Select File > Exit to return to the MAIL-
ERS+4 main screen.

Using Manage Views 
The Manage Views feature allows saved Data Entry layouts to be assigned to new mailing lists. 
You can access this feature from the MAILERS+4 main screen by selecting Tools > Data Entry 
> Manage Views. The Manage View dialog box opens.

Click Import to use a Data Entry layout (view) from an earlier version of MAILERS+4 with your 
current mailing list. To save a selected Data Entry layout (view) as the default layout for your cur-
rent list, click Set As Default. You can remove a selected Data Entry layout (view) from the 
MAILERS+4 program by clicking Delete. To exit Manage Views and return to the main screen, 
click Close.

Setting Data Entry Options 
After designing your Data Entry screen, use the Data Entry Options dialog box to set data 
entry options for your records (see Data Entry Options on page 36 for more information). 
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Adding Records to a List
To add records to a list:

1. Open the list you want to add records to.

2. From the main screen, select Database > Append. The Data Entry screen you for-
matted for the file displays. The current record number will be displayed in the lower 
left-hand corner of the screen. For new lists, this number will start at 1. 

You can use the Append toolbar at the top of the Data Entry screen to navigate to a 
desired record layout. 

3. Type the requested information in the first field, and then press either TAB or ENTER to 
advance to the next field.

4. Continue this process until all of your information has been entered into the screen.

5. Click Save to save the data you entered. Click Cancel to clear the screen of all data.

6. To advance to the next screen and save your information, TAB over to the Save button 
and press the ENTER key.

7. To view the next or previous record, click Next or Previous at the top of the Data Entry 
screen.

8. Clicking on Go To will allow you to type in the number of a specific screen and then 
jump to that screen.

9. Select File > Exit to exit Data Entry and return to the main screen.

BACKING UP DATA ENTRY TEMPLATES
MAILERS+4 allows you to save your data entry settings as a template that can be re-used with-
out having to set up the data entry screens for each database. These settings are stored in a file 
called mp4w32.dat in the MAILERS directory. A duplicate file is automatically copied to the 
BAK subdirectory of your main program directory every time you MAILERS+4.

The backup files allow you to restore your MAILER+4 settings if the original files are overwritten 
or lost for any reason.

To scroll backwards through a record, hold down the SHIFT key while pressing TAB. You can also 
return to the previous record in your list using the CTRL-HOME hot key combination, or advance to 
the next record in your list with the CTRL-END hot keys.
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Exporting Street Data
The Export Street Data feature lets you output the contents 
of the MAILERS+4 street data file in dBase, fixed-length 
(text), or comma-delimited format. This will take the postal 
address data for a ZIP Code from the database and place it 
into one file. 

This information can be used as a great resource tool for 
planning mailings and checking for possible addresses. 
However, it should never be used to create addresses or 
records for a mailing list, since the street data file is made 
up of ranges, not actual addresses.

EXPORTING STREET DATA TO A 
FILE

1. Select Tools > Export Street Data. The Export 
dialog box opens.

The ZIP Code Low and High fields define the ZIP 
Code range of records to be exported. The File 
Type box lets you specify the file format for 
exporting [dBase, fixed-length (text), or comma 
delimited]. When these fields have been defined, 
click Export to begin the process of outputting 
street data. Click Cancel to return to the main 
screen. During the export process, an Exporting 
box displays the current ZIP Code, Record 
Number, and Total Records that were exported. 

2. Type the ZIP Code range you wish to export. If 
you only wish to export a single ZIP Code, enter 
the ZIP Code number in the Low field and leave a 
“0” in the High field.

In this chapter...

Exporting Street Data to a File ............. 157
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3. Select the type of file format you want to export to [dBase, fixed-length (text), or 
comma-delimited].

4. Click Export. A Save As dialog box opens. The 5-digit ZIP Code you entered in the 
low range of the Export dialog box appears as the default file name, followed by the 
file’s extension. You can change the drive, path, file name, and extension.

5. Click Save to save the street data to a file.

Exporting street data

Viewing the File
When viewing the file, an “x” in the ZIP Plus 4 Low and High fields indicates a non-deliverable 
address range (for example, railroad tracks on one side of the street prevent the establishment 
of valid addresses in this location).

If the street prefix in the “Street Data” file is a Spanish name, the street name (rather than the 
prefix) is shown alphabetically (Calle Negocio is listed under N, Avenida Estrella is listed under 
E, and so on). 

No. Description Length Position

 1 Primary Address Range Low 10 001-010

 2 Primary Address Range High 10 011-020

 3 Primary Address Odd/Even Code 01 021-021

 4 Street Pre-Direction Abbreviation 02 022-023

 5 Street Name 28 024-051

 6 Street Suffix Abbreviation 04 052-055

 7 Street Post-Direction Suffix 02 056-057

 8 ZIP Code 05 058-062

 9 Carrier Route 04 063-066
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10 ZIP 4 Low 04 067-070

11 ZIP 4 High 04 071-074

12 Company Name 40 075-114

13 Secondary Address Abbrev.* 04 115-118

14 Secondary Address Range Low 06 119-124

15 Secondary Address Range High 06 125-130

16 Secondary Address Odd/Even 01 131-131

17 Congressional District 02 132-133 

18 County Number 05 134-138

19 Record Type 01 139-139

20 Carriage Return/Line Feed 02 140-141

* The Secondary Address Abbreviated field is used to indicate Suite (Ste), 
Apartment (Apt), Building (Bldg), and so on

No. Description Length Position
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Mail Merge+

MAILERS+4 Professional Only
What is Mail Merge+? Most businesses keep track of cus-
tomers by entering their account information in a database. 
When this database is used to personalize form letters and 
envelopes with the data from fields in a database record, it 
is known as a mail merge.

Why should you use it? Data from any field in an existing 
mailing list can be applied to your customer communica-
tions. You can also include your signature, logo, and the 
current date.

CREATING A NEW DOCUMENT

Using Existing Content in a New 
Document

The easiest way to create a new Mail Merge+ document is 
to transfer the copy of your existing file to a new document. 
When you access the Mail Merge+ function, a new Mail 
Merge+ document is automatically opened for you. 

To transfer the text of your existing file to this new Mail 
Merge+ document:

1. Select List > Mail Merge. The Mail Merge win-
dow opens.

2. Open your existing file in the program you used to 
create it. Select the text you wish to copy by 
selecting Edit > Select All (if you wish to copy 

In this chapter...

Creating a New Document .................. 161
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Formatting a Document ....................... 166
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Printing Documents in Mail Merge+ . 172
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your entire file), or by using your mouse to click and drag across the portion of text you 
wish to copy. 

3. Copy the selected text by selecting Edit > Copy. 

4. In the new Mail Merge+ document, use your mouse to click the area of the page where 
you would like to paste your copied text. 

5. After the blinking insertion point appears, select Edit > Paste. The text you selected in 
your existing file will be copied to the new Mail Merge+ document. 

Creating Content for a New Document
If you don’t have existing text to use with your Mail Merge+ document, you can create this text in 
Mail Merge+. 

1. Select List > Mail Merge. The Mail Merge window opens.

2. Select Print > Page Setup. The Page Setup dialog box opens. 

3. Specify the desired page size and margins, and then click OK.

4. Click on the Mail Merge+ document and use the TAB and ENTER keys on your key-
board to place the insertion point where you want the first line of text to begin. Since 
Mail Merge+ operates in the same manner as other word processing programs, you 
can type in the text of your document as you would with your favorite text editor.

Working with Existing Documents
Mail Merge+ lacks the features of full word processing programs, as its text editor is patterned 
after WordPad. It will not retain the formatting of complex documents and should not be used for 
this purpose. To preserve the original document, use the Save As command to give your file a 
new name.

Converting Files to Microsoft Word
Mail Merge+ works with Microsoft Word 6 .doc files. If you are using another version of Micro-
soft Word or a different word processing program (such as Word Perfect), you will need to con-
vert your file to a Microsoft Word 6 document. 

To begin the conversion process, select File > Save As. Choose a folder location for your file.

• If you are converting a file from Microsoft Word 97, use the Save as type dialog box 
and choose Word 6.0/95 (*.doc). 

• If you are converting from Microsoft Word 2000, save the file as a Word 97-2000 & 
6.0/95 (*.rtf) file. 

When Mail Merge+ opens new documents, it defaults to a letter size paper setting. The 
configuration of your Page Setup screen is determined by the print driver you are using. See the 
print driver documentation for more information on setting up your page
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• If you are using a different word processing program, check the documentation that 
came with your software to see if you can convert your files to a Microsoft Word 6 doc-
ument.

Opening Microsoft Word Documents with Mail Merge Fields
Although Mail Merge+ will open Microsoft Word 6 documents, any fields you create with the Mail 
Merge function in Microsoft Word will not be preserved in MAILERS+4. The field names will 
appear in your Mail Merge+ document, however, they will not have the ability to display associ-
ated fields from your mailing list. These Microsoft fields have been stripped of their field proper-
ties and are now just text entries.

INSERTING DATA INTO DOCUMENTS

Data Types and their Uses
The Insert menu lets you add fields to your document that will display the current date and time, 
a graphical image, or record data from your mailing list. Once you have a document that has 
been created in Mail Merge+ or imported from an external program, you can add fields to per-
sonalize this document for your customers. The process of inserting these fields into your docu-
ment is simple. After you decide which fields to add to your document, click on the Insert menu 
and select the desired field type from the drop-down menu.

Date and Time
Date and Time will display the Date and Time dialog box containing a list of available formats. 
Select the format you prefer, and then click Insert to place this field at the location of the inser-
tion point in your document. Click Cancel if you decide not to add this field to your document.

The Date and Time screen

Object
Object will display the Insert Object dialog box containing a list of object types. This object data 
is provided so you can add a signature, logo, or clip art to your customer communications. Since 
Mail Merge+ uses external program associations to open graphic objects, your system must 
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have software installed that is compatible with your file choice. Use the .bmp or .wmf file types 
to add these objects to your Mail Merge+ document. 

From the Insert Object dialog box, click Create New to create a new graphic for your document 
or Create from File to add an existing image to your document. With Create New, the object 
type you select determines the program used to create your graphic (for example, “Paintbrush 
Picture” opens Microsoft Paint). 

The Insert Object screen

As you create the new graphic, it is automatically added to your document at the insertion point 
location (if you are using a “Paintbrush Picture” or “Microsoft Word Object”). If you are using 
another program to create the graphic, it will not be inserted into your document until you save it 
and return to Mail Merge+. 

If you choose to add an existing image with Create from File, a navigation screen will appear 
with a “File” window displaying the directory path of your current file location.

If you place a logo or other graphic on an envelope, make sure its location meets the requirements 
of USPS Publication 28. To insure that these requirements are met, have your Post Office approve 
an envelope sample (as incorrect object placement can lead to mail-piece rejection).

Mail Merge+ uses external program associations to open graphic objects. To add a graphic to your 
Mail Merge+ document, your hard drive must have software that is compatible with your file choice.
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Inserting an existing image

1. Click Browse to open the Browse screen, and then find the desired .bmp or .wmf file. 

2. Click Open to return to the Insert Object dialog box. If you choose, you can select the 
Link check box to reduce the document size by storing this graphic outside your docu-
ment.

3. Click OK to add the image to your document, or Cancel to exit the Insert Object dia-
log box without adding the object.

Once you have created or imported an object type, you can select it while keeping your left 
mouse button depressed and drag it to any location in your document that will accept an inser-
tion point. You can also place an insertion point near the lower left border of your object and use 
the TAB, ENTER, and BACKSPACE keys on the keyboard to reposition it. 

To resize your object, click on it and drag one of the eight boxes in the object’s border while 
depressing the left mouse button. 

To edit an object in the program that created it, double-click the object in Mail Merge+. The 
MAILERS+4 menu bar will change to that of the program you used to create the object. After 
you have finished editing the object, deselect it by clicking somewhere else in your document to 
return to the Mail Merge+ menu. 

Word 97 Users

To place graphics and text on the same line, do the following:

1. Select Insert > Object. 

2. Click Create New, and then choose Microsoft Word Document from the Object Type 
window. 

3. Click OK.

4. If the rulers are not visible in your new Microsoft Word document, select View > Ruler. 

5. Click on the bounding box and resize it to the width of your envelope. 

6. Select Insert > Text Box. Click and drag the crosshair cursor to create a text box. 
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7. Type your address into the text box you just created. Click off the text box to deselect it. 

8. Select Insert > Picture. 

9. Select a graphic category and choose an image to insert. You can reposition the text 
and graphic by clicking and dragging them to your desired locations. 

10. To return to Mail Merge+, click on the Mail Merge+ document screen.

Field Names
The Field Names dialog box contains the fields you have formatted in the mailing list you are 
using for Mail Merge+. 

Click on the fields you wish to insert and drag them with your left mouse button depressed to the 
desired location on your document. To place multiple fields on the same line, simply drag and 
drop them to the same location. To put them on different lines, press the ENTER key before 
dragging and dropping the next field. Mail Merge+ will match these fields with the associated 
data found in each record of your mailing list.

Field names

FORMATTING A DOCUMENT

Applying Fonts
The most effective way to improve the appearance of your Mail Merge+ document is to change 
the formatting of your fonts. You can reformat the fonts in your entire document by selecting Edit 
> Select All. Any formatting changes will now be applied to all the text in your document. If you 
want to limit formatting changes to a specific portion of text, select it by using your mouse to 
click and drag across the desired text passage. After your text has been selected, open the 
Font dialog box by selecting Format > Font. 

When the Font dialog box opens, select your desired formatting choices. You can refer to the 
Sample box to see the results of your choices before applying them to your document. Click 
Cancel if you choose to close the Font dialog box without saving your changes.
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Changing the font

Adding Bullets
If you want to change the format of your document by adding bullets to a list, you can add one 
bullet at a time to your insertion point location, or select a block of text and add several bullets at 
once. To place bullets properly in a selected block of text, you must have a hard return (using 
the ENTER key) between each independent list entry. After you have placed the insertion point 
in a desired location (by clicking on it with your mouse) or selected your text, choose Format > 
Bullet Style to insert bullets in your document. You can delete your bullets by highlighting a bul-
leted block of text and reselecting Bullet Style to remove its check mark.

Formatting Paragraphs
The Paragraph dialog box lets you set the indents and alignment for a selected block of text or 
an entire document. After you have selected the text, select Format > Paragraph to open the 
Paragraph dialog box. 

When the Paragraph dialog box opens, specify the desired indentation values. The process of 
specifying left and right indentation is very similar to that of setting margins for a document, 
although indents only apply to the selected text, not the entire document (as with margins). The 
value you enter in the First Line field will determine the starting point location of the first word in 
every paragraph. 

When working with envelopes, avoid using fonts with a size of less than 8 points, a serif or script 
type style, and a color other than black. Check USPS Publication 28 for more information on 
addressing requirements and always have your Post Office approve a sample before printing an 
entire job.
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The Paragraph dialog box

You can also indicate a desired alignment for your selected text by choosing Left, Right, or 
Center from the Alignment drop-down box. Your alignment choice will be applied to every line 
of selected text in your document. After specifying your paragraph formatting choices, click OK 
to save your changes or Cancel to close the Paragraph dialog box without altering the format-
ting of your text.

Setting Tabs
Tabs serve the same purpose as indentation but are more versatile. By setting multiple tabs in 
your document, you can quickly move a line of text to any desired location. To place tab stops in 
your document, select Format > Tabs. 

1. Use the Tab stop position window to enter the value in inches of your first tab.

2. Click Set to confirm this tab setting by moving it to the large window.

3. Repeat the above steps until you have finished setting your tabs.

4. If you decide to remove one of the tabs, select it in the large window and then click 
Clear to delete it.

5. To remove all your tab settings, click Clear All. To save your tab settings and exit the 
Tabs dialog box, click OK. To close the Tabs dialog box without saving your tabs, click 
Cancel. 

Setting tabs
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Choosing a Background Screen Color
Background colors do not affect the appearance of Mail Merge+ documents, as they are only 
visible on the computer monitor and will not appear on printed copies. This feature allows you to 
choose a text background that is easier on the eyes than the default white color. To change the 
background screen color of your document, select Format > Background. The Color dialog 
box opens. 

Changing the background color

1. Click on a color sample in the Basic Colors area that matches your desired color 
choice. 

2. Click OK to change the background screen color of your document or Cancel to keep 
the existing background screen color. 

If your desired color is not in the “Basic Colors” area... 

1. Select the basic color that is the closest match, and then click Define Custom Colors. 

2. Use the slider and settings boxes to adjust your color until the color side of the 
Color/Solid sample box matches your desired color. 

3. Click Add to Custom Colors to include this color in your other color choices. 

4. Select your new color from the Custom colors area and apply it to your document 
screen by clicking OK.
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EDITING A DOCUMENT

Selecting Text and Objects
Before editing a document in Mail Merge+, you need to select the text or objects you wish to 
change. The easiest way to select your text is by selecting Edit > Select All. This will highlight 
all the text in your document (along with any objects you have inserted) and allow you to edit 
everything at the same time. 

If you only want to edit a specific block of text, use your mouse to click and drag across the 
desired portion. You can select the objects in your document by clicking on them with your 
mouse. To select several objects at the same time, hold down the SHIFT key and click on each 
one. If you want to select a specific word, word fragment, character, number, or symbol, use the 
Find feature in Mail Merge+. To open the Find dialog box, select 
Edit > Find. 

The Find screen

When the Find dialog box opens, type the word or text fragment you want to search for in the 
Find what field. To limit your search to complete words, select the Match whole word only 
check box. You can limit your search to words that have the same casing as the Find what text 
by selecting the Match case check box. 

To select the first word or word fragment in your text, click Find Next. To select each subse-
quent word or fragment that matches the search criteria, keep clicking Find Next until Find has 
finished searching your document. Find Next can also be accessed from the Edit menu, allow-
ing you to continue a search after closing the Find dialog box. Unlike the other methods of 
selecting text, the Find function can precisely select words and word fragments while automat-
ing the search process.

Manipulating Text and Objects
After the desired data has been selected in your document, you can use the other edit functions 
to manipulate it. 

• The Cut command removes selected data from your document and copies it to the
Windows clipboard.

• The Copy command copies the selected data to your clipboard without removing it
from your document.
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• Once this data has been copied to the clipboard, the Paste command will place it 
wherever the insertion point appears in your document.

If you need to remove selected data from your document without copying it to the clipboard, use 
the Clear command. You can even swap a word or word fragment with one of your choice by 
selecting Edit >Replace to open the Replace dialog box. 

The Replace screen

Replace works in the same way as the Find feature, while expanding its capabilities. To use the 
Replace feature, type the word or word fragment you wish to replace in the Find what field, and 
the text you wish to replace it with in the Replace with field. Use the Match whole word only 
and Match case check boxes to determine the precision of your text selection process. To 
replace one selected word or word fragment at a time, click on the Replace button. To select 
this word or word fragment throughout your document and replace it in a single step, click on the 
Replace All button. To select each subsequent word or word fragment without replacing it, click 
on the Find Next button. You can exit Replace at any time by clicking Cancel, however, all 
replacement operations that have already occurred will remain in effect.

Reversing Formatting Changes
As you go about editing your document, you may find that a change is not to your liking. If this 
occurs and you have not altered the document any further, the Undo function will allow you to 
reverse this edit and restore the text to its previous state. To return to the pre-edited version of 
your text, select Edit > Undo. Keep in mind that Mail Merge+ only has one level of Undo. This 
means you will only be able to reverse the last edit, not any that precede it.

SPELL CHECKING A DOCUMENT
After creating a document, it is always a good idea to run it through Spelling Check to make 
sure you catch any spelling errors. To check your entire document for misspelled words, make 
sure all the text is either selected or deselected (if a single word or paragraph is selected, Spell-
ing Check will only process it). Select Tools > Spelling Check to begin the spell checking pro-
cess. If you have misspelled words in your document, the Spelling Check screen will display.

To quickly check the spelling of a single word, double-click it with your left mouse button, then click 
your right mouse button to open the “Spell A Word” screen.
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The Spelling Check dialog box

The Spelling Check screen displays your first misspelled word in a small window, along with a 
scrolling list of spelling suggestions in a larger window. Select the correctly spelled word from 
the list of suggestions, and then click Change to replace the misspelled word with the correct 
one. If the scrolling suggestions window lacks a correct spelling for your word, type it in manu-
ally over the misspelled version that appears in the smaller window, then click Change. The 
misspelled word will be replaced and the Spelling Check screen will reappear after locating the 
next misspelled word in your document. To correct every occurrence of a misspelled word in 
your document, click Change All. 

If Spelling Check reports a word as misspelled when it is actually correct (for example, a name, 
abbreviation, and so on), you have the following options. 

• If this is a word that will regularly appear in your Mail Merge+ document, you can click 
Add to User Dict to include this word in a list of words that Spelling Check views as 
correct. This will prevent Spelling Check from reporting this word as misspelled when 
you check your spelling in the future. 

• You can also use the Ignore and Ignore All buttons to skip over a word that Spelling 
Check incorrectly reports as misspelled. Click Ignore to skip a single occurrence of a 
mistakenly reported misspelled word. Spelling Check will disregard this word and 
jump to the next misspelled word. Click Ignore All to skip every instance of this mistak-
enly reported misspelled word in your entire document. Spelling Check will disregard 
this word wherever it appears in your document. 

To abort the spell checking process at any time, click on the Exit button.

PRINTING DOCUMENTS IN MAIL MERGE+

Choosing a Database
Since Mail Merge+ uses your database mailing lists to personalize your customer communica-
tions, it cannot be accessed unless you have a list open in MAILERS+4. Once you have opened 
a mailing list, you will be able to open Mail Merge+ as well. If you have several mailing lists open 
in MAILERS+4, Mail Merge+ will default to your currently selected list or the last list you opened. 
To choose a different mailing list for printing in Mail Merge+, select Print > Select DBase, and 
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then select your desired list from the choices that appear. These choices will match the lists that 
you currently have open in MAILERS+4.

Setting Up a Print Job
Specifying the Print Order and Sequence
Before printing your Mail Merge+ document, select Print > Print Options to choose your print-
ing parameters. When the Sequence dialog box opens, choose the order and sequence of your 
print job.

You can put your document in Record number, ZIP Code, or Presort order. This allows you to 
print your Mail Merge+ document in the same order as your mailing labels. 

You can also choose the sequence your print order will follow. Normal goes from the beginning 
to the end of your mailing list, while Reverse goes from the end to the beginning. To continue 
setting up your print job, click Next, or click Cancel to exit Print Options without saving your 
changes.

Selecting the print order and sequence

Using Search to Print Specific Database Records
If you chose to print your document in Record number or ZIP Code order, the Next button will 
take you to the Print Range dialog box (If you select the Presort order option, the Presort 
Options dialog box will open first). 

The Print Range dialog box includes a comprehensive search utility. You can use your search 
results to reduce print jobs to a record or records that contain specific field data. 

1. To search your database, click on the Searched Field drop-down arrow, and select the 
field containing data you wish to locate. 

2. In the Searched Text field, type the data you want to find. 

3. Click Find First to begin the search process. 

4. The Result window will display the first matching field in your database, along with the 
record number (if you selected Record order) or the piece number (if you selected ZIP 
or Presort order). 
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The Print Range screen

5. To locate the next matching field entry in your database, click Find Next. 

6. To abort an ongoing search, click the Stop button. 

7. If you decide to start a new search, click Clear to remove the contents of the Searched 
Text field and the Result window.

Indicating the Range of Records for a Print Job
In addition to the search feature, the Print Range dialog box contains Range Setting controls. 
If you ran a search on your database (using Record order), you can click the Records radio but-
ton and enter the record number of your “Search” result in the From and To fields. This will limit 
your print job to the record displayed in the Result window. 

If consecutive records appear in the Result window when you click the Find Next button, enter 
the record number of your first consecutive record in the From field and the record number of 
your last consecutive record in the To field to print these records. The Pieces fields are not 
available when you print in Record order, as this order uses the original arrangement of records 
in your database rather than a MAILERS+4 index sortation.

When you search your database using ZIP or Presort order, the Result field displays the piece 
number instead of the record number. Since ZIP and Presort order use MAILERS+4 index asso-
ciations instead of the original record order of your database, your records are referred to as 
piece numbers in the Result field. Click Pieces and then use the From and To fields to enter 
this piece number (or range of numbers if you have consecutive results) before printing these 
records. 

The Range Setting controls can also be used without the Search feature.

You must presort your database before printing a Mail Merge+ document in Presort order. Your 
records are in Presort order when they have been sorted according to the mailings you qualify for. 
Depending on your sequence choice, the records will print in mail class groupings from the best to 
the worst mail piece rate or vice versa. 
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• If you choose to print in Record order, you can set the range of your print job to include 
all the records in your database, or only those records that fall within a specified from 
and to value. 

• If you select ZIP code order, you can set your print range to include all the records in 
your database, or only those ZIP Codes or pieces that fall within a specified from and 
to value. MAILERS+4 sorts your records in ZIP code order by arranging the ZIP Codes 
from lowest to highest or highest to lowest, depending on your Sequence choice. 

If Presort order is selected, the Next button in the Sequence dialog box takes you to the Pre-
sort Options dialog box (if your database has not been presorted, a warning message will dis-
play). 

The Presort Options screen

1. In the Job List window, select the mail types you wish to include in your Mail Merge+. 

2. If you have inserted an endorsement field in your Mail Merge+ document, click On 
First Mail Piece of Package, On Last Mail Piece of Package, or On All Mail Pieces 
to indicate when the “Endorsement Line” will be placed on your Mail Merge+ docu-
ment. 

3. Use the Separator Page option to keep track of container changes as you print your 
mail merged document. 

• None — Will result in a continuous Mail Merge+ printing with no separation 
between container changes. 

• Marker — Will indicate container changes by putting the # sign in your Marker 
field (you must insert a Marker field in your document before selecting this 
option). 

• Pause — Will stop your printer between containers and pop-up a dialog box ask-
ing if you want to continue printing.
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• Header Page — Will print a header with Tray/Package information on a blank 
page between container changes. 

If you select the Marker, Pause, or Header Page options, use these options to indicate 
whether these separators will be applied during a Tray Change or a Tray/Package 
Change.

4. Click OK to began printing the next container.

After setting your presort options, click Next to specify the print range, or Cancel to exit Print 
Options without saving your changes. Clicking Next will open the Print Range dialog box, allow-
ing you to set the range of your print job to include all the records in your database or only those 
Trays/Sacks or individual pieces that fall within a specified from and to value. 

After choosing the desired print options, click Finish to exit Print Options and save your selec-
tions, or Cancel to exit Print Options without saving your selections. Clicking Finish will save 
your Print Options settings with the database you are currently using, allowing these settings to 
be recalled when you Mail Merge+ this database in the future.

Setting Up Page Parameters
The configuration of your paper layout and printer properties screens is determined by the print 
driver you are using. To change the settings in these screens, select Print > Page Setup. Read 
your print driver documentation for more information on page setup as it applies to your printer.

Viewing and Printing Your Document
After the print options and page setup have been configured, you can view your document 
before printing it by selecting Print > Preview. 

If your Mail Merge+ document consists of more than one page, the Two Page button will allow 
you to view two pages at a time. 

Use the Next Page and Prev Page buttons to go back and forth between the pages of your doc-
ument. 

To enlarge the document preview, click the Zoom In button. Click the Zoom Out button to return 
the document view to its previous size. While the preview screen is open, your cursor will look 
like a magnifying glass. Clicking the cursor anywhere on your document will enlarge that part of 
the document view. If you click more than two times, the cursor will change back to a pointer and 
the document view will return to its original setting. 

The # sign appears once in the Marker field (#) to indicate a package change and twice (##) to 
indicate a tray change.

The Trays/Sacks option in the Print Range dialog box is only available when one job is selected in 
the Job List window of the Presort Options dialog box. The container print range for each mail type 
must be set independently.
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Envelope preview

To view your document merged with each record in your database, click Close to exit the pre-
view screen, and then select Print > Preview Next. This will open the preview screen and dis-
play the fields of your next record in your document. To go back to a preview of your previous 
record, click Close, and then select Print > Preview Previous. When you have finished the pre-
view process, click the Print button from the preview screen, or select Print in the Print menu to 
begin printing your document.

22382 Avenida Empresa
Rancho Santa Margarita, CA  92688

[ENDORSEMENT]
[FIRST NAME] [LAST NAME]
[ADDRESS]
[CITY] [STATE] [ZIP]
[Barcode]

Inserted Fields

Typed Text

Inserted BMP Logo
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Scripting

OVERVIEW OF SCRIPTING
The scripting (batch mode) feature in MAILERS+4 allows 
you to easily perform the following tasks in just a few simple 
steps, without directly opening MAILERS+4:

• Run Address Check, print the Address Check
results, and print a CASS form

• Prepare multiple presort mailings and print pre-
sort reports (available for First-Class and Stan-
dard mail only, not periodicals)

MAILERS+4 gives you the option of running a single file or 
multiple files in batch mode. When running multiple files, 
you can choose to use a different presort template for each 
file.

Before using the Batch Mode feature, you must do the fol-
lowing:

• The file(s) you want to run must have already
been formatted in MAILERS+4.

• If using presort, determine which presort tem-
plate(s) you wish to use. You must have already
set up the presort template(s) in MAILERS+4
before using batch mode.

If you wish to print reports from batch mode, make sure the 
desired printer is turned on. The reports will print to the 
printer that is set up as the default in Microsoft Windows. 

In this chapter...

Overview of Scripting ........................... 179

Running Files in Batch Mode .............. 180

Setting Batch Mode Options ............... 181
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Note that you do not have to print the reports from batch mode — you can print the reports at a 
later time directly from MAILERS+4. 

RUNNING FILES IN BATCH MODE

Running a Single File
To run a single file in batch mode, do the following:

1. Open the ADDRESSPRESORT.txt file (located in the Mailers directory) in Notepad 
or any text editor you are comfortable with.

2. Under //Open the file..., specify the name of the file(s) you want to run.

3. Specify the desired Address Check and Presort options. (For information on Address 
Object, see see Address Check Options on page 181. For information on Presort, 
see Presort Options on page 182.)

4. When you finished setting the parameters, select File > Save to save the ADDRESS-
PRESORT.txt file, and then close the file.

5. Click the Start button, and then click Run. The Run dialog box opens.

6. In the Open field, specify the path of the MP4W32.exe file. (The path contains the 
drive and directory where MAILERS+4 is installed. For example, if the MP4W32.exe 
file is located on the C: drive, then use this path: – 
C:\mailers\MP4W32.exe ADDRESSPRESORT.txt). Use the Browse button if nec-
essary to locate the path.

7. Click OK. The batch mode process is complete, and the report(s) that you 
selected to print are sent to the printer.

If using Address Check, it is suggested that you view the results and resolve any address errors 
before printing the CASS form. For more information, see Address Check Results on page 50.

If using Presort, it is suggested that you review the presort results before printing the presort report 
— you can then make changes to the template in MAILERS+4 if necessary
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Running Multiple Files
To run multiple files in batch mode, do the following:

1. Open Notepad or any text editor you are comfortable with. Make sure a blank docu-
ment is open.

2. For each file you want to run, enter the following command (see the example below): 

“path of MP4W32.EXE file\MP4W32.EXE” “path of file to be 

run\file name.txt”

3. Save the file using the .BAT file extension. Do not forget where you saved the file.

4. To run batch mode, double-click the .BAT file you just created. MAILERS+4 starts run-
ning automatically.

SETTING BATCH MODE OPTIONS
MAILERS+4 allows you to perform Address Check and Presort tasks in Batch Mode.

Address Check Options
When using Address Check in Batch Mode, you can run Address Check, and print the Address 
Check results and a CASS form.

To run Address Check, simply specify the desired options under // Address Check Batch 
commands. The options are similar to those used in the Address Check Options dialog box. 
For more information, see Running Address Check on page 40.

The lines of text under // then printing (for address)... let you specify if the 
Address Check results and the CASS form should be printed. You can choose not to print either 
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of these by commenting out the necessary line of text [place two forward slashes (//) in front of 
the desired line(s) of text].

Presort Options
When using Presort in Batch Mode, you have the option of using a template, or you can manu-
ally specify the desired presort parameters directly in the ADDRESSPRESORT.txt file. 

5. If you are using a template, specify the name of the template you wish to use in the 
line of text after // Setting parameters. Note that the template must have already 
been set up in MAILERS+4.

If you are not using a template, you can comment out this line of text by placing two 
forward slashes (//) in front of this line of text. You can then specify the presort 
parameters manually. The options are similar to those in the Presort Mailing Wizard. 
Note that the Destinations and Customize options cannot be specified in Batch Mode. 
Therefore, you must specify them directly in MAILERS+4 before setting up Batch 
Mode. For more information, see Presort Mailing Wizard on page 71.

6. A list of the available presort reports displays under // then printing... . If you 
do not want to print a particular presort report, you can comment it out by placing two 
forward slashes (//) in front of the appropriate line of text. For more information on pre-
sort reports, see Presort Reports on page 85.
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GeoCoder
Using the ZIP + 4, ZIP+2, or 5-digit ZIP code in a record’s 
address, GeoCoder appends latitude & longitude coordi-
nates (up to six decimal places), Census Tract, Block num-
bers, FIPS codes, and County Names to records in a 
mailing list. You can use this data with a mapping program 
and Census database to plot customer locations geograph-
ically and identify demographic patterns in your list. This 
information will help you target your market more effec-
tively, resulting in higher response rates and increased 
sales. 

The GeoCoder CD contains the data files for GeoCoder. 
During the installation process, GeoCoder program files 
are copied to your hard drive. You have the option of 
accessing the database files from the CD-ROM or copying 
them to your hard drive. Transferring files to your hard drive 
improves the program’s performance, however, it requires 
300 megabytes of hard disk space. Reading database files 
from the CD reduces space requirements to four mega-
bytes but causes the program to run slower. Before installa-
tion, check the amount of hard drive space that your 
computer has available. This will determine the type of 
installation that is best for you.

GeoCoder is an add-on module for MAILERS+4 and must 
be purchased separately. For more information, please 
contact your sales representative.

In this chapter...

Installing GeoCoder .............................. 184

Running GeoCoder ............................... 184

GeoCoder Options ................................ 185

Formatting GeoCoder Fields ................ 186
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INSTALLING GEOCODER
To begin installing GeoCoder:

1. Insert the GeoCoder CD into your CD-ROM drive.

2. Click the Start button and select Run from the menu. The Run dialog box opens.

The Run dialog box

3. Type your CD-ROM drive letter, typically D, followed by :\SETUP.EXE in the Open 
field. The Open field should look like this: D:\SETUP.EXE. 

4. Click OK to begin the installation. The single user License Agreement will be displayed 
before any part of the program is installed. Click Yes to proceed with the installation 
(clicking No will cancel the installation).

5. You can now choose the type of installation you want to install.

• Small — Requires 4MB of free space on your hard drive. Only program files will 
be copied to your computer. This installation saves space on your hard drive but 
runs slower because database files are accessed from the CD-ROM.

• Large — Requires 258MB of free space on your hard drive and transfers all pro-
gram and database files to your computer. This installation takes up more room on 
your drive but it runs faster than the small installation option because database 
files are accessed from the hard drive.

6. After selecting an installation option, click Next to install GeoCoder.

RUNNING GEOCODER

To run GeoCoder:

1. Open a mailing list.

2. Select List > GeoCoder. The GeoCoder dialog box opens.

If you chose the Small installation option, keep the GeoCoder CD in your CD-ROM drive to enable 
the program to read its data files while running.
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The GeoCoder options screen

3. Select the options you want GeoCoder to use (see GeoCoder Options on page 185).

4. If you need to format fields for GeoCoder, click Format. GeoCoder field lengths and 
descriptions can be found in Formatting GeoCoder Fields on page 186.

5. Click Filter if you want to specify a range of records using the MAILERS+4 filtering 
parameters.

6. Click Cancel if you decide to exit without geocoding your list.

7. Click Go to begin geocoding your list. The results display when GeoCoder finishes 
coding your list. The total records in your list, the records coded by GeoCoder, the 
invalid ZIPs found, and the records not coded display.

GEOCODER OPTIONS
The following options are available when running GeoCoder:

• Decimal in Lat/Long Fields — Select this option to include the decimal point in your 
Latitude and Longitude fields. You must have a Character field for this option. This 
option is not available if your Latitude and Longitude fields are numeric (in numeric 
field types, the decimal point is placed automatically). 

• Negative Longitude — Longitude coordinates in the Western Hemisphere are nega-
tive numbers, and most mapping programs use negative longitude coordinates. Select-
ing this option will include the negative sign (“-”) in the longitude coordinate. The 
negative sign will count as a character in the Longitude field — make sure there is 
enough space to accommodate it. 
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• Delete Uncodable dBase Records — If GeoCoder is unable to code a dBase record 
(*.DBF), it will automatically mark the record for deletion if this option is checked.

• Skip Previously Coded Records — When this option is selected, GeoCoder will not 
re-code the records that have already been geocoded.

• Use ZIP+2 if ZIP + 4 Not Found — If GeoCoder can’t find geographic data for a 
ZIP + 4 code in your record, it will use the 5-digit ZIP plus the first 2-digits of the +4 
code. Information appended to the record will be less precise than if the complete 
ZIP + 4 was used, but will still be reasonably accurate.

• Use ZIP if ZIP+2 Not Found — If GeoCoder can’t find geographic data for a ZIP+2 
code (5-digit ZIP plus first 2-digits of +4 code), it will use the 5-digit ZIP. Information 
appended to the record will not be as precise as that of the ZIP+2 code.

FORMATTING GEOCODER FIELDS
This section describes the fields used by GeoCoder. If you need to add new fields or modify 
existing fields in your list (for example, Latitude and Longitude fields), see Database Manage-
ment on page 137.

• ZIP, or ZIP and Plus4 — The field in your list that contains the ZIP Code information.

• Latitude — A 9-digit numeric field that contains the latitude coordinate.

• Longitude — A 11-digit numeric field that contains the longitude coordinate.

• Census Tract — This field contains the identification code for the Census Tract in 
which the address is located.

• Block — Block groups are the next level above census blocks in the geographic hierar-
chy. A block group is a combination of census blocks that is a subdivision of a census 
tract or block numbering area (BNA). (A county or its statistically equivalent entity con-
tains either census tracts or BNAs; it can not contain both.) A block group consists of 
all census blocks whose numbers begin with the same digit in a given census tract or 
BNA; for example, BG 3 includes all census blocks numbered in the 300s. The block 
group is the smallest geographic entity for which the decennial census tabulates and 
publishes sample data. Block groups are numbered uniquely within each Census 
Tract.

• FIPS — This field contains the Federal Information Processing Standard (FIPS). It is a 
5-digit code assigned to each county in the U.S. by the Bureau of the Census. The first 
two digits are the state code and the last three digits are the county number.

• County Name — This field contains the name of the county.

• Place Code — ZIP Code boundaries sometime overlap with city limits and unincorpo-
rated areas. The ZIP Code may place a location within one city even though it is physi-
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cally located within a neighboring area. The place code matches the ZIP + 4 code with 
the Census bureau’s official name for that physical location. 

• Place Name — This property returns the Census bureau’s official name for the ZIP + 4 
code.

For example, the 92688 ZIP Code is located mostly within the city of Rancho Santa 
Margarita. However, it also contains parts of the unincorporated area of Los Flores. 
For these ZIP + 4 codes, the City property of Address Object would return “Rancho 
Santa Margarita,” but this property will return “Los Flores.”

• Error Code — This field contains a code describing the type of GeoCoder error.

GeoCoder Fields
GeoCoder uses specific fields which must be formatted in your list. For each field, a suggested 
length is given, along with the minimum and maximum length allowed. 

A “*” next to a field indicates that the field must be formatted in your list for the feature to oper-
ate. A “+” next to a field indicates that MAILERS+4 will append data to that field if it is formatted 
in your list. 

Code Definition

Z Incomplete, incorrect, or missing ZIP + 4 Code.

N No data available for the ZIP + 4 Code.

Field Name Length Min/Max Description

*ZIP 10 5 / 10 ZIP Code (+4 if space allows)

Plus4 4 4 / 6 +4 code

+Latitude 
(NUMERIC, Decimal=6)

9 9 / 9 Latitude of the ZIP + 4

+Longitude 
(NUMERIC, Decimal=6)

11 11/11 Longitude of the ZIP + 4

+Census Tract 6 6 / 6 Census Tract ID 

+Block 1  4/4 Census Block 

+FIPS 5 5/ 5 Federal Information Processing 
Standard Code for county

+County Name 25 5/ 25 Name of the county

+Place Code 7 7/7 Census Place Code

+Place Name 60 1/60 Census Place Name

+Error Code 1 1 / 2 Error in record’s ZIP + 4 code
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Real Time SmartMover

PREPAID NCOALINK

In addition to the SmartMover add-on, Melissa Data also 
offers what is called the SmartMover real-time service, 
which is seamlessly integrated into MAILERS+4. 

This service allows you to simply submit your file in batch 
using our secure servers for confidential processing any 
time, day or night. Your files will be updated with the current 
move-update information matched to the latest USPS COA 
database of approximately 60 million permanent change-
of-address records. 

When NCOALink processing is complete, you open your 
updated file inside MAILERS+4 and continue to process 
your First-Class and Standard mailings for automation and 
presort rate discounts.

SUBMITTING YOUR DATABASE
1. Open your database file in MAILERS+4.

2. Click the SmartMover button on the MAILERS+4 
or click the Services menu and select Change of 
Address.

3. MAILERS+4 launches ListWare. The currently 
open database file is closed in MAILERS+4 and 
opened in ListWare.

4. Select NCOA Subscription (for Prepaid 
Customers).

5. Click Next.

Submitting Your Database ................... 189

Retrieving Your Processed File ............ 193
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6. Enter your customer information (name, address, e-mail address and phone number). 
Required information is marked with an "*." If you have previously used ListWare, this 
information will already be filled in. Verify that it is correct.

Note: If you are reselling Melissa Data’s Prepaid NCOALink service, provide the list owner’s 
name and address information.

In the Ident No, enter your reseller ID number.  In the box provided for a fax number, 
enter your e-mail address. This information is required.

The e-mail address must be the primary address that Melissa Data has on file in your 
customer record.

7. Click Next.

8. Format your database. If your database uses easily recognizable field names, you 
should be able to click Auto Format and ListWare will match your field names to the 
correct data type.
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9. If you need to manually format a field, select the field in the list on the top of this screen 
then check the correct data type.

Several text fields will be appended your list during processing. If you are uploading a 
dBase (DBF) file, this will be done automatically. If your list is a text file (.csv or .txt) or 
an Excel spreadsheet (.xls), you will need to add these fields to your database file. The 
following table shows the required field names and the minimum width of the 
appended fields.

10. When you are finished formatting fields, click Next.

Field Min. Width Field Min. Width

Return_cd 2 Adderr 2

Movetype 2 Dpbc 3

Movedate 6 Crrt 4

Plus4 4 Mailscore 2

Lacs 1 PMB (future releases) 16
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11. Select Submit Directly to Melissa Data via the Internet.

12. Your file is uploaded to Melissa Data's server and placed in the processing queue.

13. When your file has been processed, you will receive an e-mail notifying you that your 
database file is ready to be downloaded. The length of processing will vary depending 
on the size of your mailing list.

For more information about ListWare’s error and information codes, visit this web site:

http://www.melissadata.com/tech/listwarecodes.htm
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RETRIEVING YOUR PROCESSED FILE
After you receive the e-mail stating that your database file has been processed, follow these 
steps to download the updated list.

1. Open MAILERS+4.

2. Click the Services menu and select Change of Address.

3. MAILERS+4 launches ListWare, displaying the Welcome Back screen.

4. Click Next.

5. ListWare displays the Retrieve Updated File screen. Click the Internet - FTP button.

6. ListWare will download the updated file. The Next button will now be enabled.

7. Click Next.

8. ListWare displays the Select Format Options screen.
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9. Select the desired options for casing and address standardization of the updated 
records and click Next.

10. ListWare displays the Format Database screen.

11. Format the database by matching the field name in your list with the correct ListWare 
data types. Since you formatted your list during the upload process, this screen should 
be correct at this stage. Verify that the appended fields are correctly formatted.

12. Click Next.

13. ListWare begins updating your database with records from the downloaded file.

14. When finished, ListWare will display the Results screen, showing the number of 
records processed and the number updated.
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15. Click Next to finish.
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APPENDIX

MAILERS+4 FIELDS

MAILERS+4 uses specific fields which must be formatted in your list. This appendix lists the 
fields used by each feature. For each field, a suggested length is given along with the minimum 
and maximum length allowed. Refer to Formatting Lists on page 23 for directions on format-
ting fields in MAILERS+4. 

• A “*” next to a field indicates that the field must be formatted in your list for the feature 
to operate. 

• A “+” next to a field indicates that MAILERS+4 will append data to that field if it is for-
matted in your list. 

MAILERS+4 fields are also listed alphabetically at the end of this appendix.

ADDRESS CHECK

Field Name Length Min/Max Description

*Delivery Address 32 02 / 75 Delivery Address.

+Address Error  1 01 / 02 Address Error Codes.

Address 2 32 02 / 75 Optional Second Address Line.

+CRRT  4 04 / 04 Carrier Route Code.

*City 28 02 / 28 City Name.

City/St/ZIP 42 42 / 42 Combined City, State, and ZIP+4 
Code.

Company 40 02 / 50 Company Name.

+Delivery Point  3 02 / 03 Delivery Point code.

Last Name 16 02 / 50 Last Name of Addressee.

First Name 16 02 / 50 First Name of Addressee.

Full Name 40 02 / 100 Full Name of Addressee.
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Advanced Address Check

+Plus 4  4 04 / 04 Plus 4 Addition to ZIP Code.

*State  2 02 / 02 State Abbreviation.

Urbanization 28 02 / 28 Urbanization Code (Puerto Rico).

*ZIP 10 05 / 10 ZIP Code (with +4 if space allows).

Private Mailbox 10 02 / 16 The private mailbox number.

CMRA 1 01 / 01 Indicates whether or not an address 
belongs to a Commercial Mail 
Receiving Authority.

DPB Check Digit 1 01 / 01 The last digit in the Delivery Point 
Barcode.

ZIP+4/DPB 11 11 / 12 Contains the Plus4 field and the 
Delivery Point Barcode

Suite 16 02 / 16 Suite Name and No. (Apt 15).

+LACS  1 01 / 01 L = This is an obsolete form of the 
address. It needs to be corrected by 
Rural Address Conversion processing 
or the local Post Office.
If LACSLink is installed, returns the 
LACSLink Indicator code.
Y = Obsolete address was success-
fully converted by LACSLink.
N = Obsolete Address matched but not 
converted.

LACSLink Return 
Code

2 02/02 See LACSLink Return Codes on 
page 215.

Field Name Length Min/Max Description

+County FIPS  5 05 / 05 Federal Information Processing 
Standard. First 2 digits are a state 
code and the last 3 indicate the county 
within the state.

+County Name 25 05 / 25 County Name.

Field Name Length Min/Max Description
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Address Type 1 01 / 01 Indicates the type of address:
F = Firm or Company
G = General Delivery
H = High rise or business complex
P = PO Box
R = Rural Route Address
S = Street or Residential

+MSA  4 04 / 04 Metropolitan Statistical Area, consists 
of one or more counties forming a 
large population with adjacent 
communities and having a high degree 
of social and economic integration.

+PMSA  4 04 / 04 Primary Metropolitan Statistical Areas 
contain a population of more than one 
million. PMSAs are defined by the 
Federal Office of Budget and 
Management.

+Time Zone  2 02 / 02 Code indicates hours past Greenwich 
Mean Time (GMT)
4 = Atlantic Time 8 = Pacific Time
5 = Eastern Time 9 = Alaska Time
6 = Central Time 10 = Hawaii Time
7 = Mountain Time 11 = Samoa Time
14 = Guam Time

+ZIP Type  1 01 / 01 ZIP Code Type:
Blank = Regular ZIP Code
M = Military ZIP Code
U = Unique ZIP Code
P = PO Box ZIP Code

+Latitude 
(NUMERIC, 
Decimal=2)

 7 07 / 07 Latitude coordinate of a ZIP Code 
centroid.

+Longitude 
(NUMERIC, 
Decimal=2)

 8 08 / 08 Longitude coordinate of a ZIP Code 
centroid.

+LOT (Line-of-
Travel) Number

 4 04 / 04 Line-of-Travel number.

+LOT (Line-of-
Travel) Order

 1 01 / 01 Line-of-Travel Order.

Field Name Length Min/Max Description
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DUPLICATE CHECK 

+Congress. District  2 02 / 02 Congressional District number for 
address location.

# Residential 
Deliveries

 8 02 / 10 Total number of residences in a Carrier 
Route. 

# Business 
Deliveries

 8 02 / 10 Total number of businesses in a 
Carrier Route. 

Number  8 02 / 10 Street Address number.

Pre-Direction  2 02 / 02 Direction indicator preceding the street 
name (100 N Main St).

Name 28 02 / 28 Street Name (100 Main St).

Suffix  4 04 / 04 Street, Drive, etc. (100 Main St).

Post-Direction  2 02 / 02 Direction indicator following the street 
name (100 Main N).

Suite Name  4 03 / 04 Apartment, Suite, etc. (Apt 15).

DPV Footnotes  6 06/06 USPS Footnote

IMB Numeric 31 31/31 Unprocessed IMB Data

IMB Alpha 65 65/65 Processed IMB Data

Suite Number  6 01 / 06 Suite number (Apt 15).

Field Name Length Min/Max Description

*Delivery Address  32 02 / 75 Delivery Address.

Last Name  16 02 / 50 Last Name of Addressee.

First Name  16 02 / 50 First Name of Addressee.

Full Name  40 02 / 100 Full Name of Addressee.

*City  28 02 / 28 City Name.

*State  2 02 / 02 State Abbreviation.

*ZIP  10 05 / 10 ZIP Code (+4 if space allows).

City/St/ZIP 42 42 / 42 Combined City, State, and ZIP+4

+Dup Group    6 01 / 10 Number of duplicate group.

Field Name Length Min/Max Description
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NAME PARSE 

PHONE CHECK 

+Dup Error    1 01 / 02 “D” indicates a duplicate record.

*Duplicate Field 10 1/255 Any field can be duplicated as a key 
field.

Phone Number  16 07 / 20 Telephone number.

Field Name Length Min/Max Description

Full Name  40 02 / 100 Full Name of Addressee.

Prefix    8 02 / 50 Name Prefix (Mr, Mrs, and so on).

First Name  16 02 / 50 First Name of Addressee.

Middle Name  16 01 / 50 Middle Name of Addressee.

Last Name  16 02 / 50 Last Name of Addressee.

Suffix    8 02 / 50 Name Suffix (Jr., III, and so on).

Gender    2 02 / 50 Gender Code. 
F  =  Female
M =  Male
N  =  Neutral
U  =  Unknown
V  =  Vulgar

Name Error    1 01 / 02 Inserts “*” for missing name data.

Field Name Length Min/Max Description

*Phone #1 16 07 / 20 Primary Telephone Number.

*Phone #2 16 07 / 20 Secondary Telephone Number.

+Phone #1 Error  1 01 / 02 Primary Telephone Error Code.

+Phone #2 Error  1 01 / 02 Secondary Telephone Error Code.

City 28 02 / 28 City Name.

State  2 02 / 02 State Abbreviation.

Field Name Length Min/Max Description
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PRESORT 

Advanced Presort

* ZIP Code 10 05 / 10 ZIP Code (+4 if space allows).

Field Name Length Min/Max Description

* ZIP 10 05 / 10 ZIP Code (+4 if space allows).

+Endorsement 50 20 / 50 Defines how a package is sorted.

+Container 
Number

10 04 / 10 The tray/sack number a piece or 
package belongs to.

+Pkg Number 10 04 / 10 The package a piece belongs to.

Plus 4  4 04 / 04 Plus 4 addition to ZIP Code.

Delivery Point  3 02 / 03 Added to ZIP+4 to form Delivery Point 
Barcode (for ECR/LOT).

CRRT  4 04 / 04 Carrier Route Code.

+Presort Error  2 01 / 02 Inserts a “P” if ZIP is invalid.

Walk Seq  4 04 / 04 Walk Sequence Number.

Field Name Length Min/Max Description

Container Type 2 02 / 02 Mail Piece Container Code

Container Line 1 43 43 / 43 Container Destination. 

Container Line 2 25 25 / 25 Container Content.

CIN Code  3 03 / 03 Container Identification Number.

Container Proc 
Code

 2 02 / 02 Container Processing Code.

Container ZIP  5 05 / 05 Container ZIP Code Destination.

Pkg Sort Level  4 04 / 04 Sortation Level of the package.

Pkg ZIP  5 05 / 05 Package ZIP Code Destination.

Sort Level  4 04 / 04 Sortation Level of the container.

Destination 50 06 / 50 Destination City, State, and ZIP.

Field Name Length Min/Max Description
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OTHER FIELD TYPES

Records in Radius 

General Fields

Destination Code  1 01 / 01 Destination Discount Code.

Rate Code  7 07 / 07 Record Sortation Cost Code.

Label List  5 05 / 05 Container DMM-L Label List. 

Mail Job  3 01 / 03 Indicates the mailing of the record. 

Zone Code  3 03 / 03 Code used for Periodical mailings.

Mail Entry ZIP  5 05 / 05 Destination Entry Point ZIP Code.

Mail Piece Rate  7 07 / 07 Mailing cost of the record.

Sequence Number 13 13 / 20 A sequence number assigned to your 
mailing for tracking purposes.

Subscriber  1 01 / 20 Individual or organization with paid 
periodical subscription. If this field is 
blank or contains an “N,” Presort views 
it as a nonsubscriber.

IMB Serial No. 9 06/ 09 The serial number for each IMB

Field Name Length Min/Max Description

+Distance  4 04 / 10 Distance from Center Point ZIP Code 
to record location.

+ZIP Code Error  1 01 / 02 Indicates invalid ZIP Code.

+Center Point ZIP  5 05 / 05 Center Point ZIP Code.

Field Name Length Min/Max Description

*ZIP Code 10 05 / 10 ZIP Code (+4 if space allows).

Error Code  2 02 / 05 An error code will display.

Field Name Length Min/Max Description
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Optional Fields

MAILERS+4 PROFESSIONAL FIELDS
A = Address Check NP = Name Parse

DS = DataSelect PC = Phone Check

DC = Duplicate Check P = Presort 

Field Name Length Min/Max Description

Optional Fields  25 01 / 50 Optional fields that can be assigned, 
such as an account number or invoice 
number.

MAILERS+4 Field Name Features Used By

Address/Delivery Address A, DC

Address 2 A

Address Error A

Address Type A

Bankcard In Household S

CRRT A, P

City A, DC, PC

City/St/ZIP A, DC

Company A

Congress. District A

Container Number P

County FIPS A

County Name A

Distance DS

Delivery Point A

DPBC P

Dup Error DC

Dup Group DC
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Endorsement P

First Name A, DC, NP

Full Name A, DC, NP

Gender NP

Household Income DP

Housing Value DP

Key Field DC

LACS A

Last Name A, DC, NP

Lot Number A

Lot Order A

Latitude A

Longitude A

Middle Name NP

MSA A

Name A

Name Error NP

Number A

Pkg Number P

Per Capita Income DP

Phone Number/Phone #1 DC, PC

Phone #2 PC

Phone #1 Error PC

Phone #2 Error PC

Plus 4 A, P

PMSA A

Post-Direction A

Pre-Direction A

MAILERS+4 Field Name Features Used By
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Prefix NP

Presort Error P

State A, DC, PC

Subscriber P

Suffix A, NP

Suite A

Suite Name A

Suite Number A

Time Zone A

Urbanization A

Walk Seq P

ZIP A, DC, DP, DS, PC, P

ZIP Code Error DS

ZIP Type A

# Business Deliveries A

# Residential Deliveries A

MAILERS+4 Field Name Features Used By
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APPENDIX

ERROR/INFORMATION CODES

Error codes and information codes for each feature are listed and defined here.

RESULT CODES
Result Codes are four character codes that are returned in a single comma-delimited string to 
the Result Code field. It is possible that Result Codes may duplicate information found in other 
fields.

Address Check Result Codes
The following codes might be returned when using Address Check:

Code
U.S. 
Only Meaning Details

Status Result Codes

AS01 Address Matched to 
Postal Database

Street Address is valid and deliverable. 
Check AE08 and AE09 for full deliverability.

AS02 Street Address Match Address street matched to USPS database 
but a suite was missing or invalid. 

AS03 Non-USPS Address The input represents a real physical address 
but it is not in the USPS database. It may be 
deliverable by other carriers (UPS, 
Fedex…).

AS09 Foreign Postal Code 
Detected

Postal Code from a non-supported foreign 
country detected. A US or Canadian Postal 
Code can also return this error if the US or 
Canadian data files are not initialized.
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AS10 Y Address Matched to 
CMRA

Address belongs to a Commercial Mail 
Receiving Agency (CMRA) like The UPS 
Store®.

AS13 Y Address has been 
Updated by LACSLink

Address has been converted by LACSLink 
from a rural-style address to a city-style 
address.

AS14 Y Suite Appended by 
SuiteLink

A suite was appended by SuiteLink using the 
address and company name.

AS15 Y Suite Appended by 
AddressPlus

A suite was appended by AddressPlus using 
the address and last name.

AS16 Address is vacant Address has been unoccupied for 90 days or 
more.

AS17 Alternate delivery Address does not receive mail at this time.

AS18 Y DPV Error Call 1-800-Melissa Tech Support for 
assistance.

AS20 Y This address is 
deliverable by USPS 
only.

Alternate carriers such as UPS and Fed Ex 
do not deliver to this address.

AS23 Extraneous Information 
Found

Information found in input street address that 
was not used for verification. 

Error Result Codes

AE01 Zip Code Error The Postal Code does not exist and could 
not be determined by the city/municipality 
and state/province.

AE02 Unknown Street Error An exact street name match could not be 
found and phonetically matching the street 
name resulted in either no matches or 
matches to more than one street name.

AE03 Component Mismatch 
Error

Either the directionals or the suffix field did 
not match the post office database, or there 
was more than one choice for correcting the 
address.

Code
U.S. 
Only Meaning Details
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AE04 Non-Deliverable 
Address Error

The physical location exists but there are no 
homes on this street. One reason might be 
railroad tracks or rivers running alongside 
this street, as they would prevent 
construction of homes in this location.

AE05 Multiple Match Error Address matched to multiple records. More 
than one record matches the address and 
there is not enough information available in 
the input address to break the tie between 
multiple records.

AE06 Y Early Warning System 
Error

This address has been identified in the Early 
Warning System (EWS) data file and should 
be included in the next postal database 
update. 

AE07 Missing Minimum 
Address Input Error

Minimum required input of address/city/state 
or address/zip not found. 

AE08 Suite Range Invalid 
Error

The input street address was found but the 
input suite number was not valid.

AE09 Suite Range Missing 
Error

The input street address was found but a 
required suite number is missing. 

AE10 Primary Range Invalid 
Error

The street number in the input address was 
not valid.

AE11 Primary Range Missing 
Error

The street number in the input address was 
missing.

AE12 Y PO, HC, or RR Box 
Number Invalid Error

The input address PO, RR or HC number 
was invalid.

AE13 Y PO, HC, or RR Box 
Number Missing Error

The input address is missing a PO, RR, or 
HC Box number.

AE14 Y CMRA Secondary 
Missing Error

Address Matched to a CMRA Address but 
the secondary (Private mailbox number) is 
missing. 

AE17 Suite Range 
Extraneous Error

A suite number was entered but no suite 
information found for primary address.

Code
U.S. 
Only Meaning Details
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Change Codes

AC01 ZIP Code Change The five-digit ZIP Code was added or 
corrected based on the city and state 
names.

AC02 State Change The state name was corrected based on the 
combination of city name and ZIP Code.

AC03 City Change The city name was added or corrected 
based on the ZIP Code.

AC04 Base/Alternate Change Some addresses have alternate names, 
often chosen by the owner or resident for 
clarity or prestige.

This change code indicates that the address 
from the official, or “base,” record has been 
substituted for the alternate.

AC05 Alias Change An alias is a common abbreviation for a long 
street name, such as “MLK Blvd” for “Martin 
Luther King Blvd.”

This change code indicates that the full 
street name has been substituted for the 
alias.

AC06 Address1/Address2 
Swap

The value passed to SetAddress could not 
be verified, but SetAddress2 was used for 
verification. The value passed to the 
SetAddress function will be returned by the 
GetAddress2 function.

AC07 Address1/Company 
Swap

A Company name was detected in address 
line 1 and moved to the GetCompany 
function.

AC10 Street Name Change The street name was changed due to a 
spelling correction.

AC11 Suffix Change The street name suffix was corrected, such 
as from “St” to “Rd.”

AC12 Street Directional 
Change

The street pre-directional or post-directional 
was corrected, such as from “N” to “NW.”

Code
U.S. 
Only Meaning Details
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These result codes are designed to clearly indicate if an address is “good” or “bad.” A good 
address will contain AS01, a bad one will not. 

If you have other conditions for a good address, you can use result codes to filter them as well. 
For example, if you are not using USPS and cannot deliver to a PO Box or a Military address, 
you can exclude records that return the result code “AS20.”

Change codes do not indicate a problem with the validity of the address, but that MAILERS+4 
made minor changes to accurize and standardize the information.

GeoCoder Result Codes
The following codes could be returned when using the GeoCoder option:

If the location information in the current record was valid, this field will contain the value “GS01” 
at the very minimum and may include more of the “GS” codes. If the address could not be veri-
fied, the codes beginning with “GE” will indicate the reason or reasons why verification failed.

AC13 Suite Name Change The unit type designator for the secondary 
address was changed to , such as from 
“STE” to “APT.”

Code Description

Status Result Codes

GS01 Record was coded to the ZIP + 4 centroid.

GS02 Record was coded to the ZIP + 2 centroid.

GS03 Record was coded to the 5-digit ZIP Code centroid.

Error Result Codes

GE01 ZIP Code Error. An invalid ZIP Code was entered.

GE02 ZIP Code not found. The submitted ZIP Code was not found in the database.

Code
U.S. 
Only Meaning Details
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GENERAL ERROR CODES
The following error codes will display in an Error Code column in your database if the Error 
Code field is selected on the Others tab in the Formatting Fields dialog box.

Address Check

Duplicate Check

Name Parse

Code Definition

AC Canadian ZIP Code.

AL Length error. The address is valid but the address field is not long enough to 
standardize.

AM Multiple Addresses. The national database found two or more ranges for your 
address.

AN No Data Available for City. Address data for this city is not in the database. If 
you are using a regional data file, check to see that the address is located in 
that region.

AR Address Out of Range. The address is not within the delivery range.

AS The address failed DPV checking. There is no mail receptacle at this location.

AT Multiple Components. More than one component of your address is in error. 
Address components are the pre-direction, post-direction, and suffix.

AU Unknown Street. No street could be found within the city that matches the 
street name given in the address field.

AX Nondelivery Address. The location given in the address field physically exists 
in the city but the Post Office has indicated that there are no houses there. 
This may occur when one side of the street has railroad tracks or a river along 
side it.

AZ ZIP Code is invalid or does not match the city name.

Code Definition

DD Duplicate record.

Code Definition

N* Data in Name field can’t be located.
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Phone Check

Presort

Records in Radius

Code Definition

HA Area code does not exist in the database or the area code, prefix, or suffix 
contains a character rather than a digit in the digit pattern.

HB Phone number contains only blanks.

HD Distance Error. The area code and ZIP Code are located too far apart as 
designated in the Phone Check Options screen.

HE Numerical format of phone number is incorrect. 

HF Improper field length for chosen phone format.

HM Multiple Match (duplicate phone number errors).

HP Prefix does not exist in the database.

HZ ZIP Code does not exist in the database.

Code Definition

P4 Invalid Plus 4.

PC Invalid Carrier Route.

PL Invalid Line Of Travel Number.

PO Invalid Line Of Travel Order.

PP Insufficient pieces for a package (ECR mailing).

PW Invalid Walk Sequence.

PZ Invalid ZIP Code.

Code Definition

SZ ZIP Code does not exist in database.
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ADDRESS CHECK ERROR CODES
If the Address Error field is selected in the Formatting Fields dialog box, the following error 
codes will display, as necessary, in your MAILERS+4 reports and in your database file.

Code Definition

C Canadian ZIP Code.

L Length error. The address is valid but the address field is not long enough to 
standardize.

M Multiple Addresses. The national database found two or more ranges for your 
address.

N No Data Available for City. Address data for this city is not in the database. If 
you are using a regional data file, check to see that the address is located in 
that region.

R Address Out of Range. The address is not within the delivery range.

S The address failed DPV checking. There is no mail receptacle at this location.

T Multiple Components. More than one component of your address is in error. 
Address components are the pre-direction, post-direction, and suffix.

U Unknown Street. No street could be found within the city that matches the 
street name given in the address field.

V Vacant. The address is not currently occupied.

W Early Warning System. This address has been identified in the Early Warning 
System (EWS) data file, and should be included in the next national database 
update. For more information, see page 41.

X Nondelivery Address. The location given in the address field physically exists 
in the city but the Post Office has indicated that there are no houses there. 
This may occur when one side of the street has railroad tracks or a river along 
side it.

Z ZIP Code is invalid or does not match the city name.
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DPV FOOTNOTES

LACSLINK RETURN CODES
If LACSLink for MAILERS+4 installed and the LACSLinkReturnCode field is formatted when 
running Address Check, the following codes will be inserted into this field in your database file.

Code Description

AA Input Address Matched to the ZIP + 4 file.

A1 Input Address Not Matched to the ZIP + 4 file.

BB Input Address Matched to DPV (all components)

CC Input Address Primary Number Matched to DPV but Secondary 
Number not Matched (present but invalid).

N1 Input Address Primary Number Matched to DPV but Address Missing 
Secondary Number.

M1 Input Address Primary Number Missing.

M3 Input Address Primary Number Invalid.

P1 Input Address Missing PO, RR, or HC Box number.

P3 Input Address PO, RR or HC number invalid.

RR Input Address Matched to CMRA

R1 Input Address Matched to CMRA but Secondary Number not 
Present.

F1 Address Was Coded to a Military Address

G1 Address Was Coded to a General Delivery Address

U1 Address Was Coded to a Unique ZIP Code.

Code Definition

A LACS Record Match — The input record matched to a record in the master 
file. A new address could be furnished.

00 No Match — The input record could not be matched to a record in the master 
file. A new address could not be furnished.
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SUITELINK RETURN CODES

DUPLICATE CHECK ERROR CODES
If the Dup Error field is selected in the Formatting Fields dialog box, a “D” in this field indicates 
the record is a duplicate. This error code will display in your MAILERS+4 reports and in your 
database file.

NAME PARSE ERROR CODES
If the Name Error field is selected in the Formatting Fields dialog box, Name Parse inserts an 
asterisk (“*”) in this field when it can’t find names in a record. If the Full Name field is blank, 
Name Parse will report it as an error. This error code will display in your MAILERS+4 reports 
and in your database file. 

14 Found LACS Record: New Address Would Not Convert at Run Time — 
The input record matched to a record in the master file. The new address 
could not be converted to a deliverable address.

92 LACS Record: Secondary Number Dropped from Input Address — The 
input record matched to a master file record, but the input address had a 
secondary number and the master file record did not. The record is a ZIP + 4 
street level or high rise match.

Code Definition

Empty SuiteLink lookup was not performed.

00 No match - A SuiteLink lookup was attempted by no match was made.

A SuiteLink match.

Code Definition

D Duplicate record.

Code Definition

* Data in Name field can’t be located.

Code Definition
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PHONE CHECK ERROR CODES
If the Phone #1 Error or Phone #2 Error fields are selected in the Formatting Fields dialog 
box, the following error codes will display, as necessary, in your MAILERS+4 reports and in your 
database file. 

PRESORT ERROR CODES
If the Presort Error field is selected in the Formatting Fields dialog box, the following error 
codes will display, as necessary, in your MAILERS+4 reports and in your database file. 

Code Definition

A Area code does not exist in the database or the area code, prefix, or suffix 
contains a character rather than a digit in the digit pattern.

B Phone number contains only blanks.

D Distance Error. The area code and ZIP Code are located too far apart as 
designated in the Phone Check Options screen.

E Numerical format of phone number is incorrect. 

F Improper field length for chosen phone format.

M Multiple Match (duplicate phone number errors).

P Prefix does not exist in the database.

Z ZIP Code does not exist in the database.

Code Definition

4 Invalid Plus 4.

C Invalid Carrier Route.

L Invalid Line Of Travel Number.

O Invalid Line Of Travel Order.

P Insufficient pieces for a package (ECR mailing).

W Invalid Walk Sequence.

Z Invalid ZIP Code.
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RECORDS IN RADIUS ERROR CODES
If the ZIP Code Error field is selected in the Formatting Fields dialog box, a “Z" will display if 
the ZIP Code does not exist in the database. This error code will display in your MAILERS+4 
reports and in your database file. 

INFORMATION CODES

Return Codes

Code Definition

Z ZIP Code does not exist in database.

Code Definition

A COA Match - The input record matched to a business, individual or family 
type master file record. A new address could be furnished.

00 No Match - The input record COULD NOT BE matched to a master file 
record.  A new address could not be furnished.

01 Found COA: Foreign Move - The input record matched to a business, 
individual or family type master file record but the new address was 
outside USPS delivery area.

02 Found COA: Moved Left No Address (MLNA) - The input record matched 
to a business, individual or family type master file record and the new 
address was not provided to USPS.

03 Found COA: Box Closed No Order (BCNO) - The Input record matched to 
a business, individual or family type master file record which contains an 
old address of PO BOX that has been closed without a forwarding address 
provided.

04 Cannot match COA: Street Address with Secondary - In the STANDARD 
mode utilizing Family matching logic the input record matched to a family 
record type on the master file with an old address that contained 
secondary information which obtained a ZIP+4 street level match. The 
input record does not contain secondary information. This address match 
situation requires individual name matching logic to obtain a match and 
individual names do not match.

05 Found COA: New 11-digit DPBC is Ambiguous - The input record matched 
to a business, individual or family type master file record. The new address 
on the master file record could not be converted to a deliverable address 
because the DPBC represents more than one delivery point.
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06 Cannot Match COA: Conflicting Directions: Middle Name Related -There 
is more than one COA (individual or family type) record for the match 
algorithm and the middle names or initials on the COAs are different. 
Therefore, a single match result could not be determined.

07 Cannot Match COA: Conflicting Directions: Gender Related -There is 
more than one COA (individual or family type) record for the match 
algorithm and the genders of the names on the COAs are different. 
Therefore, a single match result could not be determined.

08 Cannot Match COA: Other Conflicting Instructions - The input record 
matched to two master file (business, individual or family type) records. 
The two records in the master file were compared and due to differences 
in the new addresses, a match could not be made.

09 Cannot Match COA: High-rise Default - The input record matched to a 
family record on the master file from a High-rise address ZIP+4 coded to 
the building default. This address match situation requires individual name 
matching logic to obtain a match and individual names do not match.

10 Cannot Match COA: Rural Default - The input record matched to a family 
record on the master file from a Rural Route or Highway Contract Route 
address ZIP+4 coded to the route default. This address situation requires 
individual name matching logic to obtain a match and individual names do 
not match.

11 Cannot Match COA: Individual Match: Insufficient COA Name for Match - 
There is a master file (individual or family type) record with the same 
surname and address but there is insufficient name information on the 
master file record to produce a match using individual matching logic.

12 Cannot Match COA: Middle Name Test Failed - The input record matched 
to an individual or family record on the master file with the same address 
and surname. However, a match cannot be made because the input name 
contains a conflict with the middle name or initials on the master file 
record.

13 Cannot Match COA: Gender Test Failed - The input record matched to a 
master file (individual or family type) record. A match cannot be made 
because the gender of the name on the input record conflicts with the 
gender of the name on the master file record.

14 Found COA: New Address Would Not Convert at Run Time - The input 
record matched to a master file (business, individual or family type) record. 
The new address could not be converted to a deliverable address.

15 Cannot Match COA: Individual Name Insufficient - There is a master file 
record with the same address and surname. A match cannot be made 
because the input record does not contain a first name or contains initials 
only.

Code Definition
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16 Cannot Match COA: Secondary Number Discrepancy - The input record 
matched to a street level individual or family type record. However, a 
match is prohibited based on I of the following reasons: 1) There is 
conflicting secondary information on the input and master file record; 2) 
the input record contained secondary information and matched to a family 
record that does not contain secondary information. In item 2, this address 
match situation requires individual name matching logic to obtain a COA 
match and individual names do not match.

17 Cannot Match COA: Other Insufficient Name - The input record matched 
to an individual or family master file record. The input name is different or 
not sufficient enough to produce a match.

18 Cannot Match COA: General Delivery - The input record matched to a 
family record on the master file from a General Delivery address. This 
address situation requires individual name matching logic to obtain a 
match and individual names do not match.

19 Found COA: New Address not ZIP+4 coded - There is a change of 
address on file but the new address cannot be ZIP+4 coded and therefore 
there is no 11?digit DPBC to store or return.

20 Cannot Match COA: Conflicting Directions after re-chaining - Multiple 
master file records were potential matches for the input record. The 
master file records contained different new addresses and a single match 
result could not be determined.

66 Daily Delete - The input record matched to a business, individual or family 
type master file record with an old address that is present in the daily 
delete file. The presence of an address in the daily delete file means that a 
COA with this address is pending deletion from the master file and that no 
mail may be forwarded from this address.

91 COA Match: Secondary Number dropped from COA – The input record 
matched to a master file record. The master file record had a secondary 
number and the input address did not. Please Note: This return code is 
derived from Individual matching logic only. If this return code is achieved 
then no other matching attempts are permitted regardless of the 
PROCESSING mode.

92 COA Match: Secondary Number Dropped from input address – The input 
record matched to a master file record, but the input address had a 
secondary number and the master file record did not. The record is a 
ZIP + 4 street level match. Please Note: This return code is derived from 
individual matching logic only. If this return code is achieved then no other 
matching attempts are permitted regardless of the PROCESSING mode.

Code Definition
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Presort Mail Job Codes
Code Definition

AA First-Class Automation Letters & Cards

AB First-Class Non-Automation Letters & Cards

AC First-Class Non-Automation Upgradable Letters & Cards

AD First-Class Automation Flats

AE First-Class Non-Automation Flats

AF First-Class Presorted Parcels

AG Standard Mail (A) Automation Letters & Cards

AH Standard Mail (A) Non-Automation Letters & Cards

AI Standard Mail (A) Non-Automation Upgradable Letters & Cards

AJ Standard Mail (A) Automation Flats

AK Standard Mail (A) Non-Automation Flats

AL Standard Mail (A) Non-Automation Enhanced Carrier Route Letters

AM Standard Mail (A) Non-Automation Enhanced Carrier Route Letters

AP Periodical Automation Letters & Cards

AQ Periodical Non-Automation Letters & Cards

AR Periodical Automation Flats

AS Periodical Non-Automation Flats

AW First-Class Co-containerized Flats

AY Standard Mail Auto Enhanced Carrier Route

BE Standard Mail Co-containerized Flats

BG Periodicals Co-containerized Flats

BH First-Class Auto Flats — Tray Based Option

XX Pieces Not Processed or Processed at Single-Piece Rate
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Presort Package Sortation Level

Presort Container Sortation Level

Code Package Sortation Level

FIRM Firm

CRD Carrier Route

5DG 5-digit

3DG 3-digit

ADC ADC

AADC AADC

MADC Mixed ADC

Code Container Sortation Level

CRD Carrier Route — Direct

CR5 5-digit Carrier Routes

CR5S 5-digit scheme Carrier Routes

5DG 5-digit

5DGS 5-digit scheme

M5D Merged 5-digit

M5DS Merged 5-digit scheme

CR3 3-digit Carrier

3DG 3-digit

3DGS 3-digit schemes

ADC ADC

AADC AADC

MADC Mixed ADC

MAAD Mixed AADC

SCF SCF (Periodical sacks)
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Presort Rate Code

Presort Destination Code

Code Rate 

CB Automation Carrier Route (First Class letters/cards) and Carrier Route Basic 
Automation (Standard Mail letters)

5B 5-digit (First Class letters/cards and flats, Periodicals letters and flats and 
Standard Mail letters Automation) 

3B 3-digit (First Class letters/cards and flats, Periodicals letters and flats and 
Standard Mail letters Automation) 

3/5B 3/5 (Standard Mail flats) Automation

BB Basic Flats

AB AADC (First Class letters/cards, Standard Mail letters), ADC (First Class flats) 
Automation

MB Mixed AADC (First Class letters/cards, Standard Mail letters), Mixed ADC 
(First Class flats) Automation

Presort Presorted (First Class letters/cards, flats and Parcels) Automation

5D 5-digit (Periodicals, flats and parcels) Presorted

3D 3-digit (Periodicals, flats and parcels) Presorted

3/5 3/5 (Standard Mail letters, flats and parcels) Presorted

BS Basic (letters/cards and flats) Presorted

WS Saturation Carrier Route

HD High Density Carrier Route

CR Basic Carrier Route

SP Single Piece Non-Presorted

Code Destination 

D Destination Delivery Unit (DDU)

S Destination SCF

B Destination NDC

A Destination ADC

space None
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Move Type
Code Definition

Blank There is no change to the record.

B Business move.

D mCOA match.

F Family move.

I Individual move.

L LACSLink address update.
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APPENDIX

CALCULATING DISTANCES

If you used Address Check to append latitude and longitude coordinates to your records, the fol-
lowing discussion will help you calculate distances between ZIP Codes using latitude and longi-
tude coordinates.

DISTANCE CALCULATION
Any point on the earth’s surface can be located by its latitude and longitude coordinates. Lati-
tude is the angle above or below the equator in degrees. The equator is zero degrees, the north 
pole is north 90 degrees latitude, and the south pole is south 90 degrees latitude. The continen-
tal United States falls between 25 and 50 degrees north.

Longitude is the angle east or west of the Greenwich meridian. The continental United States is 
between 70 and 125 degrees west.

Approximate Solutions
One degree of latitude is equal to 69.1 miles. One degree of longitude is equal to 69.1 miles at 
the equator. North or south of the equator, one degree of longitude is a smaller distance. It’s 
reduced by the cosine of the latitude. Dividing the latitude number by 57.3 converts it to radians.

DistLat = 69.1 * (Lat2-Lat1)
DistLong = 69.1 * (Lg2-Lg1) * cos(Lat1 / 57.3)
Dist = (DistLat2 + DistLong2) 0.5

If you don’t want to use the COS function, then a good approximate solution is:

DistLat = 69.1 * (Lat2-Lat1)
DistLg = 53 * (Lg2 - Lg1)
Dist = (DistLat2 + DistLong2) 0.5 

Technical support is not equipped to troubleshoot distance calculations. This information can be 
obtained at your local public library.
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Exact Solution
To calculate the exact distance between points requires spherical geometry.

The basic formula is:

The above formula has one major problem: most computer languages do not support the arc 
cosine function. Therefore a different form is necessary, one that uses the arc tangent function 
that most languages embrace.

where:

Most computer languages compute the sine and cosine function with the angle given in radians. 
To convert degrees to radians, divide degrees by the constant 57.3 (180/pi).

In BASIC this would be programmed as follows:

C = 57.3
A = sin(Lat1/C)*sin(Lat2/C) + cos(Lat1/C)*cos(Lat2/C)* 

cos(Lg2/C -Lg1/C)
D = 3959 * atn(SQR(1 - A ^ 2) / A)

Where:

D =    distance in statute miles from the first to the second point.

C =     degrees to radians constant 57.3.

Lat1 = latitude of the first point in degrees.

Lg1 =  longitude of the first point in degrees.

Lat2 = latitude of the second point in degrees.

Lg2 =  longitude of the second point in degrees.

Since all ZIP Code points in the United States are north latitude and west longitude, there is no 
need to check the sines (positive and negative) of the latitudes and longitudes.

Some programming languages, such as dBASE II/III, do not have the functions of the sine, 
cosine and arc tangent. Also, the formulas given are time-consuming to calculate. A simpler but 
less accurate method is given here:

D = 69.1 * SQR [(LAT2-LAT1)2 +0.6*(LG2-LG1)2]

D 3959 lat1  lat2 sinsin  lat1  lat2 cos long2 long1– coscos + acos=

D 3959 1 A2
–
A

-------------------
 
 
 

atan=

A lat1  lat2 sinsin  lat1  lat2 cos long2 long1– coscos +=
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Although this formula is not as accurate as the first great circle method, it will give good results 
for most applications.

In Basic it is written as follows:

D = 69.1 * SQR ((LAT2-LAT1)^2 + .6*(LONG2-LONG1)^2)

In dBASE III it is written as follows:

D = 69.1 * SQRT ((LAT2-LAT1)^2 + 0.6 *(LONG2-LONG1)^2)

To make using the database easier, the latitudes and longitudes are given in the decimal format 
instead of the degree, minute and second format. The latter would require the additional steps 
of converting seconds to fractions of a minute and then minutes to a fraction of a degree.

Bearing Formula
The bearing is the direction from the first point to the second point. It is expressed as an angle 
from north in degrees. Due north is a bearing of zero degrees, east is a bearing of 90 degrees, 
south is 180, and west is 270.

The bearing from the first point to the second is calculated with:

Since the ARCTAN function gives the angle in radians, you must convert B to degrees by multi-
plying by 57.3 (180/Pi).

To use this equation requires some special considerations. This example assumes that Lat1, 
Lat2, Lng1, Lng2 have been converted to radians. Use the following steps:

N = sin(Lat1)* sin(Lng1 - Lng2)
D = sin(Lat2) * cos(Lat1) –  cos(Lat2) * sin(Lat1) * 

cos(Lng1-Lng2)
B = 57.3 * ARCTAN(N/D)
If D>0 then B=360+B
If D<0 then B=180+B
If B<0 then B = 360 + B

Examples
The following examples should give you a feel for the numbers. For these examples we will use 
the points of Schenectady, NY and Los Angeles, CA.

First Point is in Schenectady, NY  12345

Lat1 = 42.8145 
Lng1 = 73.9380

B
lat1  long2 long1– sinsin

lat2  lat1 cossin  lat2  lat1 sin long1 long2– coscos –
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------atan=
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Second Point is in Los Angeles, CA 90001

Lat2 = 34.0515
Lng2 = 118.2420

Example 1: Approximate Formula (1)

Lat Dist = 69.1 (Lat2 - Lat1) = 605.5
Lng Dist = 69.1 * (Lng2 - Lng1) * COS (42.8145/57.3) = 2245.8
Dist = 2326.0 miles

Example 2: Approximate Formula (2)

Lat Dist = 69.1 (Lat2 - Lat1) = 605.5
Lng Dist = 53 * (Lng2 - Lng1) = 2348.1
Dist = 2424.9 miles

Example 3: Exact Solution Formula (3)

A1 = SIN (Lat1/57.3) * SIN (Lat2/57.3) =  0.3805
A2 = COS (Lat1/57.3) *COS (Lat2/57.3)* COS (Lng2/57.3-Lng1/57.3)
A2 = 0.4350
A = A1 + A2 = 0.8155
Dist = 3959 * ATN [(1 - A 2) 0.5 / A]
Dist = 2443.4 miles

Example 4: Bearing Formula (4)

N = sin(Lat1/57.3) * sin (Lng2/57.3 - Lng1/57.3) = 0.4747
D1 = sin(Lat2/57.3) * cos(Lat1/57.3) = 0.4107
D2 = cos(Lat2/57.3) * sin(Lat1/57.3) *  cos(Lng2/57.3 - 

Lng1/57.3)
D2 = 0.4029
B = 57.3 * ATN (N/(D1 - D2)) = -89.1 Degrees
Bearing = 360 + B = 360 - 89.1
Bearing = 270.9 degrees from North.
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APPENDIX

STREET SUFFIXES

Names and standard USPS abbreviations for street suffixes are listed below in alphabetical 
order. 

ALY=ALLEY ANX=ANNEX ARC=ARCADE AVE=AVENUE

BYU=BAYOU BCH=BEACH BND=BEND BLF=BLUFF

BLVD=BOULEVARD BTM=BOTTOM BR=BRANCH BRG=BRIDGE

BRK=BROOK BG=BURG BYP=BYPASS CYN=CANYON

CPE=CAPE CSWY=CAUSEWAY CTR=CENTER CIR=CIRCLE

CLB=CLUB CLFS=CLIFFS CP=CAMP COR=CORNER

CORS=CORNERS CRSE=COURSE CT=COURT CTS=COURTS

CV=COVE CIR=CIRCLE CRES=CRESCENT CRK=CREEK

XING=CROSSING DL=DALE DM=DAM DV=DIVIDE

DR=DRIVE EST=ESTATE EXPY=EXPRESSWAY EXT=EXTENSION

FALL=FALL FLS=FALLS FRY=FERRY FLD=FIELD 

FLDS=FIELDS FLT=FLAT FRD=FORD FRST=FOREST 

FRG=FORGE FRK=FORK FRKS=FORKS FT=FORT 

FWY=FREEWAY GDNS=GARDENS GLN=GLEN GRN=GREEN 

GRV=GROVE GTWY=GATEWAY HBR=HARBOR  HL=HILL

HLS=HILLS HOLW=HOLLOW HTS=HEIGHTS HVN=HAVEN

HWY=HIGHWAY INLT=INLET IS=ISLAND ISS=ISLANDS 

ISLE=ISLE JCT=JUNCTION KY=KEY KNLS=KNOLLS 

LK=LAKE LKS=LAKES LNDG=LANDING LN=LANE 

LCKS=LOCKS LDG=LODGE LF=LOAF LGT=LIGHT 
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LOOP=LOOP MALL=MALL MNR=MANOR MDWS=MEADOWS

ML=MILL MLS=MILLS MSN=MISSION MT=MOUNT 

MTN=MOUNTAIN NCK=NECK ORCH=ORCHARD OVAL=OVAL 

PARK=PARK PKWY=PARKWAY PASS=PASS PATH=PATH 

PIKE=PIKE PNES=PINES PL=PLACE PLN=PLAIN 

PLNS=PLAINS PLZ=PLAZA PT=POINT PRT=PORT 

PR=PRAIRIE RADL=RADIAL RNCH=RANCH RPDS=RAPIDS 

RD=ROAD RDG=RIDGE RST=REST RIV=RIVER 

ROW=ROW RUN=RUN SHL=SHOAL SHLS=SHOALS 

SHR=SHORE SHRS=SHORES SMT=SUMMIT SPG=SPRING 

SPGS=SPRINGS SPUR=SPUR SQ=SQUARE ST=STREET 

STA=STATION STRA=STRAVENUE STRM=STREAM TER=TERRACE 

TPKE=TURNPIKE TRCE=TRACE TRAK=TRACK TRFY=TRAFFICWAY

TRL=TRAIL TRLR=TRAILER TUNL=TUNNEL UN=UNION 

VLY=VALLEY VIA=VIADUCT VW=VIEW VLG=VILLAGE 

VL=VILLE VIS=VISTA WALK=WALK WAY=WAY 

WLS=WELLS XING=CROSSING 
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APPENDIX

TECHNICAL SUPPORT & TROUBLESHOOTING

This section provides general troubleshooting information for MAILERS+4 users, including 
answers to commonly asked questions. If your particular situation is not addressed here, please 
contact the Melissa Data Technical Support Staff (see Technical Support on page 233).

MEMORY AND MAILERS+4
Since Microsoft Windows handles the sharing of system memory internally, problems with insuf-
ficient memory are rare. There are potential problem areas, however, that should be avoided 
when using any Windows program. 

Windows System Resources
If system resources are low, reduce the number of multi-tasking programs that are currently run-
ning. 

Total System Memory
The recommended amount of total system memory is 64 megabytes for a computer that regu-
larly runs Microsoft Windows. While MAILERS+4 will run on a system with only 16 megabytes 
of memory, the potential for problems is increased. Due to its heavily graphic and multitasking 
nature, Windows will always benefit from 64 megabytes or more of total system memory.

GPF MESSAGES
The error message “Application Error ‘X’ caused a General Protection Fault in module ‘Y’ 
essentially means that an area in memory assigned to one specific file has been accessed by 
another. If this is an isolated incident, it is probably nothing to worry about. However, if it is 
occurring with any frequency, then something must be done to correct it.

If you are still having memory problems, make sure your swap file is a minimum of 768 megabytes. 
In addition, you should also run Microsoft Windows Disk Defragmenter.
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Here are some general guidelines that are helpful to follow:

1. Set up a swap file of at least 12 megabytes for Windows to use as virtual memory.

2. Maximize the amount of available memory. The less memory your system has, the
more likely it is that GPFs will occur.

3. Make sure that you have at least 10 megabytes of contiguous free space on your hard
drive. This would be in addition to any swap file that has been created.

4. You can defragment your hard drive by exiting out to DOS and typing DEFRAG.

5. Keep your system as simple as possible. Problems are more likely to occur on a com-
plex system. This is especially true if you are on a network. Try to remove things that
load into memory like screen savers (for example, AfterDark).

6. Use the latest drivers. Many GPFs occur due to outdated drivers. This refers especially
to video cards, but it also applies to network cards, sound cards and printer drivers.

What to Do When You Receive a GPF Error
1. Shut down the Windows operating system, then restart it.

2. If the problem remains after Windows reboots, reinstall the program.

If no errors are found, it is possible that there is a memory address conflict. It is a good idea to 
exclude the memory address range that is being used by your video card. This will prevent 
those addresses from being assigned to another application. You will find a lot of pertinent infor-
mation included in the readme files included with Windows. The most common ranges are 
B000-B7FF and C000-C7FF.

OPTIMIZING FOR SPEED

Transferring Data to the Hard Drive
The Transfer feature allows you to create a regional file, moving a range of data by state and/or 
ZIP Code to your hard disk from the National data located on the CD-ROM. When you move 
some of the National data to the hard disk, you increase your processing speed. This occurs 
because a hard drive runs much faster than a CD-ROM drive and the smaller database takes 
less time to scan. If you work with mailing lists that are limited to a few states or ZIP Codes, it is 
recommended that you create a regional file.
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Zip Sorting
A file will be processed much faster if it is sorted by ZIP Code. You can do this by using the 
Index option before running Address Check, or by sorting the list with a database management 
program.

TECHNICAL SUPPORT
MAILERS+4 is easy to install and runs trouble-free under most conditions. We stand behind our 
products and include free technical support with every MAILERS+4 package we sell.

If you have any problems installing or running MAILERS+4, please contact us. However, check-
ing your MAILERS+4 Help files (using the F1 key or Help menu) and this manual will often be 
the fastest way to resolve your problem. If you do need additional help, Technical Support is 
available Monday through Friday between the hours of 6:00am and 5:00pm Pacific Standard 
Time.

When you call for technical support, please have the following information ready:

• The release number of the program (found in the About MAILERS+4 sub-menu of the
Help menu).

• A clear explanation of the problem and any error messages received.

• The Windows’ version that you are using.

• The amount of free memory on your machine at the time the problem occurred.

Please be ready to recreate the problem and work through the solution over the telephone.

Contacting Technical Support
Voice: 800-MELISSA (800-635-4772)

Fax: 949-589-5211

E-mail tech@MelissaData.com

Internet: www.MelissaData.com/Tech/tech.html

Downloading Maintenance Updates
You can also download the latest maintenance releases of MAILERS+4 by logging onto the 
Melissa Data web site. The web site is located at http://www.MelissaData.com/Tech/tech.html.

CAUTION: If you interrupt Address Check while using the Index option, you will have to restart 
Address Check from the beginning of the file.

http://www.melissadata.com/tech/tech.html
http://www.melissadata.com/tech/tech.html
http://www.melissadata.com/tech/tech.html
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Uploading Files to the Melissa Data Web Site
Problem files can also be sent over the Internet to our Technical Support staff by e-mailing them 
to the Melissa Data web site. Simply compress the file and attach it to an e-mail message that 
describes the problem you are having.

TROUBLESHOOTING

Common Data File Questions
Question:

Will MAILERS+4 read my ASCII data file?

Answer:

MAILERS+4 will read fixed length ASCII files with or without a Carriage Return (CR) and Line 
Feed (LF) at the end of each record. However, ASCII files without CR / LF may only have one 
record per line.

Question:

Why do I receive a “Cannot determine file format” error message when trying to open my fixed 
length (ASCII) file in MAILERS+4?

Answer:

The “Cannot determine file format” error may occur if the records in your fixed length (ASCII) file 
are terminated by CR / LFs that are not in the same position throughout the database. Since the 
CR / LFs tell MAILERS+4 how long each of the records is, it is essential that they be in the same 
position at the end of each record or the data file will not be seen as a “Fixed Length” file. 

This problem is very common in files that have been downloaded from a Mini or Mainframe 
computer. The Mini / Mainframe does not pad the spaces in the last field, so a CR / LF is found 
at the end of the data, not at the end of the field.

Question:

My database management program uses a proprietary file format that MAILERS+4 cannot 
read. What file format should I export to?

Answer:

Some database management programs, such as Paradox and Q&A, use their own proprietary 
format that MAILERS+4 is unable to read. The best way around this is to export your file to a 
dBase III or IV format.

Most database management software on the market will export to one of these formats and the 
dBase format is an easy one to work with. MAILERS+4 will also import mailing lists that are in 
comma-delimited format, as it has the ability to convert them to dBase files. If your program 
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does not support dBase files, you must export to a fixed length (ASCII) format. This is a file for-
mat in which each record and field is a given length, and it is the same throughout the file (for 
example, If field #1 has a length of 30 characters, field #1 in every record will have a length of 30 
characters and if record #1 has a total length of 154 characters, all records will be this length). 
For common problems with the ASCII file format, see the previous question.

Question:

Can a comma-delimited file be used with MAILERS+4?

Answer:

Yes, when you open a comma-delimited file in MAILERS+4, you will be prompted to convert it to 
dBase format. When you are finished working on your file in MAILERS+4, you have the option of 
converting the file back to its original comma-delimited format.

It is important to note certain conventions when converting files from the comma-delimited for-
mat to the dBase format:

Any comma-delimited fields that are not enclosed in quotation marks will become numeric fields 
when converted to dBase. Since MAILERS+4 will not allow you to format numeric fields, make 
sure that all of the fields in your comma-delimited file are “Quote Enclosed” before importing 
them to MAILERS+4.

Field Formatting Questions
Question:

Is it necessary to format a separate Plus 4 field when using Address Check?

Answer:

Only if your main ZIP field is too short to hold the Plus 4. If you have a 10 character ZIP field, 
MAILERS+4 will add a hyphen and the Plus 4 to the ZIP field.

Question:

Is it necessary to format an Error field?

Answer:

The Error field is not required for any function in MAILERS+4. It is, however, highly recom-
mended that you do format the Error field(s). Error field(s) tell you which of your records could 
not be coded in Address Check, which records are duplicates in Duplicate Check, and why the 
other functions of MAILERS+4 could not include that record in their processing. Setting aside a 
single-character field for each of the program functions you use is a good way to keep track of 
errors in your file, while maintaining the integrity of your records.

Question:

Why am I unable to combine my split address fields when running Address Check?

Answer:
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You need to format an empty Delivery Address field so the program has a place to combine the 
separate portions of your split address. Make sure it is long enough for the separate compo-
nents of your address to fit into.

Question:

How do I get county information added to my file during Address Check?

Answer:

MAILERS+4 will output many fields of non-address data (such as County FIPS). This data is 
available on the Advanced Address Check Format screen. This is where you can format the 
various fields (including the county field) for the extra data that Address Check provides. Make 
sure that these fields are long enough for the data they must hold.

Presorting Questions
Question:

I need the NDC, SCF, and DDU (destination) discounts. How do I get them using MAILERS+4?

Answer:

Use the Destinations feature in the Presort function of MAILERS+4. This feature allows you to 
sort your mailing according to NDC, SCF, and DDU destinations.

Question:

The program is not giving me the CRRT sort results I thought I would get. Why is this?

Answer:

You MUST have enough pieces to qualify for that sortation. 

It is a good idea to check with the USPS or the Domestic Mail Manual concerning qualification 
regulations for the various sortation types. It is also possible that the local Post Office of mailing 
just doesn’t have the equipment to handle that type of sortation.

In addition, you must have a Carrier Route field formatted, and you must run Address Check. 
You should also format a Lot Order field and a Lot Number field if you are running eLOT.

Question:

Why are some of my 5-digit packages being put with the 3-digit packages?

Answer:

Presort will “borrow” from one package type to enable another package type to qualify for a 
lower rate. If a 5-digit container is required to be full, Presort will use mail from the 3-digit con-
tainer, if necessary, to fill the 5-digit container.
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Label Printing Questions
Question:

My printer isn’t listed under “Printer Name.” What printer should I select?

Answer:

If you are using a Dot Matrix or large scale Ink Jet printer, use the “Generic Text” driver or a 
printer type that emulates your printer. If you are using a Laser or small scale Ink Jet printer, use 
the “Windows” driver. The printer you are using to print your labels should be set as the default 
printer in your Windows Control Panel.

Question:

Why won’t MAILERS+4 print the bar code on my label?

Answer:

Check the setup for your printer. You must have a printer that is capable of printing graphics 
characters and it must be an IBM or Epson compatible printer. Also, your labels must be longer 
than three (3) inches, and your printer must be capable of printing a bar code with PCL 5 printer 
language.

Question:

Why is the bar code printing past the edge of the label?

Answer:

It is important to use a label that is wide enough for the bar code you are printing. If you are 
going to print a Delivery Point code, the label must be at least 3" wide for the bar code to fit.

Question:

How do I get the name and company to print on my labels?

Answer:

The fields that you wish to print must first be formatted. If they are not, you will not be able to 
use them in the Label Layout screen.
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APPENDIX

ADDRESS TYPE PERCENTAGES

Following is a breakdown of address types on the National and State levels. The numbers below 
are the percentage of each type of address in that category. 

NATIONAL ADDRESS TYPE PERCENTAGES 

ADDRESS TYPE PERCENTAGES BY STATE 

Street High Rise Firm Name PO Box Rural Route General

73.0 17.0 3.0 2.0 5.0 0.0

State Street High 
Rise

Firm 
Name

PO Box Rural 
Route

General

AL 85.5 6.0 1.5 1.0 6.0 0.0

AK 70.0 20.5 4.0 5.0 1.5 0.0

AZ 75.5 19.5 2.0 2.0 1.0 0.0

AR 83.0 6.0 1.0 1.0 9.0 0.0

CA 64.0 30.0 4.0 2.0 0.0 0.0

CO 77.0 19.0 2.0 2.0 0.0 0.0

CT 72.0 20.0 6.0 2.0 0.0 0.0

DE 70.0 13.0 4.0 2.0 11.0 0.0

DC 31.0 56.0 11.0 2.0 0.0 0.0

FL 75.0 20.0 2.0 1.0 2.0 0.0

GA 80.5 11.5 1.0 1.0 6.0 0.0

GU 75.0 12.0 1.0 11.0 1.0 0.0
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HI 46.0 45.0 4.0 4.0 1.0 0.0

ID 85.0 8.5 1.0 2.0 3.5 0.0

IL 69.0 21.0 3.0 1.0 6.0 0.0

IN 80.0 10.0 2.0 2.0 6.0 0.0

IA 79.0 10.0 1.5 1.5 8.0 0.0

KS 74.0 8.0 2.0 1.5 14.5 0.0

KY 77.5 13.0 3.0 2.0 4.5 0.0

LA 81.0 11.0 2.0 1.0 5.0 0.0

ME 60.0 17.0 3.5 3.0 16.5 0.0

MD 67.0 25.0 6.0 2.0 0.0 0.0

MA 72.0 21.0 5.0 2.0 0.0 0.0

MI 82.0 13.0 3.0 1.0 1.0 0.0

MN 69.0 13.0 3.0 2.0 13.0 0.0

MS 80.0 7.0 1.0 2.0 10.0 0.0

MO 72.5 10.0 2.0 1.0 14.5 0.0

MT 82.0 10.0 2.0 3.0 3.0 0.0

NE 69.0 7.0 2.0 2.0 20.0 0.0

NV 70.0 25.5 1.5 2.0 1.0 0.0

NH 71.0 15.0 3.0 3.5 7.5 0.0

NJ 71.0 21.0 5.0 2.0 1.0 0.0

NM 78.0 13.0 1.0 4.0 4.0 0.0

NY 46.0 43.0 5.0 2.0 4.0 0.0

NC 81.0 9.0 1.0 1.0 8.0 0.0

ND 71.5 11.0 1.0 2.0 14.5 0.0

OH 78.0 16.0 4.0 1.0 1.0 0.0

OK 69.0 9.5 3.0 1.5 17.0 0.0

OR 81.0 13.0 2.5 2.5 1.0 0.0

PA 71.0 12.0 4.0 3.0 10.0 0.0

State Street High 
Rise

Firm 
Name

PO Box Rural 
Route

General
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PR 67.0 22.0 1.0 4.0 6.0 0.0

RI 78.0 15.0 5.0 2.0 1.0 0.0

AS 0.0 0.0 0.0 99.0 0.0 1.0

SC 81.0 9.5 1.5 1.0 7.0 0.0

SD 63.0 8.0 1.0 2.0 26.0 0.0

TN 82.0 8.0 2.0 1.0 7.0 0.0

TX 76.0 14.0 2.0 1.0 7.0 0.0

UT 81.0 15.0 2.0 1.0 1.0 0.0

VT 49.0 10.0 3.0 5.0 33.0 1.0

VA 73.0 15.0 2.0 2.0 8.0 0.0

VI 46.5 34.5 0.0 13.0 6.0 0.0

WA 75.0 19.0 2.5 2.0 1.5 0.0

WV 63.0 8.0 2.5 5.0 21.5 0.0

WI 80.0 12.0 2.0 1.0 5.0 0.0

WY 80.0 11.0 1.0 5.0 3.0 0.0

PW 0.0 0.0 0.0 98.0 0.0 2.0

AA 100.0 0.0 0.0 0.0 0.0 0.0

AE 100.0 0.0 0.0 0.0 0.0 0.0

AP 100.0 0.0 0.0 0.0 0.0 0.0

State Street High 
Rise

Firm 
Name

PO Box Rural 
Route

General
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