Difference between revisions of "Contact Zone:Contact Verify Tutorial"

From Melissa Data Wiki
Jump to navigation Jump to search
 
(12 intermediate revisions by the same user not shown)
Line 1: Line 1:
{| class="mw-collapsible" cellspacing="2" style="background-color:#f9f9f9; border:1px solid #aaaaaa; font-size:9pt; color:#0645ad; padding:8px 8px;"
+
{{ContactZoneContactVerifyNav}}
! style="text-align:left; color:black; border-bottom:1px solid #aaaaaa;"|'''Contact Verify Navigation'''
 
|-
 
| style="padding-right:220px;"|
 
|-
 
|[[Contact Zone:Contact Verify Tutorial|Tutorial]]
 
|-
 
|
 
{| class="mw-collapsible mw-collapsed" style="width:100%;"
 
|- align="left"
 
! style="color:black;"|[[Contact Zone:Contact Verify:Component Settings|Component Settings]]
 
|-
 
|[[Contact Zone:Contact Verify:Component Settings#Show Details (On-Premise)|Show Details (On-Premise)]]
 
|-
 
|[[Contact Zone:Contact Verify:Component Settings#Show Details (Web)|Show Details (Web)]]
 
|}
 
|-
 
|
 
{| class="mw-collapsible mw-collapsed" style="width:100%;"
 
|- align="left"
 
! style="color:black;"|Contact Verify Tabs
 
|-
 
|[[Contact Zone:Contact Verify:Name|Name]]
 
|-
 
|[[Contact Zone:Contact Verify:Address|Address]]
 
|-
 
|[[Contact Zone:Contact Verify:GeoCode|GeoCode]]
 
|-
 
|[[Contact Zone:Contact Verify:Phone/Email|Phone/Email]]
 
|-
 
|[[Contact Zone:Contact Verify:Pass-Through Columns|Pass-Through Columns]]
 
|-
 
|[[Contact Zone:Contact Verify:Output Filter|Output Filter]]
 
|-
 
|[[Contact Zone:Contact Verify:Processing Options|Processing Options]]
 
|-
 
|[[Contact Zone:Contact Verify:Reporting|Reporting]]
 
|}
 
|-
 
|
 
{| class="mw-collapsible mw-collapsed" style="width:100%;"
 
|- align="left"
 
! style="color:black;"|[[Result Codes]]
 
|-
 
|[[Returned Result Codes:Enterprise Solutions#Contact Zone|Returned Result Codes]]
 
|}
 
|}
 
 
 
 
 
  
 
{{CustomTOC}}
 
{{CustomTOC}}
Line 54: Line 6:
  
 
==Component Settings==
 
==Component Settings==
Navigate to Tools > Melissa Data Settings > Components > Contact Verify
+
Navigate to Tools > Melissa Data Settings > Components > Contact Verify.
  
CZ_CV_Tutorial01.png
+
[[File:CZ_CV_ComponentSettings_Menu.png|link=]]
  
 
Set up the Contact Verify Component Settings. See [[Contact Zone:Contact Verify:Component Settings|Component Settings]].
 
Set up the Contact Verify Component Settings. See [[Contact Zone:Contact Verify:Component Settings|Component Settings]].
Line 64: Line 16:
 
To add Contact Verification to your project, drag the component onto the Data Flow screen. This will snap the Contact Verification Component into your workflow space.
 
To add Contact Verification to your project, drag the component onto the Data Flow screen. This will snap the Contact Verification Component into your workflow space.
  
CZ_CV_Tutorial02.png
+
[[File:CZ_CV_Tutorial_Component.png|link=]]
  
  
Line 70: Line 22:
 
Select a data flow source to be your input data. Many formats can be used as Sources, including Excel files, flat files or Access Input data sources. Connect this data source to the Contact Verification Component by dragging the arrow from your data flow source to the Contact Verification Component.
 
Select a data flow source to be your input data. Many formats can be used as Sources, including Excel files, flat files or Access Input data sources. Connect this data source to the Contact Verification Component by dragging the arrow from your data flow source to the Contact Verification Component.
  
CZ_CV_Tutorial03.png
+
[[File:CZ_CV_Tutorial_Source.png|link=]]
  
  
Line 76: Line 28:
 
Double click the Contact Verification Component to bring up the interface.
 
Double click the Contact Verification Component to bring up the interface.
  
 
==Map Columns==
 
 
===Name Tab===
 
===Name Tab===
 
Map the input and output fields for the Name tab.
 
Map the input and output fields for the Name tab.
  
CZ_CV_Tutorial04-01.png
+
[[File:CZ_CV_Name.png|link=]]
  
 
===Address Tab===
 
===Address Tab===
 
Select the existing field names using the dropdown box or create new ones. You can also set “Additional Input Columns” and “Additional Output Columns”
 
Select the existing field names using the dropdown box or create new ones. You can also set “Additional Input Columns” and “Additional Output Columns”
  
CZ_CV_Tutorial04-02.png
+
[[File:CZ_CV_Address.png|link=]]
  
 
===GeoCode Tab===
 
===GeoCode Tab===
 
Select the Source of Input Address radio button option. You can also set “Additional Output Columns”
 
Select the Source of Input Address radio button option. You can also set “Additional Output Columns”
  
CZ_CV_Tutorial04-03.png
+
[[File:CZ_CV_GeoCode.png|link=]]
  
 
===Phone/Email Tab===
 
===Phone/Email Tab===
 
Select the existing field names using the dropdown box or create new ones. You can also set “Additional Input Columns” and “Additional Output Columns”
 
Select the existing field names using the dropdown box or create new ones. You can also set “Additional Input Columns” and “Additional Output Columns”
  
CZ_CV_Tutorial04-04.png
+
[[File:CZ_CV_PhoneEmail.png|link=]]
  
 +
===Pass-Through Columns Tab===
 +
Click on “get fields”. You may choose which columns to pass through to the data file and which columns to filter out.
  
==Pass through Fields==
+
[[File:CZ_CV_PassThrough.png|link=]]
Click on “get fields”. You may choose which columns to pass through to the data file and which fields to filer out.
 
  
CZ_CV_Tutorial05.png
+
===Output Filter Tab===
 
 
 
 
==Output filter==
 
 
You can specify the filter from the drop down or you can also create your own custom filter.
 
You can specify the filter from the drop down or you can also create your own custom filter.
  
CZ_CV_Tutorial06.png
+
[[File:CZ_CV_OutputFilter.png|link=]]
  
 
+
===Processing Options Tab===
==Select Processing Options==
 
 
Select which Processing Mode you will use. Be sure to have your selected Processing Mode set up in the [[Contact Zone:Contact Verify:Component Settings|Component Settings]].
 
Select which Processing Mode you will use. Be sure to have your selected Processing Mode set up in the [[Contact Zone:Contact Verify:Component Settings|Component Settings]].
  
CZ_CV_Tutorial07.png
+
[[File:CZ_CV_ProcessingOptions.png|link=]]
 
 
  
==Choose Reporting Options==
+
===Reporting Tab===
 
Choose what reporting options you want.
 
Choose what reporting options you want.
  
CZ_CV_Tutorial08.png
+
[[File:CZ_CV_Reporting.png|link=]]
  
  
Line 126: Line 72:
 
Add data destinations for the downstream output. Connect the respective output filter pin to the output destination.
 
Add data destinations for the downstream output. Connect the respective output filter pin to the output destination.
  
CZ_CV_Tutorial09.png
+
[[File:CZ_CV_Tutorial_Output.png|link=]]
  
  
Line 132: Line 78:
 
Click File and select Save as to save the project.
 
Click File and select Save as to save the project.
  
CZ_CV_Tutorial10.png
+
[[File:CZ_Tutorial_Save.png|link=]]
  
  

Latest revision as of 00:58, 3 January 2017

← Contact Zone

Contact Verify Navigation
Overview
Tutorial
Component Settings
Show Details (On-Premise)
Show Details (Web)
Contact Verify Tabs
Name
Address
GeoCode
Phone/Email
Pass-Through Columns
Output Filter
Processing Options
Reporting
Result Codes



The following steps will guide you in the basic usage of Contact Verify for Contact Zone.

Component Settings

Navigate to Tools > Melissa Data Settings > Components > Contact Verify.

CZ CV ComponentSettings Menu.png

Set up the Contact Verify Component Settings. See Component Settings.


Add Component

To add Contact Verification to your project, drag the component onto the Data Flow screen. This will snap the Contact Verification Component into your workflow space.

CZ CV Tutorial Component.png


Connect Input

Select a data flow source to be your input data. Many formats can be used as Sources, including Excel files, flat files or Access Input data sources. Connect this data source to the Contact Verification Component by dragging the arrow from your data flow source to the Contact Verification Component.

CZ CV Tutorial Source.png


Configure Component

Double click the Contact Verification Component to bring up the interface.

Name Tab

Map the input and output fields for the Name tab.

CZ CV Name.png

Address Tab

Select the existing field names using the dropdown box or create new ones. You can also set “Additional Input Columns” and “Additional Output Columns”

CZ CV Address.png

GeoCode Tab

Select the Source of Input Address radio button option. You can also set “Additional Output Columns”

CZ CV GeoCode.png

Phone/Email Tab

Select the existing field names using the dropdown box or create new ones. You can also set “Additional Input Columns” and “Additional Output Columns”

CZ CV PhoneEmail.png

Pass-Through Columns Tab

Click on “get fields”. You may choose which columns to pass through to the data file and which columns to filter out.

CZ CV PassThrough.png

Output Filter Tab

You can specify the filter from the drop down or you can also create your own custom filter.

CZ CV OutputFilter.png

Processing Options Tab

Select which Processing Mode you will use. Be sure to have your selected Processing Mode set up in the Component Settings.

CZ CV ProcessingOptions.png

Reporting Tab

Choose what reporting options you want.

CZ CV Reporting.png


Connect Output

Add data destinations for the downstream output. Connect the respective output filter pin to the output destination.

CZ CV Tutorial Output.png


Save Settings

Click File and select Save as to save the project.

CZ Tutorial Save.png


Run Project

Now, the project is ready to run. It is possible to observe in real time as records flow from your input source through the Contact Verification Component and pipe output source depending on the filtering options.